summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2004-01-27 21:25:58 +0000
committerAlastair Tse <liquidx@gentoo.org>2004-01-27 21:25:58 +0000
commit21f59836995446b83028cff910d53fcb7b35131e (patch)
tree253508c8b1196810ef5e1b708c32f3e6d27b7dd2 /dev-libs
parentVersion bumped. (diff)
downloadgentoo-2-21f59836995446b83028cff910d53fcb7b35131e.tar.gz
gentoo-2-21f59836995446b83028cff910d53fcb7b35131e.tar.bz2
gentoo-2-21f59836995446b83028cff910d53fcb7b35131e.zip
add dev-lang/python dep. only build against current version of python. (#39347)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/newt/ChangeLog9
-rw-r--r--dev-libs/newt/files/digest-newt-0.50.35-r11
-rw-r--r--dev-libs/newt/newt-0.50.35-r1.ebuild29
-rw-r--r--dev-libs/newt/newt-0.50.35-r2.ebuild14
4 files changed, 16 insertions, 37 deletions
diff --git a/dev-libs/newt/ChangeLog b/dev-libs/newt/ChangeLog
index 020f74937258..c44c2cc18da9 100644
--- a/dev-libs/newt/ChangeLog
+++ b/dev-libs/newt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/newt
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/newt/ChangeLog,v 1.10 2003/08/11 19:56:42 wwoods Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/newt/ChangeLog,v 1.11 2004/01/27 21:25:58 liquidx Exp $
+
+ 27 Jan 2004; Alastair Tse <liquidx@gentoo.org> newt-0.50.35-r1.ebuild,
+ newt-0.50.35-r2.ebuild:
+ add dev-lang/python dep. only build against current version of
+ python. (#39347)
11 Aug 2003; Will Woods <wwoods@gentoo.org> newt-0.50.35-r1.ebuild,
newt-0.50.35-r2.ebuild:
diff --git a/dev-libs/newt/files/digest-newt-0.50.35-r1 b/dev-libs/newt/files/digest-newt-0.50.35-r1
deleted file mode 100644
index ac9ded732f82..000000000000
--- a/dev-libs/newt/files/digest-newt-0.50.35-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 87a0555f83473a67a848a11c99dd7755 newt-0.50.35.tar.gz 106345
diff --git a/dev-libs/newt/newt-0.50.35-r1.ebuild b/dev-libs/newt/newt-0.50.35-r1.ebuild
deleted file mode 100644
index 7727fdd66d7b..000000000000
--- a/dev-libs/newt/newt-0.50.35-r1.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/newt/newt-0.50.35-r1.ebuild,v 1.4 2003/08/11 19:56:42 wwoods Exp $
-
-S=${WORKDIR}/${P}
-DESCRIPTION="redhat's newt windowing toolkit development files"
-SRC_URI="http://koto.mynetix.de/gentoo/${P}.tar.gz"
-HOMEPAGE="http://www.redhat.com"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86 ppc sparc amd64 alpha"
-
-DEPEND=">=sys-libs/slang-1.4
- >=dev-libs/popt-1.6"
-
-RDEPEND=""
-
-src_compile() {
- econf || die
- make || die "make failure"
-}
-
-src_install () {
- make prefix=${D}/usr install || die "make install failed"
- dodoc CHANGES COPYING peanuts.py popcorn.py tutorial.sgml
- cd /usr/lib
- ln -s libnewt.so.${PV} libnewt.so.0.50
-}
diff --git a/dev-libs/newt/newt-0.50.35-r2.ebuild b/dev-libs/newt/newt-0.50.35-r2.ebuild
index ccb555b9ef16..b7f330b1f470 100644
--- a/dev-libs/newt/newt-0.50.35-r2.ebuild
+++ b/dev-libs/newt/newt-0.50.35-r2.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/newt/newt-0.50.35-r2.ebuild,v 1.7 2003/08/11 19:56:42 wwoods Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/newt/newt-0.50.35-r2.ebuild,v 1.8 2004/01/27 21:25:58 liquidx Exp $
+
+inherit python
S=${WORKDIR}/${P}
DESCRIPTION="redhat's newt windowing toolkit development files"
@@ -12,17 +14,19 @@ LICENSE="GPL-2"
KEYWORDS="x86 ppc sparc hppa amd64 alpha"
DEPEND=">=sys-libs/slang-1.4
- >=dev-libs/popt-1.6"
+ >=dev-libs/popt-1.6
+ dev-lang/python"
RDEPEND=""
src_compile() {
+ python_version
econf || die
- make || die "make failure"
+ make PYTHONVERS=python${PYVER} || die "make failure"
}
src_install () {
- make prefix=${D}/usr install || die "make install failed"
+ make prefix=${D}/usr PYTHONVERS=python${PYVER} install || die "make install failed"
dodoc CHANGES COPYING peanuts.py popcorn.py tutorial.sgml
dosym libnewt.so.${PV} /usr/lib/libnewt.so.0.50
}