summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2010-09-27 18:56:54 +0000
committerThomas Sachau <tommy@gentoo.org>2010-09-27 18:56:54 +0000
commit2bd2528e0dc98dabb07e3d41df89c763c2b8fb9c (patch)
tree7e97da2487f72bcf871e3fb85a0d210c9d6052fd /dev-libs
parentAdded dev-php5/pecl-cairo-0.2.0 (diff)
downloadgentoo-2-2bd2528e0dc98dabb07e3d41df89c763c2b8fb9c.tar.gz
gentoo-2-2bd2528e0dc98dabb07e3d41df89c763c2b8fb9c.tar.bz2
gentoo-2-2bd2528e0dc98dabb07e3d41df89c763c2b8fb9c.zip
Revision bump for libtomcrypt, fixes a compile- and runtime-failure with net-p2p/fms
(Portage version: 2.2_rc87-r1/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libtomcrypt/ChangeLog9
-rw-r--r--dev-libs/libtomcrypt/libtomcrypt-1.17-r5.ebuild53
2 files changed, 61 insertions, 1 deletions
diff --git a/dev-libs/libtomcrypt/ChangeLog b/dev-libs/libtomcrypt/ChangeLog
index 7d39a151d928..3af0b0028894 100644
--- a/dev-libs/libtomcrypt/ChangeLog
+++ b/dev-libs/libtomcrypt/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/libtomcrypt
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libtomcrypt/ChangeLog,v 1.41 2010/09/19 04:37:17 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libtomcrypt/ChangeLog,v 1.42 2010/09/27 18:56:54 tommy Exp $
+
+*libtomcrypt-1.17-r5 (27 Sep 2010)
+
+ 27 Sep 2010; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
+ +libtomcrypt-1.17-r5.ebuild:
+ Revision bump for libtomcrypt, fixes a compile- and runtime-failure with
+ net-p2p/fms
19 Sep 2010; Jeroen Roovers <jer@gentoo.org>
files/libtomcrypt-1.06-makefile.diff,
diff --git a/dev-libs/libtomcrypt/libtomcrypt-1.17-r5.ebuild b/dev-libs/libtomcrypt/libtomcrypt-1.17-r5.ebuild
new file mode 100644
index 000000000000..5bf761371dbf
--- /dev/null
+++ b/dev-libs/libtomcrypt/libtomcrypt-1.17-r5.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libtomcrypt/libtomcrypt-1.17-r5.ebuild,v 1.1 2010/09/27 18:56:54 tommy Exp $
+
+EAPI="2"
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="modular and portable cryptographic toolkit"
+HOMEPAGE="http://libtom.org/?page=features&whatfile=crypt"
+SRC_URI="http://libtom.org/files/crypt-${PV}.tar.bz2"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc libtommath tomsfastmath"
+
+RDEPEND="libtommath? ( dev-libs/libtommath )
+ tomsfastmath? ( >=dev-libs/tomsfastmath-0.12 )
+ !libtommath? ( !tomsfastmath? ( dev-libs/libtommath ) )"
+DEPEND="${RDEPEND}
+ doc? ( virtual/latex-base app-text/ghostscript-gpl )"
+
+src_prepare() {
+ use doc || sed -i '/^install:/s:docs::' makefile
+ epatch "${FILESDIR}"/libtomcrypt-1.17-r2-libtool-tag-and-make-fix.patch
+ sed -i \
+ -e "s:--mode=link gcc:--mode=link $(tc-getCC) ${LDFLAGS} --tag CC $(tc-getCC):g" \
+ -e "s: gcc: $(tc-getCC):g" \
+ {,testprof/}makefile.shared || die
+}
+
+src_compile() {
+ local extraflags=""
+ use libtommath && append-flags -DLTM_DESC && extraflags="-ltommath"
+ use tomsfastmath && append-flags -DTFM_DESC && extraflags="${extraflags} -ltfm"
+ EXTRALIBS="${extraflags}" \
+ CC=$(tc-getCC) \
+ IGNORE_SPEED=1 \
+ emake -f makefile.shared \
+ || die "emake failed"
+}
+
+src_install() {
+ emake -f makefile.shared DESTDIR="${D}" install ||\
+ die "emake install failed"
+ dodoc TODO changes || die "dodoc failed"
+ if use doc ; then
+ dodoc doc/* || die "dodoc failed"
+ docinto notes ; dodoc notes/* || die "dodoc failed"
+ docinto demos ; dodoc demos/* || die "dodoc failed"
+ fi
+}