summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2013-08-25 18:37:15 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2013-08-25 18:37:15 +0000
commit2d3429f7fc629667fdd074a0a122804bf4a62490 (patch)
tree16c2bd7cfc9a40aed04923d63bc6afe0a916988b /dev-libs
parentVersion bump. (diff)
downloadgentoo-2-2d3429f7fc629667fdd074a0a122804bf4a62490.tar.gz
gentoo-2-2d3429f7fc629667fdd074a0a122804bf4a62490.tar.bz2
gentoo-2-2d3429f7fc629667fdd074a0a122804bf4a62490.zip
Version bump.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libgee/ChangeLog7
-rw-r--r--dev-libs/libgee/libgee-0.10.4.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/dev-libs/libgee/ChangeLog b/dev-libs/libgee/ChangeLog
index 4abbf163d263..34cfad47f17e 100644
--- a/dev-libs/libgee/ChangeLog
+++ b/dev-libs/libgee/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libgee
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgee/ChangeLog,v 1.75 2013/08/01 18:55:10 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgee/ChangeLog,v 1.76 2013/08/25 18:37:15 eva Exp $
+
+*libgee-0.10.4 (25 Aug 2013)
+
+ 25 Aug 2013; Gilles Dartiguelongue <eva@gentoo.org> +libgee-0.10.4.ebuild:
+ Version bump.
*libgee-0.10.3 (01 Aug 2013)
diff --git a/dev-libs/libgee/libgee-0.10.4.ebuild b/dev-libs/libgee/libgee-0.10.4.ebuild
new file mode 100644
index 000000000000..4c47611cb137
--- /dev/null
+++ b/dev-libs/libgee/libgee-0.10.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgee/libgee-0.10.4.ebuild,v 1.1 2013/08/25 18:37:15 eva Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="GObject-based interfaces and classes for commonly used data structures"
+HOMEPAGE="https://wiki.gnome.org/Libgee"
+
+LICENSE="LGPL-2.1+"
+SLOT="0.8"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-linux"
+IUSE="+introspection"
+
+# FIXME: add doc support, requires valadoc
+RDEPEND="
+ >=dev-libs/glib-2.32:2
+ introspection? ( >=dev-libs/gobject-introspection-0.9.6:= )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog* MAINTAINERS NEWS README"
+ gnome2_src_configure \
+ $(use_enable introspection)
+ VALAC="$(type -P false)"
+}