summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2008-11-13 20:46:28 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2008-11-13 20:46:28 +0000
commit42fb39806ed9921adcd0dde86466dd235da23db1 (patch)
treeef74d20f96adec625466336e37f5c007c1715037 /dev-libs
parentVersion bumb (diff)
downloadgentoo-2-42fb39806ed9921adcd0dde86466dd235da23db1.tar.gz
gentoo-2-42fb39806ed9921adcd0dde86466dd235da23db1.tar.bz2
gentoo-2-42fb39806ed9921adcd0dde86466dd235da23db1.zip
Make it build with bison-2.4; bug #246262
(Portage version: 2.2_rc14/cvs/Linux 2.6.27-gentoo-r2 x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libIDL/ChangeLog6
-rw-r--r--dev-libs/libIDL/files/libIDL-0.8.11-bison-2.4.patch21
-rw-r--r--dev-libs/libIDL/libIDL-0.8.11.ebuild4
3 files changed, 29 insertions, 2 deletions
diff --git a/dev-libs/libIDL/ChangeLog b/dev-libs/libIDL/ChangeLog
index 6648557f3c8c..0f238ddd0b59 100644
--- a/dev-libs/libIDL/ChangeLog
+++ b/dev-libs/libIDL/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/libIDL
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libIDL/ChangeLog,v 1.97 2008/11/12 21:11:28 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libIDL/ChangeLog,v 1.98 2008/11/13 20:46:28 dang Exp $
+
+ 13 Nov 2008; Daniel Gryniewicz <dang@gentoo.org>
+ +files/libIDL-0.8.11-bison-2.4.patch, libIDL-0.8.11.ebuild:
+ Make it build with bison-2.4; bug #246262
12 Nov 2008; Brent Baude <ranger@gentoo.org> libIDL-0.8.11.ebuild:
stable ppc64, bug 246058
diff --git a/dev-libs/libIDL/files/libIDL-0.8.11-bison-2.4.patch b/dev-libs/libIDL/files/libIDL-0.8.11-bison-2.4.patch
new file mode 100644
index 000000000000..25dbf1e89d63
--- /dev/null
+++ b/dev-libs/libIDL/files/libIDL-0.8.11-bison-2.4.patch
@@ -0,0 +1,21 @@
+diff --exclude-from=/home/dang/.scripts/diffrc -up -ruN libIDL-0.8.11.orig/parser.y libIDL-0.8.11/parser.y
+--- libIDL-0.8.11.orig/parser.y 2007-01-01 18:41:34.000000000 -0500
++++ libIDL-0.8.11/parser.y 2008-11-13 15:31:13.000000000 -0500
+@@ -607,7 +607,7 @@ struct_type: z_props TOK_STRUCT
+ { $<str>$ = "struct"; }
+ z_new_scope_catch '{' {
+ g_hash_table_insert (__IDL_structunion_ht, $4, $4);
+- $$ = IDL_type_struct_new ($4, NULL);
++ $<tree>$ = IDL_type_struct_new ($4, NULL);
+ } member_list
+ '}' pop_scope {
+ g_hash_table_remove (__IDL_structunion_ht, $4);
+@@ -624,7 +624,7 @@ union_type: z_props TOK_UNION
+ switch_type_spec
+ ')' '{' {
+ g_hash_table_insert (__IDL_structunion_ht, $4, $4);
+- $$ = IDL_type_union_new ($4, $7, NULL);
++ $<tree>$ = IDL_type_union_new ($4, $7, NULL);
+ } switch_body
+ '}' pop_scope {
+ g_hash_table_remove (__IDL_structunion_ht, $4);
diff --git a/dev-libs/libIDL/libIDL-0.8.11.ebuild b/dev-libs/libIDL/libIDL-0.8.11.ebuild
index 4148d48531c9..230e02f0c501 100644
--- a/dev-libs/libIDL/libIDL-0.8.11.ebuild
+++ b/dev-libs/libIDL/libIDL-0.8.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libIDL/libIDL-0.8.11.ebuild,v 1.5 2008/11/12 21:11:28 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libIDL/libIDL-0.8.11.ebuild,v 1.6 2008/11/13 20:46:28 dang Exp $
inherit eutils gnome2
@@ -23,4 +23,6 @@ DOCS="AUTHORS BUGS ChangeLog HACKING MAINTAINERS NEWS README"
src_unpack() {
gnome2_src_unpack
epunt_cxx
+
+ epatch "${FILESDIR}"/${P}-bison-2.4.patch
}