summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2014-01-24 20:18:05 +0000
committerMatt Turner <mattst88@gentoo.org>2014-01-24 20:18:05 +0000
commit4e1f6ba2c3fb421b9fcf4b366984d0394196e4a0 (patch)
treeba30cd174ee1d9795f5c6ebe447fdf699b99e2a0 /dev-libs
parentEAPI bump (diff)
downloadgentoo-2-4e1f6ba2c3fb421b9fcf4b366984d0394196e4a0.tar.gz
gentoo-2-4e1f6ba2c3fb421b9fcf4b366984d0394196e4a0.tar.bz2
gentoo-2-4e1f6ba2c3fb421b9fcf4b366984d0394196e4a0.zip
Version bump to 1.4.0.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 974CA72A)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/wayland/ChangeLog9
-rw-r--r--dev-libs/wayland/wayland-1.4.0.ebuild57
2 files changed, 64 insertions, 2 deletions
diff --git a/dev-libs/wayland/ChangeLog b/dev-libs/wayland/ChangeLog
index 20378f4ae175..b9685be9bf4f 100644
--- a/dev-libs/wayland/ChangeLog
+++ b/dev-libs/wayland/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/wayland
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/wayland/ChangeLog,v 1.32 2013/12/31 18:23:49 mattst88 Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/wayland/ChangeLog,v 1.33 2014/01/24 20:18:05 mattst88 Exp $
+
+*wayland-1.4.0 (24 Jan 2014)
+
+ 24 Jan 2014; Matt Turner <mattst88@gentoo.org> +wayland-1.4.0.ebuild:
+ Version bump to 1.4.0.
*wayland-1.3.0 (31 Dec 2013)
diff --git a/dev-libs/wayland/wayland-1.4.0.ebuild b/dev-libs/wayland/wayland-1.4.0.ebuild
new file mode 100644
index 000000000000..1fbcabf4aa90
--- /dev/null
+++ b/dev-libs/wayland/wayland-1.4.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/wayland/wayland-1.4.0.ebuild,v 1.1 2014/01/24 20:18:05 mattst88 Exp $
+
+EAPI=5
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="git://anongit.freedesktop.org/git/${PN}/${PN}"
+ GIT_ECLASS="git-r3"
+ EXPERIMENTAL="true"
+ AUTOTOOLS_AUTORECONF=1
+fi
+
+inherit autotools-multilib toolchain-funcs $GIT_ECLASS
+
+DESCRIPTION="Wayland protocol libraries"
+HOMEPAGE="http://wayland.freedesktop.org/"
+
+if [[ $PV = 9999* ]]; then
+ SRC_URI="${SRC_PATCHES}"
+ KEYWORDS=""
+else
+ SRC_URI="http://wayland.freedesktop.org/releases/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="doc"
+
+RDEPEND="dev-libs/expat[${MULTILIB_USEDEP}]
+ virtual/libffi[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable doc documentation)
+ )
+ if tc-is-cross-compiler ; then
+ myeconfargs+=( --disable-scanner )
+ fi
+ if ! multilib_build_binaries; then
+ myeconfargs+=( --disable-documentation )
+ fi
+
+ autotools-multilib_src_configure
+}
+
+src_test() {
+ export XDG_RUNTIME_DIR="${T}/runtime-dir"
+ mkdir "${XDG_RUNTIME_DIR}" || die
+ chmod 0700 "${XDG_RUNTIME_DIR}" || die
+
+ autotools-multilib_src_test
+}