summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-30 23:32:35 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-30 23:32:35 +0000
commit6ce71afd08891b73c2de2b5cfb731e4a4b8897f9 (patch)
treefb1043257c6c1a7218f2eecf4b78b7a486e58f25 /dev-libs
parentUse Python 2 (bug #315819). (diff)
downloadgentoo-2-6ce71afd08891b73c2de2b5cfb731e4a4b8897f9.tar.gz
gentoo-2-6ce71afd08891b73c2de2b5cfb731e4a4b8897f9.tar.bz2
gentoo-2-6ce71afd08891b73c2de2b5cfb731e4a4b8897f9.zip
Set SUPPORT_PYTHON_ABIS (bug #361179).
(Portage version: 2.2.0_alpha29_p4/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libpreludedb/ChangeLog6
-rw-r--r--dev-libs/libpreludedb/libpreludedb-1.0.0-r1.ebuild56
2 files changed, 55 insertions, 7 deletions
diff --git a/dev-libs/libpreludedb/ChangeLog b/dev-libs/libpreludedb/ChangeLog
index a8b723b176ee..c2eac863d2c4 100644
--- a/dev-libs/libpreludedb/ChangeLog
+++ b/dev-libs/libpreludedb/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/libpreludedb
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpreludedb/ChangeLog,v 1.48 2011/01/10 20:51:47 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpreludedb/ChangeLog,v 1.49 2011/03/30 23:32:35 arfrever Exp $
+
+ 30 Mar 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ libpreludedb-1.0.0-r1.ebuild:
+ Set SUPPORT_PYTHON_ABIS (bug #361179).
10 Jan 2011; Thomas Kahle <tomka@gentoo.org> libpreludedb-0.9.2.ebuild,
libpreludedb-0.9.13.ebuild:
diff --git a/dev-libs/libpreludedb/libpreludedb-1.0.0-r1.ebuild b/dev-libs/libpreludedb/libpreludedb-1.0.0-r1.ebuild
index a41be84f4945..cbce9a97e028 100644
--- a/dev-libs/libpreludedb/libpreludedb-1.0.0-r1.ebuild
+++ b/dev-libs/libpreludedb/libpreludedb-1.0.0-r1.ebuild
@@ -1,10 +1,13 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpreludedb/libpreludedb-1.0.0-r1.ebuild,v 1.2 2010/06/17 21:33:54 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libpreludedb/libpreludedb-1.0.0-r1.ebuild,v 1.3 2011/03/30 23:32:35 arfrever Exp $
-EAPI="2"
+EAPI="3"
+PYTHON_DEPEND="python? 2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
-inherit eutils flag-o-matic perl-module
+inherit autotools distutils eutils perl-module
DESCRIPTION="Prelude-IDS framework for easy access to the Prelude database"
HOMEPAGE="http://www.prelude-technologies.com"
@@ -22,8 +25,24 @@ RDEPEND=">=dev-libs/libprelude-0.9.9
DEPEND="${RDEPEND}
doc? ( dev-util/gtk-doc )"
+PYTHON_MODNAME="preludedb.py"
+
+pkg_setup() {
+ if use python; then
+ python_pkg_setup
+ fi
+}
+
src_prepare() {
epatch "${FILESDIR}"/${P}-ldflags.patch
+
+ # Python bindings are built/installed manually.
+ sed \
+ -e "s/^python: python-build/python:/" \
+ -e "/cd python && \$(PYTHON) setup.py install/d" \
+ -i bindings/Makefile.am || die "sed failed"
+
+ eautoreconf
}
src_configure() {
@@ -36,8 +55,17 @@ src_configure() {
$(use_with sqlite sqlite3) \
$(use_with perl) \
$(use_with swig) \
- $(use_with python) \
- || die "econf failed"
+ $(use_with python)
+}
+
+src_compile() {
+ default
+
+ if use python; then
+ pushd bindings/python > /dev/null
+ distutils_src_compile
+ popd > /dev/null
+ fi
}
src_install() {
@@ -47,9 +75,25 @@ src_install() {
perl_delete_localpod
perl_delete_packlist
fi
+
+ if use python; then
+ pushd bindings/python > /dev/null
+ distutils_src_install
+ popd > /dev/null
+ fi
}
pkg_postinst() {
+ if use python; then
+ distutils_pkg_postinst
+ fi
+
elog "For additional installation instructions go to"
elog "https://trac.prelude-ids.org/wiki/InstallingLibpreludedb"
}
+
+pkg_postrm() {
+ if use python; then
+ distutils_pkg_postrm
+ fi
+}