summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-08-26 20:41:56 +0000
committerAchim Gottinger <achim@gentoo.org>2000-08-26 20:41:56 +0000
commit7554db96a47b45a414f9747e84339da3177a84ca (patch)
tree15824a41e415a940229efb1f1375572f4f587b62 /dev-libs
parent*** empty log message *** (diff)
downloadgentoo-2-7554db96a47b45a414f9747e84339da3177a84ca.tar.gz
gentoo-2-7554db96a47b45a414f9747e84339da3177a84ca.tar.bz2
gentoo-2-7554db96a47b45a414f9747e84339da3177a84ca.zip
*** empty log message ***
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libole2/files/digest-libole2-0.1.61
-rw-r--r--dev-libs/libole2/libole2-0.1.6.ebuild31
-rw-r--r--dev-libs/rep-gtk/rep-gtk-0.13a.ebuild32
3 files changed, 64 insertions, 0 deletions
diff --git a/dev-libs/libole2/files/digest-libole2-0.1.6 b/dev-libs/libole2/files/digest-libole2-0.1.6
new file mode 100644
index 000000000000..2a6b611f8525
--- /dev/null
+++ b/dev-libs/libole2/files/digest-libole2-0.1.6
@@ -0,0 +1 @@
+MD5 507412fa80ffb3912320bd2e582db2eb libole2-0.1.6.tar.gz
diff --git a/dev-libs/libole2/libole2-0.1.6.ebuild b/dev-libs/libole2/libole2-0.1.6.ebuild
new file mode 100644
index 000000000000..a8c3de08cd9c
--- /dev/null
+++ b/dev-libs/libole2/libole2-0.1.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header
+
+P=libole2-0.1.6
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="libole2"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/unstable/sources/libole2/${A}"
+HOMEPAGE="http://www.gnome.org/"
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+ cd ${S}
+ ./configure --host=${CHOST} --prefix=/opt/gnome --with-catgets
+ make
+}
+
+src_install() {
+ cd ${S}
+ make prefix=${D}/opt/gnome install
+
+ dodoc AUTHORS COPYING ChangeLog NEWS README* TODO
+}
+
+
+
diff --git a/dev-libs/rep-gtk/rep-gtk-0.13a.ebuild b/dev-libs/rep-gtk/rep-gtk-0.13a.ebuild
new file mode 100644
index 000000000000..8090f09fc68b
--- /dev/null
+++ b/dev-libs/rep-gtk/rep-gtk-0.13a.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/rep-gtk/rep-gtk-0.13a.ebuild,v 1.1 2000/08/26 20:41:55 achim Exp $
+
+P=rep-gtk-0.13a
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="GTK/GDK bindings for the librep Lisp environment"
+SRC_URI="ftp://rep-gtk.sourceforge.net/pub/rep-gtk/"${A}
+HOMEPAGE="http://rep-gtk.sourceforge.net/"
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+ cd ${S}
+ ./configure --host=${CHOST} --with-gnome --with-libglade
+ make
+}
+
+src_install() {
+ cd ${S}
+ make DESTDIR=${D} install
+ dodoc AUTHORS BUGS COPYING ChangeLog README* TODO
+ docinto examples
+ dodoc examples/*
+}
+
+
+