summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2012-12-13 17:23:44 +0000
committerSergey Popov <pinkbyte@gentoo.org>2012-12-13 17:23:44 +0000
commit9240c10b826d0b9001aaa3f3f2dfc4641456faf3 (patch)
treee0731fdd889143859d3bdc3d2d0c6ddda2c47808 /dev-libs
parentAdd missing 'die' statement, stable on amd64 wrt bug #441510 (diff)
downloadgentoo-2-9240c10b826d0b9001aaa3f3f2dfc4641456faf3.tar.gz
gentoo-2-9240c10b826d0b9001aaa3f3f2dfc4641456faf3.tar.bz2
gentoo-2-9240c10b826d0b9001aaa3f3f2dfc4641456faf3.zip
Version bump
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/jthread/ChangeLog7
-rw-r--r--dev-libs/jthread/jthread-1.3.1.ebuild25
2 files changed, 31 insertions, 1 deletions
diff --git a/dev-libs/jthread/ChangeLog b/dev-libs/jthread/ChangeLog
index 8b3ca1c2ce49..1fbeb2b00e98 100644
--- a/dev-libs/jthread/ChangeLog
+++ b/dev-libs/jthread/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/jthread
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/jthread/ChangeLog,v 1.11 2012/12/04 15:36:35 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/jthread/ChangeLog,v 1.12 2012/12/13 17:23:44 pinkbyte Exp $
+
+*jthread-1.3.1 (13 Dec 2012)
+
+ 13 Dec 2012; Sergey Popov <pinkbyte@gentoo.org> +jthread-1.3.1.ebuild:
+ Version bump
04 Dec 2012; <ago@gentoo.org> jthread-1.2.1.ebuild:
Stable for x86, wrt bug #444304
diff --git a/dev-libs/jthread/jthread-1.3.1.ebuild b/dev-libs/jthread/jthread-1.3.1.ebuild
new file mode 100644
index 000000000000..5b662cbdad22
--- /dev/null
+++ b/dev-libs/jthread/jthread-1.3.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/jthread/jthread-1.3.1.ebuild,v 1.1 2012/12/13 17:23:44 pinkbyte Exp $
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="JThread provides some classes to make use of threads easy on different platforms."
+HOMEPAGE="http://research.edm.uhasselt.be/~jori/page/index.php?n=CS.Jthread"
+SRC_URI="http://research.edm.uhasselt.be/jori/${PN}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+DOCS=( ChangeLog README.TXT TODO doc/manual.tex )
+
+src_prepare() {
+ # do not build static library, if it is not requested
+ if ! use static-libs; then
+ sed -i -e '/jthread-static/d' src/CMakeLists.txt || die 'sed on src/CMakeLists.txt failed'
+ fi
+}