summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2012-12-14 21:45:32 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2012-12-14 21:45:32 +0000
commitb449510c1bc72152d9d99112f5c78b13758dbcd6 (patch)
tree8f775756afe42127db134509b1aaa0086c5e8e17 /dev-libs
parentAdd regexp-UofT to MISC-FREE license group. (diff)
downloadgentoo-2-b449510c1bc72152d9d99112f5c78b13758dbcd6.tar.gz
gentoo-2-b449510c1bc72152d9d99112f5c78b13758dbcd6.tar.bz2
gentoo-2-b449510c1bc72152d9d99112f5c78b13758dbcd6.zip
bug#405525 add support for USE static-libs
(Portage version: 2.2.0_alpha148/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/nettle/ChangeLog8
-rw-r--r--dev-libs/nettle/files/nettle-2.5-static-libs.patch108
-rw-r--r--dev-libs/nettle/nettle-2.5-r1.ebuild35
3 files changed, 150 insertions, 1 deletions
diff --git a/dev-libs/nettle/ChangeLog b/dev-libs/nettle/ChangeLog
index d67f61ceda14..a341a0249c7f 100644
--- a/dev-libs/nettle/ChangeLog
+++ b/dev-libs/nettle/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/nettle
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/nettle/ChangeLog,v 1.70 2012/10/20 16:40:22 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/nettle/ChangeLog,v 1.71 2012/12/14 21:45:31 alonbl Exp $
+
+*nettle-2.5-r1 (14 Dec 2012)
+
+ 14 Dec 2012; <alonbl@gentoo.org> +files/nettle-2.5-static-libs.patch,
+ +nettle-2.5-r1.ebuild:
+ bug#405525 add support for USE static-libs
20 Oct 2012; Raúl Porcel <armin76@gentoo.org> nettle-2.5.ebuild:
alpha/ia64/s390/sh/sparc stable wrt #433235
diff --git a/dev-libs/nettle/files/nettle-2.5-static-libs.patch b/dev-libs/nettle/files/nettle-2.5-static-libs.patch
new file mode 100644
index 000000000000..4434d582dce5
--- /dev/null
+++ b/dev-libs/nettle/files/nettle-2.5-static-libs.patch
@@ -0,0 +1,108 @@
+From c4a57cf2b0ebf3b99309f40cfa1c5107ae038d84 Mon Sep 17 00:00:00 2001
+From: Alon Bar-Lev <alon.barlev@gmail.com>
+Date: Fri, 14 Dec 2012 23:31:10 +0200
+Subject: [PATCH] build: add --enable-static option
+
+Gentoo bug#405525, support not installing static libraries.
+
+Signed-off-by: Alon Bar-Lev <alon.barlev@gmail.com>
+---
+ Makefile.in | 16 ++++++++++------
+ configure.ac | 12 ++++++++++++
+ 2 files changed, 22 insertions(+), 6 deletions(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index be0de3c..d4a2a7d 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -21,7 +21,11 @@ include config.make
+ PRE_CPPFLAGS = -I.
+ # FIXME: Add configuration of LIBEXT?
+ LIBTARGETS = libnettle.a @IF_HOGWEED@ libhogweed.a
+-SHLIBTARGETS = $(LIBNETTLE_FORLINK) @IF_HOGWEED@ $(LIBHOGWEED_FORLINK)
++@IF_STATIC@INSTALL_LIBTARGETS = install-static
++@IF_STATIC@UNINSTALL_LIBTARGETS = uninstall-static
++@IF_SHARED@SHLIBTARGETS = $(LIBNETTLE_FORLINK) @IF_HOGWEED@ $(LIBHOGWEED_FORLINK)
++@IF_SHARED@INSTALL_SHLIBTARGETS = install-shared-nettle @IF_HOGWEED@ install-shared-hogweed
++@IF_SHARED@UNINSTALL_SHLIBTARGETS = uninstall-shared
+
+ getopt_SOURCES = getopt.c getopt1.c
+ getopt_TARGETS = $(getopt_SOURCES:.c=.$(OBJEXT))
+@@ -32,7 +36,7 @@ internal_TARGETS = $(internal_SOURCES:.c=.$(OBJEXT))
+ TARGETS = aesdata$(EXEEXT) desdata$(EXEEXT) twofishdata$(EXEEXT) \
+ shadata$(EXEEXT) gcmdata$(EXEEXT) \
+ $(getopt_TARGETS) $(internal_TARGETS) \
+- $(LIBTARGETS) @IF_SHARED@ $(SHLIBTARGETS)
++ $(LIBTARGETS) $(SHLIBTARGETS)
+ IMPLICIT_TARGETS = @IF_DLL@ $(LIBNETTLE_FILE) $(LIBHOGWEED_FILE)
+
+ DOCTARGETS = nettle.info nettle.html nettle.pdf
+@@ -302,8 +306,8 @@ hogweed.pc: hogweed.pc.in config.status
+ ./config.status $@
+
+ # Installation
+-install-here: install-info install-headers install-static install-pkgconfig \
+- @IF_SHARED@ install-shared-nettle @IF_HOGWEED@ install-shared-hogweed
++install-here: install-info install-headers install-pkgconfig \
++ $(INSTALL_LIBTARGETS) $(INSTALL_SHLIBTARGETS)
+
+ install-static: $(LIBTARGETS)
+ $(MKDIR_P) $(DESTDIR)$(libdir)
+@@ -369,8 +373,8 @@ install-pkgconfig: $(PKGCONFIG_FILES)
+ done
+
+ # Uninstall
+-uninstall-here: uninstall-info uninstall-headers uninstall-static \
+- uninstall-pkgconfig @IF_SHARED@ uninstall-shared
++uninstall-here: uninstall-info uninstall-headers uninstall-pkgconfig \
++ $(UNINSTALL_LIBTARGETS) $(UNINSTALL_SHLIBTARGETS)
+
+ uninstall-static:
+ for f in $(LIBTARGETS) ; do \
+diff --git a/configure.ac b/configure.ac
+index 6bf2b8b..994ee75 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -43,6 +43,10 @@ AC_ARG_ENABLE(assembler,
+ AC_HELP_STRING([--disable-assembler],[Disable assembler code]),,
+ [enable_assembler=yes])
+
++AC_ARG_ENABLE(static,
++ AC_HELP_STRING([--disable-static], [Do not build any static library]),,
++ [enable_static=yes])
++
+ AC_ARG_ENABLE(shared,
+ AC_HELP_STRING([--disable-shared], [Do not build any shared library]),,
+ [enable_shared=yes])
+@@ -566,6 +570,12 @@ else
+ IF_HOGWEED='#'
+ fi
+
++if test "x$enable_static" = xyes ; then
++ IF_STATIC=''
++else
++ IF_STATIC='#'
++fi
++
+ if test "x$enable_shared" = xyes ; then
+ IF_SHARED=''
+ else
+@@ -573,6 +583,7 @@ else
+ fi
+
+ AC_SUBST(IF_HOGWEED)
++AC_SUBST(IF_STATIC)
+ AC_SUBST(IF_SHARED)
+ AC_SUBST(IF_DLL)
+
+@@ -654,6 +665,7 @@ AC_MSG_NOTICE([summary of build options:
+ Install prefix: ${prefix}
+ Library directory: ${libdir}
+ Compiler: ${CC}
++ Static libraries: ${enable_static}
+ Shared libraries: ${enable_shared}
+ Public key crypto: ${enable_public_key}
+ ])
+--
+1.7.8.6
+
diff --git a/dev-libs/nettle/nettle-2.5-r1.ebuild b/dev-libs/nettle/nettle-2.5-r1.ebuild
new file mode 100644
index 000000000000..19cdd91c5a22
--- /dev/null
+++ b/dev-libs/nettle/nettle-2.5-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/nettle/nettle-2.5-r1.ebuild,v 1.1 2012/12/14 21:45:31 alonbl Exp $
+
+EAPI="4"
+
+inherit eutils autotools
+
+DESCRIPTION="Low-level cryptographic library"
+HOMEPAGE="http://www.lysator.liu.se/~nisse/nettle/"
+SRC_URI="http://www.lysator.liu.se/~nisse/archive/${P}.tar.gz"
+
+LICENSE="|| ( LGPL-3 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="static-libs +gmp"
+
+DEPEND="gmp? ( dev-libs/gmp )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -e "/CFLAGS=/s: -ggdb3::" -i configure.ac || die
+ epatch "${FILESDIR}"/${PN}-2.5-missing-libm-link.patch
+ sed -i -e 's/solaris\*)/sunldsolaris*)/' configure.ac || die
+ epatch "${FILESDIR}/${P}-static-libs.patch"
+ eautoreconf
+}
+
+src_configure() {
+ # --disable-openssl bug #427526
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable gmp public-key) \
+ --disable-openssl
+}