summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-09-12 14:08:04 +0000
committerPacho Ramos <pacho@gentoo.org>2011-09-12 14:08:04 +0000
commitc7fa8d1f1fd0f1d125625914aa4ef64ec0df5a2e (patch)
tree0f20110749292ec7b016eb01dec5357d1ad7c162 /dev-libs
parentVersion bump, drop .la files. (diff)
downloadgentoo-2-c7fa8d1f1fd0f1d125625914aa4ef64ec0df5a2e.tar.gz
gentoo-2-c7fa8d1f1fd0f1d125625914aa4ef64ec0df5a2e.tar.bz2
gentoo-2-c7fa8d1f1fd0f1d125625914aa4ef64ec0df5a2e.zip
Version bump, drop .la files, remove old.
(Portage version: 2.1.10.15/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/librep/ChangeLog8
-rw-r--r--dev-libs/librep/files/librep-0.92.0-disable-elisp.patch19
-rw-r--r--dev-libs/librep/librep-0.92.1.ebuild (renamed from dev-libs/librep/librep-0.17.3.ebuild)29
3 files changed, 43 insertions, 13 deletions
diff --git a/dev-libs/librep/ChangeLog b/dev-libs/librep/ChangeLog
index dcc3090310d0..fb745b41b4ea 100644
--- a/dev-libs/librep/ChangeLog
+++ b/dev-libs/librep/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/librep
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/librep/ChangeLog,v 1.61 2011/08/07 17:38:25 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/librep/ChangeLog,v 1.62 2011/09/12 14:08:04 pacho Exp $
+
+*librep-0.92.1 (12 Sep 2011)
+
+ 12 Sep 2011; Pacho Ramos <pacho@gentoo.org> -librep-0.17.3.ebuild,
+ +files/librep-0.92.0-disable-elisp.patch, +librep-0.92.1.ebuild:
+ Version bump, drop .la files, remove old.
07 Aug 2011; Raúl Porcel <armin76@gentoo.org> librep-0.90.6.ebuild:
alpha/ia64/sparc stable wrt #376345
diff --git a/dev-libs/librep/files/librep-0.92.0-disable-elisp.patch b/dev-libs/librep/files/librep-0.92.0-disable-elisp.patch
new file mode 100644
index 000000000000..6f7b2f1228c7
--- /dev/null
+++ b/dev-libs/librep/files/librep-0.92.0-disable-elisp.patch
@@ -0,0 +1,19 @@
+--- Makefile.in.old 2011-07-25 14:08:18.000000000 +0200
++++ Makefile.in 2011-07-25 14:09:05.000000000 +0200
+@@ -53,15 +53,13 @@
+ $(INSTALL_SCRIPT) libtool $(DESTDIR)$(repcommonexecdir)
+ $(INSTALL_DATA) rules.mk $(DESTDIR)$(repcommonexecdir)
+ $(INSTALL_SCRIPT) install-aliases $(DESTDIR)$(repcommonexecdir)
+- $(INSTALL_DATA) rep-debugger.el $(DESTDIR)$(emacssitelispdir)
+ mkdir -p $(DESTDIR)$(libdir)/pkgconfig
+ $(INSTALL_DATA) $(top_srcdir)/librep.pc $(DESTDIR)$(libdir)/pkgconfig/
+
+ installdirs : mkinstalldirs
+ $(SHELL) $< $(DESTDIR)$(repdir) \
+ $(DESTDIR)$(bindir) $(DESTDIR)$(aclocaldir) \
+- $(DESTDIR)$(repcommonexecdir) $(DESTDIR)$(repexecdir) \
+- $(DESTDIR)$(emacssitelispdir)
++ $(DESTDIR)$(repcommonexecdir) $(DESTDIR)$(repexecdir)
+
+ uninstall :
+ -for dir in $(INSTALL_SUBDIRS); do \
diff --git a/dev-libs/librep/librep-0.17.3.ebuild b/dev-libs/librep/librep-0.92.1.ebuild
index b5326bf1b3b5..fcf15a4d6c94 100644
--- a/dev-libs/librep/librep-0.17.3.ebuild
+++ b/dev-libs/librep/librep-0.92.1.ebuild
@@ -1,12 +1,14 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/librep/librep-0.17.3.ebuild,v 1.1 2009/03/08 20:06:34 truedfx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/librep/librep-0.92.1.ebuild,v 1.1 2011/09/12 14:08:04 pacho Exp $
+
+EAPI="4"
inherit eutils multilib elisp-common
DESCRIPTION="Shared library implementing a Lisp dialect"
HOMEPAGE="http://librep.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+SRC_URI="http://download.tuxfamily.org/librep/${P}.tar.xz"
LICENSE="GPL-2"
SLOT="0"
@@ -19,20 +21,21 @@ RDEPEND=">=sys-libs/gdbm-1.8.0
DEPEND="${RDEPEND}
sys-apps/texinfo"
-src_unpack() {
- unpack ${P}.tar.bz2
- cd "${S}"
- epatch "${FILESDIR}"/${P}-disable-elisp.patch
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.92.0-disable-elisp.patch
}
-src_compile() {
+src_configure() {
econf \
--libexecdir=/usr/$(get_libdir) \
--without-gmp \
--without-ffi \
- $(use_with readline) || die "configure failed"
+ --disable-static \
+ $(use_with readline)
+}
- emake || die "make failed"
+src_compile() {
+ emake
if use emacs; then
elisp-compile rep-debugger.el || die "elisp-compile failed"
@@ -40,8 +43,10 @@ src_compile() {
}
src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc AUTHORS BUGS ChangeLog NEWS README THANKS TODO TREE
+ emake DESTDIR="${D}" install
+ find "${D}" -name '*.la' -exec rm -f {} + || die "la file removal failed"
+
+ dodoc ChangeLog MAINTAINERS NEWS README TODO
docinto doc
dodoc doc/*