summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2006-10-23 19:25:43 +0000
committerTiziano Müller <dev-zero@gentoo.org>2006-10-23 19:25:43 +0000
commitebf15f5d02b0b5df197bb2a1130bc5034e136089 (patch)
treee04104a5f197eb3238b6e1a8792e8877411feea8 /dev-libs
parentAdd non-gentoo mirror. (diff)
downloadgentoo-2-ebf15f5d02b0b5df197bb2a1130bc5034e136089.tar.gz
gentoo-2-ebf15f5d02b0b5df197bb2a1130bc5034e136089.tar.bz2
gentoo-2-ebf15f5d02b0b5df197bb2a1130bc5034e136089.zip
'static' USE-flag removed (was broken). Patch added for bug #146112. Fixing bug #137638. Adding symlink from *thread-mt.so -> *thread.so which solves problems with other packages.
(Portage version: 2.1.2_pre3-r3)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/boost/ChangeLog7
-rw-r--r--dev-libs/boost/boost-1.33.1-r1.ebuild214
-rw-r--r--dev-libs/boost/boost-1.33.1.ebuild4
-rw-r--r--dev-libs/boost/boost-1.34_pre20060930.ebuild15
-rw-r--r--dev-libs/boost/files/boost-1.33.1-gcc41_visit_each.patch10
-rw-r--r--dev-libs/boost/files/digest-boost-1.33.1-r13
6 files changed, 246 insertions, 7 deletions
diff --git a/dev-libs/boost/ChangeLog b/dev-libs/boost/ChangeLog
index 6cc5db6a404c..380707c539bf 100644
--- a/dev-libs/boost/ChangeLog
+++ b/dev-libs/boost/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/boost
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.92 2006/10/04 10:48:42 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.93 2006/10/23 19:25:43 dev-zero Exp $
+
+ 23 Oct 2006; Tiziano Müller <dev-zero@gentoo.org> ChangeLog:
+ 'static' USE-flag removed (was broken). Patch added for bug #146112. Fixing
+ bug #137638. Adding symlink from *thread-mt.so -> *thread.so which solves
+ problems with other packages.
04 Oct 2006; Diego Pettenò <flameeyes@gentoo.org> boost-1.33.1.ebuild:
Add ~x86-fbsd keyword.
diff --git a/dev-libs/boost/boost-1.33.1-r1.ebuild b/dev-libs/boost/boost-1.33.1-r1.ebuild
new file mode 100644
index 000000000000..2343d1f16646
--- /dev/null
+++ b/dev-libs/boost/boost-1.33.1-r1.ebuild
@@ -0,0 +1,214 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.33.1-r1.ebuild,v 1.1 2006/10/23 19:25:43 dev-zero Exp $
+
+inherit eutils distutils multilib python versionator
+
+MY_P=${PN}_$(replace_all_version_separators _)
+
+DESCRIPTION="Boost Libraries for C++"
+HOMEPAGE="http://www.boost.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+LICENSE="freedist Boost-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="bcp bjam debug doc pyste threads threadsonly"
+
+DEPEND="sys-libs/zlib"
+RDEPEND="${DEPEND}
+ !dev-util/boost-jam
+ pyste? ( dev-cpp/gccxml dev-python/elementtree )"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-gcc41_visit_each.patch"
+
+ # Don't strip (safest approach atm)
+ sed -i \
+ -e 's/-s\b//g' \
+ tools/build/jam_src/build.jam \
+ tools/build/v1/gcc-tools.jam \
+ || die "sed failed"
+}
+
+pkg_setup() {
+ BOOSTJAM="${S}/tools/build/jam_src/bin.*/bjam"
+
+ # FIXME: Until we have a better way to do that
+ NUMJOBS=$(sed -e 's/.*\(\-j[ 0-9]\+\) .*/\1/' <<< ${MAKEOPTS})
+
+ python_version
+
+ if [ "${ARCH}" == "amd64" ]; then
+ arch=
+ else
+ arch=${ARCH}
+ fi
+
+ if use ppc-macos ; then
+ BOOST_TOOLSET="darwin"
+ TOOLSET_NAME="darwin"
+ SOSUFFIX="dylib"
+ else
+ BOOST_TOOLSET="gcc"
+ TOOLSET_NAME="gcc"
+ SOSUFFIX="so"
+ fi
+
+ BUILD="release <runtime-link>dynamic"
+
+ if use debug ; then
+ BUILD="${BUILD} debug"
+ fi
+
+ if use threads && use threadsonly ; then
+ BUILD="${BUILD} <threading>multi"
+ fi
+
+ if use threads && ! use threadsonly ; then
+ BUILD="${BUILD} <threading>single/multi"
+ fi
+
+ if ! use threads ; then
+ BUILD="${BUILD} <threading>single"
+ fi
+
+}
+
+src_compile() {
+ cd "${S}/tools/build/jam_src"
+ ./build.sh ${BOOST_TOOLSET} || die "Failed to build bjam"
+
+ cd "${S}"
+ # Fixing boost with threads on alpha. Thanks to ibm <imirkin@mit.edu>
+ if use threads && [ "${ARCH}" == "alpha" ]; then
+ epatch ${FILESDIR}/boost-alpha-threads.patch
+ fi
+
+ ${BOOSTJAM} ${NUMJOBS} -sBOOST_ROOT="${S}" \
+ -sPYTHON_ROOT=/usr \
+ -sPYTHON_VERSION=${PYVER} \
+ -sTOOLS=${BOOST_TOOLSET} \
+ -sBUILD="${BUILD}" \
+ ${ADDITIONAL_OPTIONS} \
+ --prefix=${D}/usr \
+ --layout=system
+
+ ${BOOSTJAM} ${NUMJOBS} -sBOOST_ROOT="${S}" \
+ -sPYTHON_ROOT=/usr \
+ -sPYTHON_VERSION=${PYVER} \
+ -sTOOLS=${BOOST_TOOLSET} \
+ -sBUILD="${BUILD}" \
+ ${ADDITIONAL_OPTIONS} \
+ --prefix=${D}/usr \
+ --layout=system
+
+ if use pyste; then
+ cd "${S}/libs/python/pyste/install"
+ distutils_src_compile
+ fi
+
+ if use bcp; then
+ cd "${S}/tools/bcp/"
+ ${BOOSTJAM} || die "Building bcp failed"
+ fi
+}
+
+src_install () {
+
+ cd "${S}/tools/build"
+ dodir /usr/share/boost-build
+ insinto /usr/share/boost-build
+ cp -pPR index.html v1/ v2/ "${D}/usr/share/boost-build" || die "failed to install docs"
+
+ cd "${S}"
+ ${BOOSTJAM} ${NUMJOBS} -sBOOST_ROOT="${S}" \
+ -sPYTHON_ROOT=/usr \
+ -sPYTHON_VERSION=${PYVER} \
+ -sTOOLS=${BOOST_TOOLSET} \
+ -sBUILD="${BUILD}" \
+ ${ADDITIONAL_OPTIONS} \
+ --prefix="${D}/usr" \
+ --layout=system \
+ install || die "Install failed"
+
+ dodoc README
+
+ if use doc ; then
+ dohtml index.htm google_logo_40wht.gif c++boost.gif boost.css \
+ -A pdf -r more-r people -r doc
+
+ find libs -type f -not -regex '^libs/[^/]*/build/.*' \
+ -and -not -regex '^libs/.*/test[^/]?/.*' \
+ -and -not -regex '^libs/.*/bench[^/]?/.*' \
+ -and -not -regex '^libs/[^/]*/tools/.*' \
+ -and -not -name \*.bat \
+ -and -not -name Jamfile\* \
+ -and -not -regex '^libs/[^/]*/src/.*' \
+ -and -not -iname makefile \
+ -and -not -name \*.mak \
+ -and -not -name .\* \
+ -and -not -name \*.dsw \
+ -and -not -name \*.dsp \
+ -exec \
+ install -D -m0644 \{\} "${D}/usr/share/doc/${PF}/html/{}" \;
+ fi
+
+ #and finally set "default" links to -gcc-mt versions
+ cd "${D}/usr/lib"
+
+ for fn in $(ls -1 *.${SOSUFFIX}| cut -d- -f1 | sort -u) ; do
+ if [ -f "$fn.${SOSUFFIX}" ] ; then
+ dosym "$fn.${SOSUFFIX}" "/usr/lib/$fn-${TOOLSET_NAME}.${SOSUFFIX}"
+ fi
+ if [ -f "$fn-mt.${SOSUFFIX}" ] ; then
+ dosym "$fn-mt.${SOSUFFIX}" "/usr/lib/$fn-${TOOLSET_NAME}-mt.${SOSUFFIX}"
+ fi
+ if [ -f "$fn-d.${SOSUFFIX}" ] ; then
+ dosym "$fn-d.${SOSUFFIX}" "/usr/lib/$fn-${TOOLSET_NAME}-d.${SOSUFFIX}"
+ fi
+ if [ -f "$fn-mt-d.${SOSUFFIX}" ] ; then
+ dosym "$fn-mt-d.${SOSUFFIX}" "/usr/lib/$fn-${TOOLSET_NAME}-mt-d.${SOSUFFIX}"
+ fi
+ done
+
+ for fn in $(ls -1 *.a| cut -d- -f1 | sort -u) ; do
+ if [ -f "$fn.a" ] ; then
+ dosym "$fn.a" "/usr/lib/$fn-${TOOLSET_NAME}.a"
+ fi
+ if [ -f "$fn-mt.a" ] ; then
+ dosym "$fn-mt.a" "/usr/lib/$fn-${TOOLSET_NAME}-mt.a"
+ fi
+ if [ -f "$fn-d.a" ] ; then
+ dosym "$fn-d.a" "/usr/lib/$fn-${TOOLSET_NAME}-d.a"
+ fi
+ if [ -f "$fn-mt-d.a" ] ; then
+ dosym "$fn-mt-d.a" "/usr/lib/$fn-${TOOLSET_NAME}-mt-d.a"
+ fi
+ done
+
+ if use threads ; then
+ dosym "libboost_thread-mt.a" "/usr/lib/libboost_thread.a"
+ dosym "libboost_thread-mt.so" "/usr/lib/libboost_thread.so"
+ fi
+
+ [[ $(get_libdir) == "lib" ]] || mv "${D}/usr/lib" "${D}/usr/$(get_libdir)"
+
+ if use pyste; then
+ cd "${S}/libs/python/pyste/install"
+ distutils_src_install
+ fi
+
+ if use bcp; then
+ dobin "${S}/tools/bcp/run/bcp" || die "bcp install failed"
+ fi
+
+ if use bjam; then
+ cd "${S}"/tools/build/jam_src/bin.*/
+ dobin bjam || die "bjam install failed"
+ fi
+}
diff --git a/dev-libs/boost/boost-1.33.1.ebuild b/dev-libs/boost/boost-1.33.1.ebuild
index 9ee6cd0e69dd..1e9dc9d6c119 100644
--- a/dev-libs/boost/boost-1.33.1.ebuild
+++ b/dev-libs/boost/boost-1.33.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.33.1.ebuild,v 1.12 2006/10/04 10:48:42 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.33.1.ebuild,v 1.13 2006/10/23 19:25:43 dev-zero Exp $
# This ebuild was generated by Ebuilder v0.4.
inherit python distutils multilib eutils
@@ -12,7 +12,7 @@ BOOST_PV=${BOOST_PV1/./_}
SRC_URI="mirror://gentoo/${PN}_${BOOST_PV}.tar.bz2 \
mirror://sourceforge/boost/${PN}_${BOOST_PV}.tar.bz2"
LICENSE="freedist Boost-1.0"
-SLOT="1"
+SLOT="0"
KEYWORDS="alpha amd64 hppa ia64 mips ppc ppc64 sparc x86 ~x86-fbsd"
IUSE="bcp bjam debug doc pyste static threads threadsonly"
diff --git a/dev-libs/boost/boost-1.34_pre20060930.ebuild b/dev-libs/boost/boost-1.34_pre20060930.ebuild
index dec6ec8728cd..4c879273a034 100644
--- a/dev-libs/boost/boost-1.34_pre20060930.ebuild
+++ b/dev-libs/boost/boost-1.34_pre20060930.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.34_pre20060930.ebuild,v 1.2 2006/10/01 23:00:09 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.34_pre20060930.ebuild,v 1.3 2006/10/23 19:25:43 dev-zero Exp $
-inherit python distutils multilib eutils versionator
+inherit distutils multilib python versionator
MY_P=${PN}_$(replace_all_version_separators _)
@@ -10,7 +10,7 @@ DESCRIPTION="Boost Libraries for C++"
HOMEPAGE="http://www.boost.org/"
SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
LICENSE="freedist Boost-1.0"
-SLOT="1"
+SLOT="0"
KEYWORDS="~x86"
IUSE="bcp bjam debug doc icu pyste static threads threadsonly"
@@ -31,6 +31,7 @@ S=${WORKDIR}/${MY_P}
# - Remove boost-jam and remove the blocker
# - Find a better way to do set the options than in pkg_setup (check whether they are really needed for installation)
# - Eventually split-out boost.python and spirit (second one has it's own release-cycle)
+# - Do a 'slotmove'
pkg_setup() {
BOOSTJAM="${S}/tools/jam/src/bin.*/bjam"
@@ -141,7 +142,6 @@ src_install () {
--layout=system \
install || die "Install failed"
-
dodoc README
if use doc ; then
@@ -197,6 +197,13 @@ src_install () {
fi
done
+ if use threads ; then
+ dosym "libboost_thread-mt.a" "/usr/lib/libboost_thread.a"
+ if ! use static ; then
+ dosym "libboost_thread-mt.so" "/usr/lib/libboost_thread.so"
+ fi
+ fi
+
[[ $(get_libdir) == "lib" ]] || mv "${D}/usr/lib" "${D}/usr/$(get_libdir)"
if use pyste; then
diff --git a/dev-libs/boost/files/boost-1.33.1-gcc41_visit_each.patch b/dev-libs/boost/files/boost-1.33.1-gcc41_visit_each.patch
new file mode 100644
index 000000000000..d21a35366131
--- /dev/null
+++ b/dev-libs/boost/files/boost-1.33.1-gcc41_visit_each.patch
@@ -0,0 +1,10 @@
+--- boost/bind.hpp.orig 2006-10-05 21:09:32.000000000 +0200
++++ boost/bind.hpp 2006-10-05 21:10:10.000000000 +0200
+@@ -27,6 +27,7 @@
+ #include <boost/type.hpp>
+ #include <boost/bind/arg.hpp>
+ #include <boost/detail/workaround.hpp>
++#include <boost/visit_each.hpp>
+
+ // Borland-specific bug, visit_each() silently fails to produce code
+
diff --git a/dev-libs/boost/files/digest-boost-1.33.1-r1 b/dev-libs/boost/files/digest-boost-1.33.1-r1
new file mode 100644
index 000000000000..7372f018b6a2
--- /dev/null
+++ b/dev-libs/boost/files/digest-boost-1.33.1-r1
@@ -0,0 +1,3 @@
+MD5 2b999b2fb7798e1737d1fff8fac602ef boost_1_33_1.tar.bz2 11507161
+RMD160 3d5999d321b558f74d786bec52ee1b1fcd7e7152 boost_1_33_1.tar.bz2 11507161
+SHA256 6232e93205acbc8c705f44f15977aae158550c99a384f41606cff26c16393be0 boost_1_33_1.tar.bz2 11507161