summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2004-02-15 11:23:04 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2004-02-15 11:23:04 +0000
commit861c94bba44ebb64e4aec5fe646e15c904e6a630 (patch)
treec16e86228e6b04f0c459cbaab897a1b3259a8a13 /dev-lisp/cl-menusystem
parentNew ppc-sources-dev release with XFS support and updated Pegasos patch. (Mani... (diff)
downloadgentoo-2-861c94bba44ebb64e4aec5fe646e15c904e6a630.tar.gz
gentoo-2-861c94bba44ebb64e4aec5fe646e15c904e6a630.tar.bz2
gentoo-2-861c94bba44ebb64e4aec5fe646e15c904e6a630.zip
*** empty log message ***
Diffstat (limited to 'dev-lisp/cl-menusystem')
-rw-r--r--dev-lisp/cl-menusystem/ChangeLog10
-rw-r--r--dev-lisp/cl-menusystem/Manifest4
-rw-r--r--dev-lisp/cl-menusystem/cl-menusystem-20030919.ebuild24
-rw-r--r--dev-lisp/cl-menusystem/files/digest-cl-menusystem-200309191
-rw-r--r--dev-lisp/cl-menusystem/metadata.xml12
5 files changed, 51 insertions, 0 deletions
diff --git a/dev-lisp/cl-menusystem/ChangeLog b/dev-lisp/cl-menusystem/ChangeLog
new file mode 100644
index 000000000000..bb1ac057fbf5
--- /dev/null
+++ b/dev-lisp/cl-menusystem/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-lisp/cl-menusystem
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-menusystem/ChangeLog,v 1.1 2004/02/15 11:23:04 mkennedy Exp $
+
+*cl-menusystem-20030919 (15 Feb 2004)
+
+ 15 Feb 2004; <mkennedy@gentoo.org> cl-menusystem-20030919.ebuild,
+ metadata.xml:
+ Initial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>
+
diff --git a/dev-lisp/cl-menusystem/Manifest b/dev-lisp/cl-menusystem/Manifest
new file mode 100644
index 000000000000..dace45254f71
--- /dev/null
+++ b/dev-lisp/cl-menusystem/Manifest
@@ -0,0 +1,4 @@
+MD5 5dba6951bf6f9d707b526119b9404960 cl-menusystem-20030919.ebuild 839
+MD5 abd716458d31270a75f10e286f069608 cl-menusystem-20030919.ebuild~ 705
+MD5 1f2c6296906c798bb99bf07f466063fe metadata.xml 510
+MD5 6034a0a72c1445650e3da9cf2d26078a files/digest-cl-menusystem-20030919 74
diff --git a/dev-lisp/cl-menusystem/cl-menusystem-20030919.ebuild b/dev-lisp/cl-menusystem/cl-menusystem-20030919.ebuild
new file mode 100644
index 000000000000..aef2f4461425
--- /dev/null
+++ b/dev-lisp/cl-menusystem/cl-menusystem-20030919.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-menusystem/cl-menusystem-20030919.ebuild,v 1.1 2004/02/15 11:23:04 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="CL-MENUSYSTEM is a menu system for Common Lisp that implements menu control and settings editing for Common Lisp applications."
+HOMEPAGE="http://www.cs.indiana.edu/~bmastenb/software/cl-menusystem/"
+SRC_URI="http://www.cs.indiana.edu/~bmastenb/software/cl-menusystem/cl-menusystem-${PV:0:4}-${PV:4:2}-${PV:6:2}.tar.gz"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86"
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp"
+
+CLPACKAGE=cl-menusystem
+
+S=${WORKDIR}/${PN}
+
+src_install() {
+ common-lisp-install *.lisp cl-menusystem.asd
+ common-lisp-system-symlink
+ dodoc DOCUMENTATION README
+}
diff --git a/dev-lisp/cl-menusystem/files/digest-cl-menusystem-20030919 b/dev-lisp/cl-menusystem/files/digest-cl-menusystem-20030919
new file mode 100644
index 000000000000..74de230449a6
--- /dev/null
+++ b/dev-lisp/cl-menusystem/files/digest-cl-menusystem-20030919
@@ -0,0 +1 @@
+MD5 6c04db109f3388d5d85991ca613fdc94 cl-menusystem-2003-09-19.tar.gz 7286
diff --git a/dev-lisp/cl-menusystem/metadata.xml b/dev-lisp/cl-menusystem/metadata.xml
new file mode 100644
index 000000000000..2abc6f487ee5
--- /dev/null
+++ b/dev-lisp/cl-menusystem/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>common-lisp</herd>
+<longdescription>
+CL-MENUSYSTEM is a menu system for Common Lisp that implements menu
+control and settings editing for CL applications. It has a number of
+nifty features, including being based on CLOS, with separation of
+backends (hypothetical as right now there's only one) and using
+restarts for non-local exits from menus.
+</longdescription>
+</pkgmetadata>