summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2004-09-12 21:37:49 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2004-09-12 21:37:49 +0000
commit306c91562c89629bac6f71025d48e07155e066c5 (patch)
tree3629bae510bfc1f17f3da2e4f7a26b380ba57623 /dev-lisp/cl-postoffice/cl-postoffice-1.8.2.3.ebuild
parentuse mirror: in SRC_URI; tidy (Manifest recommit) (diff)
downloadgentoo-2-306c91562c89629bac6f71025d48e07155e066c5.tar.gz
gentoo-2-306c91562c89629bac6f71025d48e07155e066c5.tar.bz2
gentoo-2-306c91562c89629bac6f71025d48e07155e066c5.zip
*** empty log message ***
Diffstat (limited to 'dev-lisp/cl-postoffice/cl-postoffice-1.8.2.3.ebuild')
-rw-r--r--dev-lisp/cl-postoffice/cl-postoffice-1.8.2.3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-lisp/cl-postoffice/cl-postoffice-1.8.2.3.ebuild b/dev-lisp/cl-postoffice/cl-postoffice-1.8.2.3.ebuild
new file mode 100644
index 000000000000..a3c23389ddc4
--- /dev/null
+++ b/dev-lisp/cl-postoffice/cl-postoffice-1.8.2.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-postoffice/cl-postoffice-1.8.2.3.ebuild,v 1.1 2004/09/12 21:37:49 mkennedy Exp $
+
+inherit common-lisp eutils
+
+DEB_PV=1
+
+DESCRIPTION="Franz's SMTP, POP, & IMAP interface library for Common Lisp Programs"
+HOMEPAGE="http://opensource.franz.com/postoffice/index.html
+ http://packages.debian.org/unstable/devel/cl-postoffice"
+SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-postoffice/cl-postoffice_${PV}.orig.tar.gz
+ http://ftp.debian.org/debian/pool/main/c/cl-postoffice/cl-postoffice_${PV}-${DEB_PV}.diff.gz"
+LICENSE="LLGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="dev-lisp/common-lisp-controller
+ dev-lisp/cl-acl-compat"
+
+S=${WORKDIR}/${PN}-${PV}
+
+CLPACKAGE=postoffice
+
+# Invesitage why this doesn't work with CLISP sometime.
+
+src_install() {
+ common-lisp-install *.lisp *.asd
+ common-lisp-system-symlink
+ do-debian-credits
+ dodoc ChangeLog
+ dohtml postoffice.html
+}