summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2004-05-14 03:34:37 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2004-05-14 03:34:37 +0000
commitb985f00d1f9b3c33f633138dcb10378aa5d28399 (patch)
treed23e84e5b4dbbc3d11b2701ee9662e40bc925b64 /dev-lisp/cl-rsm-rsa/cl-rsm-rsa-1.3.20040328.ebuild
parentStable on mips. (Manifest recommit) (diff)
downloadgentoo-2-b985f00d1f9b3c33f633138dcb10378aa5d28399.tar.gz
gentoo-2-b985f00d1f9b3c33f633138dcb10378aa5d28399.tar.bz2
gentoo-2-b985f00d1f9b3c33f633138dcb10378aa5d28399.zip
*** empty log message ***
Diffstat (limited to 'dev-lisp/cl-rsm-rsa/cl-rsm-rsa-1.3.20040328.ebuild')
-rw-r--r--dev-lisp/cl-rsm-rsa/cl-rsm-rsa-1.3.20040328.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-lisp/cl-rsm-rsa/cl-rsm-rsa-1.3.20040328.ebuild b/dev-lisp/cl-rsm-rsa/cl-rsm-rsa-1.3.20040328.ebuild
new file mode 100644
index 000000000000..c464e740a2e4
--- /dev/null
+++ b/dev-lisp/cl-rsm-rsa/cl-rsm-rsa-1.3.20040328.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-rsm-rsa/cl-rsm-rsa-1.3.20040328.ebuild,v 1.1 2004/05/14 03:34:37 mkennedy Exp $
+
+inherit common-lisp
+
+MY_PV=${PV:0:3}
+CVS_PV=${PV:4:4}.${PV:8:2}.${PV:10}
+
+DESCRIPTION="McIntire's Common Lisp RSA Library"
+HOMEPAGE="http://packages.debian.org/unstable/devel/${PN}.html"
+SRC_URI="http://ftp.debian.org/debian/pool/main/c/${PN}/cl-rsm-rsa_${MY_PV}+cvs.${CVS_PV}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp
+ dev-lisp/cl-rsm-mod
+ dev-lisp/cl-rsm-string"
+
+CLPACKAGE=rsm-rsa
+
+S=${WORKDIR}/cl-rsm-rsa-${MY_PV}+cvs.${CVS_PV}
+
+src_install() {
+ common-lisp-install *.lisp *.asd
+ common-lisp-system-symlink
+ dodoc copying copyright
+ dohtml *.html *.jpg
+ do-debian-credits
+}