summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-07-07 13:47:33 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-07-07 13:47:33 +0000
commitd11591611c1218b95a74d3b694fef7e0dcad1922 (patch)
tree811a3618bed2e65d0a302c01f6f357aecd2abaad /dev-lisp/clisp
parentUnmask hddtemp USE-flag, make dev-lisp/clisp deps minimal (diff)
downloadgentoo-2-d11591611c1218b95a74d3b694fef7e0dcad1922.tar.gz
gentoo-2-d11591611c1218b95a74d3b694fef7e0dcad1922.tar.bz2
gentoo-2-d11591611c1218b95a74d3b694fef7e0dcad1922.zip
Tweak ebuild to make it compile on alpha/ia64, add ~alpha/~ia64, bug #230035
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-lisp/clisp')
-rw-r--r--dev-lisp/clisp/ChangeLog6
-rw-r--r--dev-lisp/clisp/clisp-2.46.ebuild17
2 files changed, 20 insertions, 3 deletions
diff --git a/dev-lisp/clisp/ChangeLog b/dev-lisp/clisp/ChangeLog
index afefa773b0b4..97850ba975db 100644
--- a/dev-lisp/clisp/ChangeLog
+++ b/dev-lisp/clisp/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lisp/clisp
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/ChangeLog,v 1.80 2008/07/03 17:14:16 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/ChangeLog,v 1.81 2008/07/07 13:47:33 armin76 Exp $
+
+ 07 Jul 2008; Raúl Porcel <armin76@gentoo.org> clisp-2.46.ebuild:
+ Tweak ebuild to make it compile on alpha/ia64, add ~alpha/~ia64, bug
+ #230035
*clisp-2.46 (03 Jul 2008)
diff --git a/dev-lisp/clisp/clisp-2.46.ebuild b/dev-lisp/clisp/clisp-2.46.ebuild
index 80937fbacfc7..a369946f0027 100644
--- a/dev-lisp/clisp/clisp-2.46.ebuild
+++ b/dev-lisp/clisp/clisp-2.46.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.46.ebuild,v 1.1 2008/07/03 17:14:16 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.46.ebuild,v 1.2 2008/07/07 13:47:33 armin76 Exp $
inherit flag-o-matic eutils toolchain-funcs multilib
@@ -11,7 +11,7 @@ LICENSE="GPL-2"
# EAPI="1"
SLOT="2"
-KEYWORDS="~amd64 ~ppc -sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc -sparc ~x86"
IUSE="hyperspec X new-clx fastcgi gdbm gtk pari pcre postgres readline svm zlib"
RDEPEND="virtual/libiconv
@@ -53,11 +53,24 @@ BUILDDIR="builddir"
# * matlab, netica: not in portage
# * oracle: can't install oracle-instantclient
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # More than -O1 breaks alpha/ia64
+ use alpha || use ia64 && sed -i -e 's/-O2//g' src/makemake.in
+}
+
src_compile() {
# built-in features
local myconf="--with-ffcall --with-dynamic-modules"
use readline || myconf="${myconf} --with-noreadline"
+ # We need this to build on alpha/ia64
+ if use alpha || use ia64; then
+ replace-flags -O? -O1
+ append-flags '-D NO_MULTIMAP_SHM -D NO_MULTIMAP_FILE -D NO_SINGLEMAP -D NO_TRIVIALMAP'
+ fi
# default modules
enable_modules wildcard rawsock i18n
# optional modules