summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2010-04-12 11:53:52 +0000
committerAndrey Grozin <grozin@gentoo.org>2010-04-12 11:53:52 +0000
commit50e1883a8c54ab18f560682a18873205116781ad (patch)
tree04d1de952010a88cea3211a5f8f7667e3af521fc /dev-lisp/ecls
parentInitial commit wrt #314797 by Arthur Spitzer. (diff)
downloadgentoo-2-50e1883a8c54ab18f560682a18873205116781ad.tar.gz
gentoo-2-50e1883a8c54ab18f560682a18873205116781ad.tar.bz2
gentoo-2-50e1883a8c54ab18f560682a18873205116781ad.zip
Version bump
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'dev-lisp/ecls')
-rw-r--r--dev-lisp/ecls/ChangeLog8
-rw-r--r--dev-lisp/ecls/ecls-10.4.1.ebuild70
-rw-r--r--dev-lisp/ecls/files/10.4.1-headers-gentoo.patch17
-rw-r--r--dev-lisp/ecls/metadata.xml3
4 files changed, 96 insertions, 2 deletions
diff --git a/dev-lisp/ecls/ChangeLog b/dev-lisp/ecls/ChangeLog
index e91bf4e23924..7d57c520ae7b 100644
--- a/dev-lisp/ecls/ChangeLog
+++ b/dev-lisp/ecls/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lisp/ecls
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ChangeLog,v 1.34 2010/02/19 16:36:18 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ChangeLog,v 1.35 2010/04/12 11:53:52 grozin Exp $
+
+*ecls-10.4.1 (12 Apr 2010)
+
+ 12 Apr 2010; Andrey Grozin <grozin@gentoo.org>
+ +files/10.4.1-headers-gentoo.patch, +ecls-10.4.1.ebuild:
+ Version bump
*ecls-10.2.1 (19 Feb 2010)
diff --git a/dev-lisp/ecls/ecls-10.4.1.ebuild b/dev-lisp/ecls/ecls-10.4.1.ebuild
new file mode 100644
index 000000000000..abab12d84995
--- /dev/null
+++ b/dev-lisp/ecls/ecls-10.4.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ecls-10.4.1.ebuild,v 1.1 2010/04/12 11:53:52 grozin Exp $
+
+EAPI=3
+inherit eutils multilib
+
+MY_P=ecl-${PV}
+
+DESCRIPTION="ECL is an embeddable Common Lisp implementation."
+HOMEPAGE="http://common-lisp.net/project/ecl/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="debug gengc precisegc threads +unicode X"
+
+RDEPEND="dev-libs/gmp
+ virtual/libffi
+ >=dev-libs/boehm-gc-7.1[threads?]"
+DEPEND="${RDEPEND}
+ app-text/texi2html"
+PDEPEND="dev-lisp/gentoo-init"
+
+PROVIDE="virtual/commonlisp"
+
+S="${WORKDIR}"/${MY_P}
+
+pkg_setup() {
+ if use gengc || use precisegc; then
+ ewarn "USE flags gengc and precisegc are experimental"
+ ewarn "Don't use them if you want a stable ecl"
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-headers-gentoo.patch
+}
+
+src_configure() {
+ econf \
+ --with-system-gmp \
+ --enable-boehm=system \
+ --enable-longdouble \
+ $(use_enable gengc) \
+ $(use_enable precisegc) \
+ $(use_with debug debug-cflags) \
+ $(use_enable threads) \
+ $(use_with threads __thread) \
+ $(use_enable unicode) \
+ $(use_with X x) \
+ $(use_with X clx)
+}
+
+src_compile() {
+ #parallel fails
+ emake -j1 || die "Compilation failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "Installation failed"
+
+ dodoc ANNOUNCEMENT Copyright
+ dodoc "${FILESDIR}"/README.Gentoo
+ pushd build/doc
+ newman ecl.man ecl.1
+ newman ecl-config.man ecl-config.1
+ popd
+}
diff --git a/dev-lisp/ecls/files/10.4.1-headers-gentoo.patch b/dev-lisp/ecls/files/10.4.1-headers-gentoo.patch
new file mode 100644
index 000000000000..635fc5d4afde
--- /dev/null
+++ b/dev-lisp/ecls/files/10.4.1-headers-gentoo.patch
@@ -0,0 +1,17 @@
+diff -Naur ecl-8.12.0.orig/src/h/object.h ecl-8.12.0/src/h/object.h
+--- ecl.orig/src/h/object.h 2008-12-17 16:41:53.000000000 +0100
++++ ecl/src/h/object.h 2008-12-17 19:35:05.000000000 +0100
+@@ -23,8 +23,13 @@
+ Integer and boolean types (see config.h)
+ */
+
++#ifndef TRUE
+ #define TRUE 1 /* boolean true value */
++#endif
++
++#ifndef FALSE
+ #define FALSE 0 /* boolean false value */
++#endif
+
+ #if !defined(__cplusplus) && !defined(bool)
+ typedef int bool;
diff --git a/dev-lisp/ecls/metadata.xml b/dev-lisp/ecls/metadata.xml
index 8fbb9faa273b..e04ad8f7f3f3 100644
--- a/dev-lisp/ecls/metadata.xml
+++ b/dev-lisp/ecls/metadata.xml
@@ -9,6 +9,7 @@ System), conditions, loops, etc, plus a translator to C, which can produce
standalone executables.
</longdescription>
<use>
-<flag name='precisegc'>Use type information during garbage collection</flag>
+<flag name='gengc'>Use generational garbage collection (experimental)</flag>
+<flag name='precisegc'>Use type information during garbage collection (experimental)</flag>
</use>
</pkgmetadata>