summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2005-03-11 16:51:39 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2005-03-11 16:51:39 +0000
commitc1254f995a7d0a3974f973d7355f666d8ff0857a (patch)
tree421fddbcc14f0db09b6583aeb89409860a43d92c /dev-lisp/openmcl/openmcl-0.14.2_p1.ebuild
parent- marking 2.1.3 stable for all supporting arches (diff)
downloadgentoo-2-c1254f995a7d0a3974f973d7355f666d8ff0857a.tar.gz
gentoo-2-c1254f995a7d0a3974f973d7355f666d8ff0857a.tar.bz2
gentoo-2-c1254f995a7d0a3974f973d7355f666d8ff0857a.zip
(Portage version: 2.0.51.19)
Diffstat (limited to 'dev-lisp/openmcl/openmcl-0.14.2_p1.ebuild')
-rw-r--r--dev-lisp/openmcl/openmcl-0.14.2_p1.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/dev-lisp/openmcl/openmcl-0.14.2_p1.ebuild b/dev-lisp/openmcl/openmcl-0.14.2_p1.ebuild
new file mode 100644
index 000000000000..ae41b7572206
--- /dev/null
+++ b/dev-lisp/openmcl/openmcl-0.14.2_p1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/openmcl/openmcl-0.14.2_p1.ebuild,v 1.1 2005/03/11 16:51:39 mkennedy Exp $
+
+inherit eutils common-lisp-common-2
+
+EXTRA_PV=o
+MY_PV=${PV/_p/.p}
+
+DESCRIPTION="OpenMCL is a Common Lisp implementation, derived from Digitool's MCL product"
+HOMEPAGE="http://openmcl.clozure.com/
+ http://packages.debian.org/unstable/devel/openmcl"
+SRC_URI="http://ftp.debian.org/debian/pool/main/o/${PN}/${PN}_${MY_PV}.${EXTRA_PV}.tar.gz"
+LICENSE="LLGPL-2.1"
+SLOT="0"
+KEYWORDS="~ppc"
+IUSE=""
+
+DEPEND="=dev-lisp/common-lisp-controller-4*
+ >=dev-lisp/cl-asdf-1.84
+ dev-lisp/openmcl-build-tools"
+
+PROVIDE="virtual/commonlisp"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+# The following relies heavily on what I read in debian/rules...
+
+src_unpack() {
+ unpack ${A}
+ pushd ${S}
+ sed -e "s,%ver%,${MY_PV}.${EXTRA_PV}," \
+ < debian/run-bootstrap.lisp.template \
+ > debian/run-bootstrap.lisp
+ cp debian/Makefile .
+ cp -a /usr/lib/openmcl/{PPCCL-orig,headers} .
+ popd
+}
+
+src_compile() {
+ OPENMCL=/usr/bin/openmcl make || die
+}
+
+src_install() {
+ dodir /etc
+ dodir /usr/bin
+ dodir /usr/lib/common-lisp/bin
+ dodir /usr/lib/openmcl
+ dodir /usr/lib/openmcl/lib
+ dodir /usr/lib/openmcl/library
+ make install DESTDIR=${D} || die
+ insinto /usr/lib/openmcl
+ doins debian/install-clc.lisp
+ exeinto /usr/lib/common-lisp/bin/
+ doexe debian/openmcl.sh
+ dohtml doc/HTML/*.html
+ doman debian/openmcl.1
+ do-debian-credits
+}
+
+pkg_postinst() {
+ standard-impl-postinst openmcl || die
+}
+
+pkg_postrm() {
+ standard-impl-postrm openmcl /usr/bin/openmcl
+ if [ ! -x /usr/bin/openmcl ]; then
+ rm -rf /usr/lib/openmcl/ || die
+ fi
+}