summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2015-02-23 22:46:07 +0000
committerAndrey Grozin <grozin@gentoo.org>2015-02-23 22:46:07 +0000
commit05b22781558d714d3679973019d9ecabdf6c32ba (patch)
tree3822502da862b4bc4965db3b4a539b1105d64fe3 /dev-lisp
parentSecurity bump (bug #511764). Removed old (diff)
downloadgentoo-2-05b22781558d714d3679973019d9ecabdf6c32ba.tar.gz
gentoo-2-05b22781558d714d3679973019d9ecabdf6c32ba.tar.bz2
gentoo-2-05b22781558d714d3679973019d9ecabdf6c32ba.zip
Version bump
(Portage version: 2.2.17/cvs/Linux i686, signed Manifest commit with key 0x3AFFCE974D34BD8C!)
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/ecls/ChangeLog8
-rw-r--r--dev-lisp/ecls/ecls-15.2.21.ebuild91
-rw-r--r--dev-lisp/ecls/metadata.xml1
3 files changed, 99 insertions, 1 deletions
diff --git a/dev-lisp/ecls/ChangeLog b/dev-lisp/ecls/ChangeLog
index 8f76f2fb7cdd..05ae3cb6ab04 100644
--- a/dev-lisp/ecls/ChangeLog
+++ b/dev-lisp/ecls/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lisp/ecls
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ChangeLog,v 1.51 2015/01/28 19:40:42 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ChangeLog,v 1.52 2015/02/23 22:46:07 grozin Exp $
+
+*ecls-15.2.21 (23 Feb 2015)
+
+ 23 Feb 2015; Andrey Grozin <grozin@gentoo.org> +ecls-15.2.21.ebuild,
+ metadata.xml:
+ Version bump
28 Jan 2015; Michał Górny <mgorny@gentoo.org> ecls-12.12.1-r5.ebuild,
ecls-13.5.1-r1.ebuild, ecls-13.5.1.ebuild:
diff --git a/dev-lisp/ecls/ecls-15.2.21.ebuild b/dev-lisp/ecls/ecls-15.2.21.ebuild
new file mode 100644
index 000000000000..a301a11d7cac
--- /dev/null
+++ b/dev-lisp/ecls/ecls-15.2.21.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ecls-15.2.21.ebuild,v 1.1 2015/02/23 22:46:07 grozin Exp $
+
+EAPI=5
+inherit eutils multilib
+
+# test phase only works if ecls already installed #516876
+RESTRICT="test"
+
+MY_P=ecl-${PV}
+
+DESCRIPTION="ECL is an embeddable Common Lisp implementation"
+HOMEPAGE="http://ecls.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tgz"
+
+LICENSE="BSD LGPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="debug emacs gengc precisegc cpu_flags_x86_sse +threads +unicode +libatomic X"
+
+CDEPEND="dev-libs/gmp:0
+ virtual/libffi
+ libatomic? ( dev-libs/libatomic_ops )
+ >=dev-libs/boehm-gc-7.1[threads?]
+ >=dev-lisp/asdf-2.33-r3:="
+DEPEND="${CDEPEND}
+ app-text/texi2html
+ emacs? ( virtual/emacs >=app-admin/eselect-emacs-1.12 )"
+RDEPEND="${CDEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+pkg_setup () {
+ if use gengc || use precisegc ; then
+ ewarn "You have enabled the generational garbage collector or"
+ ewarn "the precise collection routines. These features are not very stable"
+ ewarn "at the moment and may cause crashes."
+ ewarn "Don't enable them unless you know what you're doing."
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-headers-gentoo.patch
+ cp "${EPREFIX}"/usr/share/common-lisp/source/asdf/build/asdf.lisp contrib/asdf/ || die
+}
+
+src_configure() {
+ econf \
+ --with-system-gmp \
+ --enable-boehm=system \
+ --enable-longdouble=yes \
+ --with-dffi \
+ $(use_enable gengc) \
+ $(use_enable precisegc) \
+ $(use_with debug debug-cflags) \
+ $(use_enable libatomic libatomic system) \
+ $(use_with cpu_flags_x86_sse sse) \
+ $(use_enable threads) \
+ $(use_with threads __thread) \
+ $(use_enable unicode) \
+ $(use_with unicode unicode-names) \
+ $(use_with X x) \
+ $(use_with X clx)
+}
+
+src_compile() {
+ if use emacs; then
+ local ETAGS=$(eselect --brief etags list | sed -ne '/emacs/{p;q}')
+ [[ -n ${ETAGS} ]] || die "No etags implementation found"
+ pushd build > /dev/null || die
+ emake ETAGS=${ETAGS} TAGS
+ popd > /dev/null
+ else
+ touch build/TAGS
+ fi
+
+ #parallel make fails
+ emake -j1 || die "Compilation failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "Installation failed"
+
+ dodoc ANNOUNCEMENT Copyright
+ dodoc "${FILESDIR}"/README.Gentoo
+ pushd build/doc
+ newman ecl.man ecl.1
+ newman ecl-config.man ecl-config.1
+ popd
+}
diff --git a/dev-lisp/ecls/metadata.xml b/dev-lisp/ecls/metadata.xml
index e04ad8f7f3f3..c760ccb19e85 100644
--- a/dev-lisp/ecls/metadata.xml
+++ b/dev-lisp/ecls/metadata.xml
@@ -11,5 +11,6 @@ standalone executables.
<use>
<flag name='gengc'>Use generational garbage collection (experimental)</flag>
<flag name='precisegc'>Use type information during garbage collection (experimental)</flag>
+<flag name='libatomic'>Use <pkg>dev-libs/libatomic_ops</pkg> library</flag>
</use>
</pkgmetadata>