summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-03-21 14:21:02 +0000
committerJustin Lecher <jlec@gentoo.org>2015-03-21 14:21:02 +0000
commit1bac708a4b59783a8cd505a4094dcebb9230d25e (patch)
tree7b60bb2f3cfc68931a44e5f301076b7805816596 /dev-lisp
parentadd missing eclass (diff)
downloadgentoo-2-1bac708a4b59783a8cd505a4094dcebb9230d25e.tar.gz
gentoo-2-1bac708a4b59783a8cd505a4094dcebb9230d25e.tar.bz2
gentoo-2-1bac708a4b59783a8cd505a4094dcebb9230d25e.zip
use esvn_clean
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/clozurecl/ChangeLog9
-rw-r--r--dev-lisp/clozurecl/clozurecl-1.10.ebuild25
-rw-r--r--dev-lisp/clozurecl/clozurecl-1.9_p1-r1.ebuild25
3 files changed, 32 insertions, 27 deletions
diff --git a/dev-lisp/clozurecl/ChangeLog b/dev-lisp/clozurecl/ChangeLog
index 64af842ed728..05fdfe362861 100644
--- a/dev-lisp/clozurecl/ChangeLog
+++ b/dev-lisp/clozurecl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lisp/clozurecl
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clozurecl/ChangeLog,v 1.13 2014/09/14 09:57:58 grozin Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clozurecl/ChangeLog,v 1.14 2015/03/21 14:21:02 jlec Exp $
+
+ 21 Mar 2015; Justin Lecher <jlec@gentoo.org> clozurecl-1.10.ebuild,
+ clozurecl-1.9_p1-r1.ebuild:
+ use esvn_clean
*clozurecl-1.10 (14 Sep 2014)
@@ -67,4 +71,3 @@
17 Dec 2009; Andrey Grozin <grozin@gentoo.org> +clozurecl-1.4.ebuild,
+files/fix_user-homedir-pathname.patch, +metadata.xml:
Initial import (from the lisp overlay)
-
diff --git a/dev-lisp/clozurecl/clozurecl-1.10.ebuild b/dev-lisp/clozurecl/clozurecl-1.10.ebuild
index 1fc324f01120..faf1913759b6 100644
--- a/dev-lisp/clozurecl/clozurecl-1.10.ebuild
+++ b/dev-lisp/clozurecl/clozurecl-1.10.ebuild
@@ -1,19 +1,21 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clozurecl/clozurecl-1.10.ebuild,v 1.1 2014/09/14 09:57:58 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clozurecl/clozurecl-1.10.ebuild,v 1.2 2015/03/21 14:21:02 jlec Exp $
EAPI=5
+
inherit eutils multilib toolchain-funcs
MY_PN=ccl
MY_P=${MY_PN}-${PV}
-DESCRIPTION="ClozureCL is a Common Lisp implementation, derived from Digitool's MCL product"
+DESCRIPTION="Common Lisp implementation, derived from Digitool's MCL product"
HOMEPAGE="http://ccl.clozure.com/"
-SRC_URI="x86? ( ftp://ftp.clozure.com/pub/release/${PV}/${MY_P}-linuxx86.tar.gz )
- amd64? ( ftp://ftp.clozure.com/pub/release/${PV}/${MY_P}-linuxx86.tar.gz )"
- # ppc? ( ftp://ftp.clozure.com/pub/release/${PV}/${MY_P}-linuxppc.tar.gz )
- # ppc64? ( ftp://ftp.clozure.com/pub/release/${PV}/${MY_P}-linuxppc.tar.gz )"
+SRC_URI="
+ x86? ( ftp://ftp.clozure.com/pub/release/${PV}/${MY_P}-linuxx86.tar.gz )
+ amd64? ( ftp://ftp.clozure.com/pub/release/${PV}/${MY_P}-linuxx86.tar.gz )"
+ # ppc? ( ftp://ftp.clozure.com/pub/release/${PV}/${MY_P}-linuxppc.tar.gz )
+ # ppc64? ( ftp://ftp.clozure.com/pub/release/${PV}/${MY_P}-linuxppc.tar.gz )"
LICENSE="LLGPL-2.1"
SLOT="0"
@@ -53,10 +55,9 @@ src_compile() {
./${CCL_RUNTIME} -n -b -Q -e '(ccl:rebuild-ccl :full t)' -e '(ccl:quit)' || die "Compilation failed"
# remove non-owner write permissions on the full-image
- chmod go-w ${CCL_RUNTIME}{,.image}
+ chmod go-w ${CCL_RUNTIME}{,.image} || die
- # remove .svn directories
- find "${S}" -type d -name .svn -exec rm -rf {} ';' &>/dev/null
+ esvn_clean
}
src_install() {
@@ -73,8 +74,8 @@ src_install() {
# until we figure out which source files are necessary for runtime
# optional features and which aren't, we install all sources
- find . -type f -name '*fsl' -delete
- rm -f lisp-kernel/${CCL_KERNEL}/*.o
+ find . -type f -name '*fsl' -delete || die
+ rm -f lisp-kernel/${CCL_KERNEL}/*.o || die
cp -a compiler level-0 level-1 lib library \
lisp-kernel scripts tools xdump contrib \
"${D}"/${install_dir} || die
diff --git a/dev-lisp/clozurecl/clozurecl-1.9_p1-r1.ebuild b/dev-lisp/clozurecl/clozurecl-1.9_p1-r1.ebuild
index d5b11f136e78..22596f43bc23 100644
--- a/dev-lisp/clozurecl/clozurecl-1.9_p1-r1.ebuild
+++ b/dev-lisp/clozurecl/clozurecl-1.9_p1-r1.ebuild
@@ -1,19 +1,21 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clozurecl/clozurecl-1.9_p1-r1.ebuild,v 1.1 2013/10/14 10:48:32 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clozurecl/clozurecl-1.9_p1-r1.ebuild,v 1.2 2015/03/21 14:21:02 jlec Exp $
EAPI=5
+
inherit eutils multilib toolchain-funcs
MY_PN=ccl
MY_P=${MY_PN}-${PV}
-DESCRIPTION="ClozureCL is a Common Lisp implementation, derived from Digitool's MCL product"
+DESCRIPTION="Common Lisp implementation, derived from Digitool's MCL product"
HOMEPAGE="http://ccl.clozure.com/"
-SRC_URI="x86? ( http://dev.gentoo.org/~grozin/${MY_P}-linuxx86.tar.bz2 )
- amd64? ( http://dev.gentoo.org/~grozin/${MY_P}-linuxx86.tar.bz2 )"
- # ppc? ( ftp://ftp.clozure.com/pub/release/${PV}/${MY_P}-linuxppc.tar.gz )
- # ppc64? ( ftp://ftp.clozure.com/pub/release/${PV}/${MY_P}-linuxppc.tar.gz )"
+SRC_URI="
+ x86? ( http://dev.gentoo.org/~grozin/${MY_P}-linuxx86.tar.bz2 )
+ amd64? ( http://dev.gentoo.org/~grozin/${MY_P}-linuxx86.tar.bz2 )"
+ # ppc? ( ftp://ftp.clozure.com/pub/release/${PV}/${MY_P}-linuxppc.tar.gz )
+ # ppc64? ( ftp://ftp.clozure.com/pub/release/${PV}/${MY_P}-linuxppc.tar.gz )"
LICENSE="LLGPL-2.1"
SLOT="0"
@@ -53,10 +55,9 @@ src_compile() {
./${CCL_RUNTIME} -n -b -Q -e '(ccl:rebuild-ccl :full t)' -e '(ccl:quit)' || die "Compilation failed"
# remove non-owner write permissions on the full-image
- chmod go-w ${CCL_RUNTIME}{,.image}
+ chmod go-w ${CCL_RUNTIME}{,.image} || die
- # remove .svn directories
- find "${S}" -type d -name .svn -exec rm -rf {} ';' &>/dev/null
+ esvn_clean
}
src_install() {
@@ -73,8 +74,8 @@ src_install() {
# until we figure out which source files are necessary for runtime
# optional features and which aren't, we install all sources
- find . -type f -name '*fsl' -delete
- rm -f lisp-kernel/${CCL_KERNEL}/*.o
+ find . -type f -name '*fsl' -delete || die
+ rm -f lisp-kernel/${CCL_KERNEL}/*.o || die
cp -a compiler level-0 level-1 lib library \
lisp-kernel scripts tools xdump contrib \
"${D}"/${install_dir} || die