summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2004-11-03 05:42:15 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2004-11-03 05:42:15 +0000
commit2258ca228705f1fcadee8ff796da348b10a1d2bb (patch)
tree559d1264fce0bca4798bb10af714c298fbf18463 /dev-lisp
parentMoved patches in app-text/tetex/files directory to Gentoo mirrors. (diff)
downloadgentoo-2-2258ca228705f1fcadee8ff796da348b10a1d2bb.tar.gz
gentoo-2-2258ca228705f1fcadee8ff796da348b10a1d2bb.tar.bz2
gentoo-2-2258ca228705f1fcadee8ff796da348b10a1d2bb.zip
*** empty log message ***
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/ecls/ChangeLog8
-rw-r--r--dev-lisp/ecls/Manifest2
-rw-r--r--dev-lisp/ecls/ecls-0.9d.ebuild44
-rw-r--r--dev-lisp/ecls/files/0.9d-texinfo-gentoo.patch73
-rw-r--r--dev-lisp/ecls/files/digest-ecls-0.9d1
5 files changed, 127 insertions, 1 deletions
diff --git a/dev-lisp/ecls/ChangeLog b/dev-lisp/ecls/ChangeLog
index 9992697a2ae7..3cf9a9337554 100644
--- a/dev-lisp/ecls/ChangeLog
+++ b/dev-lisp/ecls/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lisp/ecls
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ChangeLog,v 1.9 2004/10/28 15:00:12 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ChangeLog,v 1.10 2004/11/03 05:42:15 mkennedy Exp $
+
+*ecls-0.9d (02 Nov 2004)
+
+ 02 Nov 2004; Matthew Kenendy <mkennedy@gentoo.org>
+ +files/0.9d-texinfo-gentoo.patch, +ecls-0.9d.ebuild:
+ New upstream version.
28 Oct 2004; Matthew Kenendy <mkennedy@gentoo.org>
+files/0.9c-texinfo-gentoo.patch, ecls-0.9c.ebuild:
diff --git a/dev-lisp/ecls/Manifest b/dev-lisp/ecls/Manifest
index a57ac767464a..67d0d5ca0e69 100644
--- a/dev-lisp/ecls/Manifest
+++ b/dev-lisp/ecls/Manifest
@@ -3,9 +3,11 @@ MD5 239b2a09cb322da9ad7818314b4933d2 ecls-0.9c.ebuild 1468
MD5 6d5408cb4095f4e61785bf0a78ae6ea0 ChangeLog 1385
MD5 9b65b0341efc8f4b29498aad23315229 metadata.xml 164
MD5 174ba6c16944b5135444609051ab5912 ecls-0.9b.ebuild 1286
+MD5 97de7e8174cebd98f4320deadc2826c8 ecls-0.9d.ebuild 987
MD5 e3190b09fe9b3d6635ee2230bfd6df0e files/0.9c-gcc-3.4-gentoo.patch 2550
MD5 146550f52692408e4bbc8ff3b641a436 files/digest-ecls-0.9b 58
MD5 e23cb04b0671bbdf6c508b87489570ee files/digest-ecls-0.2 58
MD5 d68b203008a4e745e31a492c1b5fe764 files/ecl-texi-gentoo.patch 1051
MD5 4bec90700c813eeba10f4804469ae39c files/digest-ecls-0.9c 58
MD5 abb6b52782b57db4eaf4ebd77b9f2505 files/0.9c-texinfo-gentoo.patch 3709
+MD5 7bc96db7aefcaaa816c3270fa705f453 files/digest-ecls-0.9d 58
diff --git a/dev-lisp/ecls/ecls-0.9d.ebuild b/dev-lisp/ecls/ecls-0.9d.ebuild
new file mode 100644
index 000000000000..f96b82eb4843
--- /dev/null
+++ b/dev-lisp/ecls/ecls-0.9d.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ecls-0.9d.ebuild,v 1.1 2004/11/03 05:42:15 mkennedy Exp $
+
+inherit eutils
+
+DESCRIPTION="ECL is an embeddable Common Lisp implementation."
+SRC_URI="mirror://sourceforge/ecls/ecl-${PV}.tgz"
+HOMEPAGE="http://ecls.sourceforge.net/"
+SLOT="0"
+LICENSE="BSD LGPL-2"
+KEYWORDS="~x86"
+
+DEPEND="X? ( virtual/x11 )
+ =dev-libs/gmp-4*
+ dev-libs/boehm-gc
+ app-text/texi2html"
+
+IUSE="X"
+
+S=${WORKDIR}/ecl-${PV}
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${PV}-texinfo-gentoo.patch || die
+}
+
+src_compile() {
+ myconf="--enable-local-gmp --enable-local-boehm --with-tcp"
+ myconf="$myconf --with-ffi --with-clos-streams --with-cmu-format `use_with X x`"
+ einfo "Configuring with: $myconf"
+ econf ${myconf} || die
+ make || die
+}
+
+src_install () {
+ make bindir=${D}/usr/bin \
+ infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ libdir=${D}/usr/lib/ecl \
+ docdir=${D}/usr/share/doc/${PF} install || true
+ dohtml doc/*.html
+ dodoc ANNOUNCEMENT Copyright LGPL
+}
diff --git a/dev-lisp/ecls/files/0.9d-texinfo-gentoo.patch b/dev-lisp/ecls/files/0.9d-texinfo-gentoo.patch
new file mode 100644
index 000000000000..565f4a3735cf
--- /dev/null
+++ b/dev-lisp/ecls/files/0.9d-texinfo-gentoo.patch
@@ -0,0 +1,73 @@
+diff -ur ecl-0.9d.orig/src/doc/user.txi ecl-0.9d/src/doc/user.txi
+--- ecl-0.9d.orig/src/doc/user.txi 2004-11-02 05:26:16.000000000 -0600
++++ ecl-0.9d/src/doc/user.txi 2004-11-02 20:38:49.642445608 -0600
+@@ -3394,11 +3394,11 @@
+ @deffnx {Method} {(setf documentation)} {new-value (list list) @optional{} doc-type}
+ @end deffn
+
+-@defun {ensure-generic-function} {function-name @keys{} lambda-list @keys :argument-precedence-order :declare :documentation :generic-function-class|ekeys{:method-combination :method-class :environment}}
+-@example
+-function-name ::= symbol | (setf symbol)
+-@end example
+-@end defun
++@c @defun {ensure-generic-function} {function-name @keys{} lambda-list @keys :argument-precedence-order :declare :documentation :generic-function-class|ekeys{:method-combination :method-class :environment}}
++@c @example
++@c function-name ::= symbol | (setf symbol)
++@c @end example
++@c @end defun
+
+ @defun {find-class} {symbol @optional{} errorp environment}
+
+@@ -3417,29 +3417,29 @@
+
+ The generic function function-keywords is used to return the keyword parameter specifiers for a given method.
+
+-@defmac {generic-function} {lambda-list \mchoice{option | @{method-description@}*}}
++@c @defmac {generic-function} {lambda-list \mchoice{option | @{method-description@}*}}
+
+-@example
+-option ::= (:argument-precedence-order @{parameter-name@}+)
+- | (declare @{declaration@}+)
+- | (:documentation string)
+- | (:method-combination symbol @{arg@}*)
+- | (:generic-function-class class-name)
+- | (:method-class class-name)
+-method-description ::= (:method @{method-qualifier@}*
+- specialized-lambda-list
+- @{declaration | @var{documentation}@}*
+- @{form@}*)
+-@end example
+-The @code{generic-function} macro creates an anonymous generic function. The
+-generic function is created with the set of methods specified by its method
+-descriptions. The @var{option}, @var{method-qualifier}, and
+-@var{specialized-lambda-list} arguments are the same as for @code{defgeneric}.
+-The generic function object is returned as the result. If no method
+-descriptions are specified, an anonymous generic function with no methods is
+-created. See @macref{defgeneric}, @macref{generic-flet},
+-@macref{generic-labels}, @macref{defmethod}.
+-@end defmac
++@c @example
++@c option ::= (:argument-precedence-order @{parameter-name@}+)
++@c | (declare @{declaration@}+)
++@c | (:documentation string)
++@c | (:method-combination symbol @{arg@}*)
++@c | (:generic-function-class class-name)
++@c | (:method-class class-name)
++@c method-description ::= (:method @{method-qualifier@}*
++@c specialized-lambda-list
++@c @{declaration | @var{documentation}@}*
++@c @{form@}*)
++@c @end example
++@c The @code{generic-function} macro creates an anonymous generic function. The
++@c generic function is created with the set of methods specified by its method
++@c descriptions. The @var{option}, @var{method-qualifier}, and
++@c @var{specialized-lambda-list} arguments are the same as for @code{defgeneric}.
++@c The generic function object is returned as the result. If no method
++@c descriptions are specified, an anonymous generic function with no methods is
++@c created. See @macref{defgeneric}, @macref{generic-flet},
++@c @macref{generic-labels}, @macref{defmethod}.
++@c @end defmac
+
+ @deffn {Generic} {initialize-instance} instance @rest{} initargs
+ @deffnx {Method} {initialize-instance} {(instance standard-object) @rest{} initargs}
+Only in ecl-0.9d/src/doc: user.txi~
diff --git a/dev-lisp/ecls/files/digest-ecls-0.9d b/dev-lisp/ecls/files/digest-ecls-0.9d
new file mode 100644
index 000000000000..8a0fcb9d1bcd
--- /dev/null
+++ b/dev-lisp/ecls/files/digest-ecls-0.9d
@@ -0,0 +1 @@
+MD5 50da732c4a4d4824c8dd7c9e2f661ad6 ecl-0.9d.tgz 4340522