summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-01-03 12:26:40 +0000
committerManuel Rüger <mrueg@gentoo.org>2015-01-03 12:26:40 +0000
commit84689f31f45816f7a3f110b764a226e884ef5352 (patch)
tree9d84fe6300dd50fb2eb331e6448b018acd267bfe /dev-lua
parentUse python-any-r1 for waf. (diff)
downloadgentoo-2-84689f31f45816f7a3f110b764a226e884ef5352.tar.gz
gentoo-2-84689f31f45816f7a3f110b764a226e884ef5352.tar.bz2
gentoo-2-84689f31f45816f7a3f110b764a226e884ef5352.zip
Version bump.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/lua-zlib/ChangeLog9
-rw-r--r--dev-lua/lua-zlib/lua-zlib-0.4.ebuild31
2 files changed, 38 insertions, 2 deletions
diff --git a/dev-lua/lua-zlib/ChangeLog b/dev-lua/lua-zlib/ChangeLog
index e0d6458a5671..cb2ccc054548 100644
--- a/dev-lua/lua-zlib/ChangeLog
+++ b/dev-lua/lua-zlib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lua/lua-zlib
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lua/lua-zlib/ChangeLog,v 1.12 2014/12/28 11:30:32 mrueg Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lua/lua-zlib/ChangeLog,v 1.13 2015/01/03 12:26:40 mrueg Exp $
+
+*lua-zlib-0.4 (03 Jan 2015)
+
+ 03 Jan 2015; Manuel Rüger <mrueg@gentoo.org> +lua-zlib-0.4.ebuild:
+ Version bump.
28 Dec 2014; Manuel Rüger <mrueg@gentoo.org> -lua-zlib-0.2.ebuild:
Remove old.
diff --git a/dev-lua/lua-zlib/lua-zlib-0.4.ebuild b/dev-lua/lua-zlib/lua-zlib-0.4.ebuild
new file mode 100644
index 000000000000..1ceae4d70770
--- /dev/null
+++ b/dev-lua/lua-zlib/lua-zlib-0.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lua/lua-zlib/lua-zlib-0.4.ebuild,v 1.1 2015/01/03 12:26:40 mrueg Exp $
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Lua bindings to zlib"
+HOMEPAGE="http://github.com/brimworks/lua-zlib"
+SRC_URI="https://github.com/brimworks/${PN}/tarball/v${PV} -> ${P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/lua
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ mv *-${PN}-* "${S}"
+}
+
+src_configure() {
+ MYCMAKEARGS="-DINSTALL_CMOD='$(pkg-config --variable INSTALL_CMOD lua)'"
+ cmake-utils_src_configure
+}