summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-08-22 14:19:53 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-08-22 14:19:53 +0000
commitd108c317d9288270818e382d662de47b3fe06429 (patch)
tree6e71d1570f68124cbcac405bf9339346f8266614 /dev-ml/bolt
parentppc stable (bug 415255). (diff)
downloadgentoo-2-d108c317d9288270818e382d662de47b3fe06429.tar.gz
gentoo-2-d108c317d9288270818e382d662de47b3fe06429.tar.bz2
gentoo-2-d108c317d9288270818e382d662de47b3fe06429.zip
version bump
(Portage version: 2.2.0_alpha121/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml/bolt')
-rw-r--r--dev-ml/bolt/ChangeLog9
-rw-r--r--dev-ml/bolt/bolt-1.3.ebuild38
2 files changed, 45 insertions, 2 deletions
diff --git a/dev-ml/bolt/ChangeLog b/dev-ml/bolt/ChangeLog
index 533ba1dc9cba..088b295bfb32 100644
--- a/dev-ml/bolt/ChangeLog
+++ b/dev-ml/bolt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/bolt
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/bolt/ChangeLog,v 1.1 2011/08/20 11:14:23 aballier Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/bolt/ChangeLog,v 1.2 2012/08/22 14:19:53 aballier Exp $
+
+*bolt-1.3 (22 Aug 2012)
+
+ 22 Aug 2012; Alexis Ballier <aballier@gentoo.org> +bolt-1.3.ebuild:
+ version bump
*bolt-1.2 (20 Aug 2011)
diff --git a/dev-ml/bolt/bolt-1.3.ebuild b/dev-ml/bolt/bolt-1.3.ebuild
new file mode 100644
index 000000000000..48dc8c43a7c8
--- /dev/null
+++ b/dev-ml/bolt/bolt-1.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/bolt/bolt-1.3.ebuild,v 1.1 2012/08/22 14:19:53 aballier Exp $
+
+EAPI=4
+
+inherit findlib
+
+DESCRIPTION="Logging tool for the Objective Caml language"
+HOMEPAGE="http://bolt.x9c.fr/"
+SRC_URI="http://bolt.x9c.fr/distrib/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+DEPEND=">=dev-lang/ocaml-3.11[ocamlopt]"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ sh configure
+}
+
+src_compile() {
+ emake all
+ use doc && emake doc
+}
+
+src_test() {
+ emake tests
+}
+
+src_install() {
+ findlib_src_install
+ dodoc README CHANGES FEATURES
+ use doc && dohtml ocamldoc/*
+}