summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-08-19 15:28:17 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-08-19 15:28:17 +0000
commit744a8b4f9bb206279b8d05220f0c11d1906a9a74 (patch)
tree1e45fefbc439f20fca3397d0fa27d08c97478707 /dev-ml/core
parentversion bump (diff)
downloadgentoo-2-744a8b4f9bb206279b8d05220f0c11d1906a9a74.tar.gz
gentoo-2-744a8b4f9bb206279b8d05220f0c11d1906a9a74.tar.bz2
gentoo-2-744a8b4f9bb206279b8d05220f0c11d1906a9a74.zip
version bump and fix build with ocaml 4.01
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml/core')
-rw-r--r--dev-ml/core/ChangeLog8
-rw-r--r--dev-ml/core/core-109.38.00.ebuild39
-rw-r--r--dev-ml/core/files/core-ocaml-4.01.patch24
3 files changed, 70 insertions, 1 deletions
diff --git a/dev-ml/core/ChangeLog b/dev-ml/core/ChangeLog
index b5f506f029fc..9d1562755498 100644
--- a/dev-ml/core/ChangeLog
+++ b/dev-ml/core/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/core
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/core/ChangeLog,v 1.24 2013/08/19 12:53:00 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/core/ChangeLog,v 1.25 2013/08/19 15:28:17 aballier Exp $
+
+*core-109.38.00 (19 Aug 2013)
+
+ 19 Aug 2013; Alexis Ballier <aballier@gentoo.org> +core-109.38.00.ebuild,
+ +files/core-ocaml-4.01.patch:
+ version bump and fix build with ocaml 4.01
19 Aug 2013; Alexis Ballier <aballier@gentoo.org> -core-109.27.00.ebuild,
-core-109.34.00.ebuild:
diff --git a/dev-ml/core/core-109.38.00.ebuild b/dev-ml/core/core-109.38.00.ebuild
new file mode 100644
index 000000000000..6c23b6497546
--- /dev/null
+++ b/dev-ml/core/core-109.38.00.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/core/core-109.38.00.ebuild,v 1.1 2013/08/19 15:28:17 aballier Exp $
+
+EAPI="5"
+
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit eutils oasis
+
+MY_P=${P/_/\~}
+DESCRIPTION="Jane Street's alternative to the standard library"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV}/individual/${MY_P}.tar.gz
+ http://dev.gentoo.org/~aballier/distfiles/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-ml/res:=
+ >=dev-ml/core_kernel-109.35.00:=
+ >=dev-ml/sexplib-109.20.00:=
+ >=dev-ml/bin-prot-109.15.00:=
+ >=dev-ml/fieldslib-109.20.00:=
+ >=dev-ml/pa_ounit-109.27.00:=
+ >=dev-ml/variantslib-109.15.00:=
+ >=dev-ml/comparelib-109.27.00:=
+ >=dev-ml/herelib-109.35.00:=
+ >=dev-ml/pipebang-109.15.00:="
+DEPEND="${RDEPEND}
+ test? ( >=dev-ml/ounit-1.1.2 )"
+DOCS=( "README.md" )
+
+src_prepare() {
+ has_version '>=dev-lang/ocaml-4.01.0_beta' && epatch "${FILESDIR}/${PN}-ocaml-4.01.patch"
+}
diff --git a/dev-ml/core/files/core-ocaml-4.01.patch b/dev-ml/core/files/core-ocaml-4.01.patch
new file mode 100644
index 000000000000..1f08a11f69e7
--- /dev/null
+++ b/dev-ml/core/files/core-ocaml-4.01.patch
@@ -0,0 +1,24 @@
+Index: core-109.38.00/lib/core_unix.ml
+===================================================================
+--- core-109.38.00.orig/lib/core_unix.ml
++++ core-109.38.00/lib/core_unix.ml
+@@ -890,6 +890,7 @@ Unix.open_flag =
+ | O_SYNC
+ | O_RSYNC
+ | O_SHARE_DELETE
++| O_CLOEXEC
+ with sexp
+
+ type file_perm = int with of_sexp
+Index: core-109.38.00/lib/core_unix.mli
+===================================================================
+--- core-109.38.00.orig/lib/core_unix.mli
++++ core-109.38.00/lib/core_unix.mli
+@@ -305,6 +305,7 @@ type open_flag =
+ | O_SYNC (** Writes complete as `Synchronised I/O file integrity completion' *)
+ | O_RSYNC (** Reads complete as writes (depending on O_SYNC/O_DSYNC) *)
+ | O_SHARE_DELETE (** Windows only: allow the file to be deleted while still open *)
++ | O_CLOEXEC
+ with sexp
+
+ (** The type of file access rights. *)