summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-02-15 09:07:18 +0000
committerAlexis Ballier <aballier@gentoo.org>2015-02-15 09:07:18 +0000
commit8b23afc167f179fe06f58621ff9a49c983be8e8a (patch)
treee5081d0cd86554e10ba31e20bc11397424ae9b04 /dev-ml/easy-format
parentMarked ~ppc too. (diff)
downloadgentoo-2-8b23afc167f179fe06f58621ff9a49c983be8e8a.tar.gz
gentoo-2-8b23afc167f179fe06f58621ff9a49c983be8e8a.tar.bz2
gentoo-2-8b23afc167f179fe06f58621ff9a49c983be8e8a.zip
initial import, ebuild by José Romildo Malaquias, bug #539328
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml/easy-format')
-rw-r--r--dev-ml/easy-format/ChangeLog10
-rw-r--r--dev-ml/easy-format/easy-format-1.0.2.ebuild34
-rw-r--r--dev-ml/easy-format/metadata.xml5
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-ml/easy-format/ChangeLog b/dev-ml/easy-format/ChangeLog
new file mode 100644
index 000000000000..c82b79047324
--- /dev/null
+++ b/dev-ml/easy-format/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ml/easy-format
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/easy-format/ChangeLog,v 1.1 2015/02/15 09:07:18 aballier Exp $
+
+*easy-format-1.0.2 (15 Feb 2015)
+
+ 15 Feb 2015; Alexis Ballier <aballier@gentoo.org> +easy-format-1.0.2.ebuild,
+ +metadata.xml:
+ initial import, ebuild by José Romildo Malaquias, bug #539328
+
diff --git a/dev-ml/easy-format/easy-format-1.0.2.ebuild b/dev-ml/easy-format/easy-format-1.0.2.ebuild
new file mode 100644
index 000000000000..93f87e4112fa
--- /dev/null
+++ b/dev-ml/easy-format/easy-format-1.0.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/easy-format/easy-format-1.0.2.ebuild,v 1.1 2015/02/15 09:07:18 aballier Exp $
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Pretty-printing library for OCaml"
+HOMEPAGE="http://mjambon.com/easy-format.html"
+SRC_URI="http://mjambon.com/releases/${PN}/${P}.tar.gz"
+
+SLOT="0/${PV}"
+LICENSE="BSD"
+KEYWORDS="~amd64"
+
+IUSE="examples +ocamlopt"
+
+RDEPEND="dev-lang/ocaml:=[ocamlopt?]"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ emake all
+ use ocamlopt && emake opt
+}
+
+src_install() {
+ findlib_src_install
+ dodoc README.md Changes
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/dev-ml/easy-format/metadata.xml b/dev-ml/easy-format/metadata.xml
new file mode 100644
index 000000000000..2193d772e351
--- /dev/null
+++ b/dev-ml/easy-format/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ml</herd>
+</pkgmetadata>