summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-06-11 22:20:01 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-06-11 22:20:01 +0000
commit877a6b3dda16e7c93f17cb940720495fb6b3814f (patch)
tree77b891953bce912221e3531e252d18edd84b7ede /dev-ml/findlib
parentStable for amd64 wrt bug #472736 (diff)
downloadgentoo-2-877a6b3dda16e7c93f17cb940720495fb6b3814f.tar.gz
gentoo-2-877a6b3dda16e7c93f17cb940720495fb6b3814f.tar.bz2
gentoo-2-877a6b3dda16e7c93f17cb940720495fb6b3814f.zip
version bump
(Portage version: 2.2.0_alpha179/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml/findlib')
-rw-r--r--dev-ml/findlib/ChangeLog7
-rw-r--r--dev-ml/findlib/findlib-1.4.ebuild70
2 files changed, 76 insertions, 1 deletions
diff --git a/dev-ml/findlib/ChangeLog b/dev-ml/findlib/ChangeLog
index ddf11ebffeeb..2f53c39b77e4 100644
--- a/dev-ml/findlib/ChangeLog
+++ b/dev-ml/findlib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/findlib
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/findlib/ChangeLog,v 1.105 2013/06/10 12:26:08 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/findlib/ChangeLog,v 1.106 2013/06/11 22:20:01 aballier Exp $
+
+*findlib-1.4 (11 Jun 2013)
+
+ 11 Jun 2013; Alexis Ballier <aballier@gentoo.org> +findlib-1.4.ebuild:
+ version bump
10 Jun 2013; Alexis Ballier <aballier@gentoo.org> -findlib-1.3.3.ebuild:
remove old
diff --git a/dev-ml/findlib/findlib-1.4.ebuild b/dev-ml/findlib/findlib-1.4.ebuild
new file mode 100644
index 000000000000..03d85adf8ae0
--- /dev/null
+++ b/dev-ml/findlib/findlib-1.4.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/findlib/findlib-1.4.ebuild,v 1.1 2013/06/11 22:20:01 aballier Exp $
+
+EAPI=5
+
+inherit multilib
+
+DESCRIPTION="OCaml tool to find/use non-standard packages."
+HOMEPAGE="http://projects.camlcity.org/projects/findlib.html"
+SRC_URI="http://download.camlcity.org/download/${P}.tar.gz"
+IUSE="doc +ocamlopt tk"
+
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+
+DEPEND=">=dev-lang/ocaml-3.10:=[ocamlopt?,tk?]"
+RDEPEND="${DEPEND}"
+
+ocamlfind_destdir="${EPREFIX}/usr/$(get_libdir)/ocaml"
+stublibs="${ocamlfind_destdir}/stublibs"
+
+src_configure() {
+ local myconf
+ use tk && myconf="-with-toolbox"
+ ./configure -bindir "${EPREFIX}"/usr/bin -mandir "${EPREFIX}"/usr/share/man \
+ -sitelib ${ocamlfind_destdir} \
+ -config ${ocamlfind_destdir}/findlib/findlib.conf \
+ -no-custom \
+ ${myconf} || die "configure failed"
+}
+
+src_compile() {
+ emake all
+ if use ocamlopt; then
+ emake opt # optimized code
+ fi
+}
+
+src_install() {
+ emake prefix="${D}" install
+
+ dodir "${stublibs#${EPREFIX}}"
+
+ cd "${S}/doc"
+ dodoc QUICKSTART README DOCINFO
+ use doc && dohtml -r ref-html guide-html
+}
+
+check_stublibs() {
+ local ocaml_stdlib=`ocamlc -where`
+ local ldconf="${ocaml_stdlib}/ld.conf"
+
+ if [ ! -e ${ldconf} ]
+ then
+ echo "${ocaml_stdlib}" > ${ldconf}
+ echo "${ocaml_stdlib}/stublibs" >> ${ldconf}
+ fi
+
+ if [ -z `grep -e ${stublibs} ${ldconf}` ]
+ then
+ echo ${stublibs} >> ${ldconf}
+ fi
+}
+
+pkg_postinst() {
+ check_stublibs
+}