summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2003-06-20 01:09:22 +0000
committerGeorge Shapovalov <george@gentoo.org>2003-06-20 01:09:22 +0000
commit3b09ded4a937e920a473461443fd3cdfa94312ed (patch)
tree4acc021f9444a64dc072932f228f739b335717ec /dev-ml/ocaml-make/ocaml-make-5.04.0.ebuild
parentnew package - a generic Makefile for simplification of ocaml Makefiles (diff)
downloadgentoo-2-3b09ded4a937e920a473461443fd3cdfa94312ed.tar.gz
gentoo-2-3b09ded4a937e920a473461443fd3cdfa94312ed.tar.bz2
gentoo-2-3b09ded4a937e920a473461443fd3cdfa94312ed.zip
new package - a generic Makefile for simplification of ocaml Makefiles
Diffstat (limited to 'dev-ml/ocaml-make/ocaml-make-5.04.0.ebuild')
-rw-r--r--dev-ml/ocaml-make/ocaml-make-5.04.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ml/ocaml-make/ocaml-make-5.04.0.ebuild b/dev-ml/ocaml-make/ocaml-make-5.04.0.ebuild
new file mode 100644
index 000000000000..38862fbf96de
--- /dev/null
+++ b/dev-ml/ocaml-make/ocaml-make-5.04.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-make/ocaml-make-5.04.0.ebuild,v 1.1 2003/06/20 01:09:11 george Exp $
+
+DESCRIPTION="Generic O'Caml Makefile for GNU Make"
+HOMEPAGE="http://www.ai.univie.ac.at/~markus/home/ocaml_sources.html"
+LICENSE="LGPL-2.1"
+
+DEPEND=">=dev-lang/ocaml-3.06-r1
+ >=dev-ml/findlib-0.8"
+SRC_URI="http://www.oefai.at/~markus/ocaml_sources/${P}.tar.bz2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc"
+IUSE=""
+S=${WORKDIR}/${P}
+
+src_compile() {
+ # Nothing to do
+ echo -n
+}
+
+src_install () {
+ # Just put the OCamlMakefile into /usr/include
+ # where GNU Make will automatically pick it up.
+ insinto /usr/include
+ doins OCamlMakefile
+ # install documentation
+ dodoc LICENSE README Changes
+}