summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-03-27 22:50:27 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-03-27 22:50:27 +0000
commit7a70c2267423b75d43ead8106dbc10e12db9c7d1 (patch)
tree62e741daf749c22f25804ad02bfe621e8ce3cd68 /dev-ml/ocamlify
parentAdd support for disabling debug useflag usage for old oasis versions (diff)
downloadgentoo-2-7a70c2267423b75d43ead8106dbc10e12db9c7d1.tar.gz
gentoo-2-7a70c2267423b75d43ead8106dbc10e12db9c7d1.tar.bz2
gentoo-2-7a70c2267423b75d43ead8106dbc10e12db9c7d1.zip
initial import, ebuild based on the one from Vladimir Ivanov in bug #355765 and converted to oasis.eclass
(Portage version: 2.2.0_alpha95/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml/ocamlify')
-rw-r--r--dev-ml/ocamlify/ChangeLog11
-rw-r--r--dev-ml/ocamlify/metadata.xml5
-rw-r--r--dev-ml/ocamlify/ocamlify-0.0.1.ebuild23
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-ml/ocamlify/ChangeLog b/dev-ml/ocamlify/ChangeLog
new file mode 100644
index 000000000000..c3bc00bb448a
--- /dev/null
+++ b/dev-ml/ocamlify/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-ml/ocamlify
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlify/ChangeLog,v 1.1 2012/03/27 22:50:27 aballier Exp $
+
+*ocamlify-0.0.1 (27 Mar 2012)
+
+ 27 Mar 2012; Alexis Ballier <aballier@gentoo.org> +ocamlify-0.0.1.ebuild,
+ +metadata.xml:
+ initial import, ebuild based on the one from Vladimir Ivanov in bug #355765
+ and converted to oasis.eclass
+
diff --git a/dev-ml/ocamlify/metadata.xml b/dev-ml/ocamlify/metadata.xml
new file mode 100644
index 000000000000..2193d772e351
--- /dev/null
+++ b/dev-ml/ocamlify/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ml</herd>
+</pkgmetadata>
diff --git a/dev-ml/ocamlify/ocamlify-0.0.1.ebuild b/dev-ml/ocamlify/ocamlify-0.0.1.ebuild
new file mode 100644
index 000000000000..e75aa557f773
--- /dev/null
+++ b/dev-ml/ocamlify/ocamlify-0.0.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlify/ocamlify-0.0.1.ebuild,v 1.1 2012/03/27 22:50:27 aballier Exp $
+
+EAPI=3
+
+OASIS_NO_DEBUG=1
+
+inherit oasis
+
+DESCRIPTION="OCamlify allows to create OCaml source code by including whole file into OCaml string or string list"
+HOMEPAGE="http://forge.ocamlcore.org/projects/ocamlify"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/379/${P}.tar.gz"
+
+LICENSE="LGPL-2.1-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+IUSE=""
+
+DOCS=( "README.txt" "AUTHORS.txt" )