summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-03-07 09:28:17 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-03-07 09:28:17 +0000
commitde822837b039252ba3f029c3f41f2e7b5d026b25 (patch)
tree107d8b92452f2bfb6ae12d3645adeb08a30cda53 /dev-ml/ocamlnet/ocamlnet-3.5.1.ebuild
parentremove old (diff)
downloadgentoo-2-de822837b039252ba3f029c3f41f2e7b5d026b25.tar.gz
gentoo-2-de822837b039252ba3f029c3f41f2e7b5d026b25.tar.bz2
gentoo-2-de822837b039252ba3f029c3f41f2e7b5d026b25.zip
version bump
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml/ocamlnet/ocamlnet-3.5.1.ebuild')
-rw-r--r--dev-ml/ocamlnet/ocamlnet-3.5.1.ebuild75
1 files changed, 75 insertions, 0 deletions
diff --git a/dev-ml/ocamlnet/ocamlnet-3.5.1.ebuild b/dev-ml/ocamlnet/ocamlnet-3.5.1.ebuild
new file mode 100644
index 000000000000..534d0ffcc0b9
--- /dev/null
+++ b/dev-ml/ocamlnet/ocamlnet-3.5.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ocamlnet-3.5.1.ebuild,v 1.1 2012/03/07 09:28:17 aballier Exp $
+
+EAPI="2"
+
+inherit eutils findlib
+
+MY_P=${P/_beta/test}
+DESCRIPTION="Modules for OCaml application-level Internet protocols"
+HOMEPAGE="http://projects.camlcity.org/projects/ocamlnet.html"
+SRC_URI="http://download.camlcity.org/download/${MY_P}.tar.gz"
+
+LICENSE="as-is GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="cryptokit gtk ssl tk httpd +ocamlopt +pcre zip"
+RESTRICT="installsources"
+
+# the auth-dh compile flag has been disabled as well, since it depends on
+# ocaml-cryptgps, which is not available.
+
+DEPEND=">=dev-ml/findlib-1.0
+ pcre? ( >=dev-ml/pcre-ocaml-5 )
+ >=dev-lang/ocaml-3.10.2[tk?,ocamlopt?]
+ cryptokit? ( dev-ml/cryptokit )
+ gtk? ( >=dev-ml/lablgtk-2 )
+ ssl? ( >=dev-ml/ocaml-ssl-0.4 )
+ zip? ( dev-ml/camlzip )
+ "
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+ocamlnet_use_with() {
+ if use $1; then
+ echo "-with-$2"
+ else
+ echo "-without-$2"
+ fi
+}
+
+ocamlnet_use_enable() {
+ if use $1; then
+ echo "-enable-$2"
+ else
+ echo "-disable-$2"
+ fi
+}
+
+src_configure() {
+ ./configure \
+ -bindir /usr/bin \
+ -datadir /usr/share/${PN} \
+ $(ocamlnet_use_enable cryptokit crypto) \
+ $(ocamlnet_use_enable gtk gtk2) \
+ $(ocamlnet_use_enable pcre pcre) \
+ $(ocamlnet_use_enable ssl ssl) \
+ $(ocamlnet_use_enable tk tcl) \
+ $(ocamlnet_use_enable zip zip) \
+ $(ocamlnet_use_with httpd nethttpd) \
+ || die "Error : econf failed!"
+}
+
+src_compile() {
+ emake -j1 all || die "make failed"
+ if use ocamlopt; then
+ emake -j1 opt || die "make failed"
+ fi
+}
+
+src_install() {
+ export STRIP_MASK="*/bin/*"
+ findlib_src_install
+}