summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-08-19 13:13:31 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-08-19 13:13:31 +0000
commit795ee708088c7651946951624778aa94b745afb3 (patch)
tree017ff58646242fb71f7ce916aed7d2c5656a8d5a /dev-ml/ocamlnet
parentvanilla-2.6.32.61 + genpatches-2.6.32-48 + grsecurity-2.9.1-2.6.32.61-2013081... (diff)
downloadgentoo-2-795ee708088c7651946951624778aa94b745afb3.tar.gz
gentoo-2-795ee708088c7651946951624778aa94b745afb3.tar.bz2
gentoo-2-795ee708088c7651946951624778aa94b745afb3.zip
Fix build with ocaml 4.01.
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml/ocamlnet')
-rw-r--r--dev-ml/ocamlnet/ChangeLog6
-rw-r--r--dev-ml/ocamlnet/files/ocamlnet-3.6.6-ocaml-4.01.patch13
-rw-r--r--dev-ml/ocamlnet/ocamlnet-3.6.6.ebuild6
3 files changed, 23 insertions, 2 deletions
diff --git a/dev-ml/ocamlnet/ChangeLog b/dev-ml/ocamlnet/ChangeLog
index 95edad1e43e0..321a8fb4cf04 100644
--- a/dev-ml/ocamlnet/ChangeLog
+++ b/dev-ml/ocamlnet/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ml/ocamlnet
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ChangeLog,v 1.76 2013/07/22 00:17:22 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ChangeLog,v 1.77 2013/08/19 13:13:31 aballier Exp $
+
+ 19 Aug 2013; Alexis Ballier <aballier@gentoo.org> ocamlnet-3.6.6.ebuild,
+ +files/ocamlnet-3.6.6-ocaml-4.01.patch:
+ Fix build with ocaml 4.01.
*ocamlnet-3.6.6 (22 Jul 2013)
diff --git a/dev-ml/ocamlnet/files/ocamlnet-3.6.6-ocaml-4.01.patch b/dev-ml/ocamlnet/files/ocamlnet-3.6.6-ocaml-4.01.patch
new file mode 100644
index 000000000000..9e8d344ca42e
--- /dev/null
+++ b/dev-ml/ocamlnet/files/ocamlnet-3.6.6-ocaml-4.01.patch
@@ -0,0 +1,13 @@
+Index: ocamlnet-3.6.6/src/netsys/netsys_posix.ml
+===================================================================
+--- ocamlnet-3.6.6.orig/src/netsys/netsys_posix.ml
++++ ocamlnet-3.6.6/src/netsys/netsys_posix.ml
+@@ -705,7 +705,7 @@ type at_flag = AT_EACCESS | AT_SYMLINK_N
+ IFDEF HAVE_O_SHARE_DELETE THEN
+ type open_flag1 = Unix.open_flag =
+ O_RDONLY | O_WRONLY | O_RDWR | O_NONBLOCK | O_APPEND | O_CREAT | O_TRUNC
+- | O_EXCL | O_NOCTTY | O_DSYNC | O_SYNC | O_RSYNC | O_SHARE_DELETE
++ | O_EXCL | O_NOCTTY | O_DSYNC | O_SYNC | O_RSYNC | O_SHARE_DELETE | O_CLOEXEC
+ ELSE
+ type open_flag1 = Unix.open_flag =
+ O_RDONLY | O_WRONLY | O_RDWR | O_NONBLOCK | O_APPEND | O_CREAT | O_TRUNC
diff --git a/dev-ml/ocamlnet/ocamlnet-3.6.6.ebuild b/dev-ml/ocamlnet/ocamlnet-3.6.6.ebuild
index a6f81ff3e8d5..706de14fa059 100644
--- a/dev-ml/ocamlnet/ocamlnet-3.6.6.ebuild
+++ b/dev-ml/ocamlnet/ocamlnet-3.6.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ocamlnet-3.6.6.ebuild,v 1.1 2013/07/22 00:17:22 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ocamlnet-3.6.6.ebuild,v 1.2 2013/08/19 13:13:31 aballier Exp $
EAPI="5"
@@ -32,6 +32,10 @@ RDEPEND="${DEPEND}"
S=${WORKDIR}/${MY_P}
+src_prepare() {
+ has_version '>=dev-lang/ocaml-4.01.0_beta' && epatch "${FILESDIR}/${P}-ocaml-4.01.patch"
+}
+
ocamlnet_use_with() {
if use $1; then
echo "-with-$2"