summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthieu Sozeau <mattam@gentoo.org>2006-02-04 17:05:19 +0000
committerMatthieu Sozeau <mattam@gentoo.org>2006-02-04 17:05:19 +0000
commit3022262698a5036b9147b71ff1a553faffbeb4ef (patch)
treeadbb37444188571f562c429ee549b5c8b64b0f0b /dev-ml/ocamlweb/ocamlweb-1.37.ebuild
parentnew cvs snappshot, will work with vdr >=1.3.38 (diff)
downloadgentoo-2-3022262698a5036b9147b71ff1a553faffbeb4ef.tar.gz
gentoo-2-3022262698a5036b9147b71ff1a553faffbeb4ef.tar.bz2
gentoo-2-3022262698a5036b9147b71ff1a553faffbeb4ef.zip
Version bump. Remove obsolete version.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'dev-ml/ocamlweb/ocamlweb-1.37.ebuild')
-rw-r--r--dev-ml/ocamlweb/ocamlweb-1.37.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-ml/ocamlweb/ocamlweb-1.37.ebuild b/dev-ml/ocamlweb/ocamlweb-1.37.ebuild
new file mode 100644
index 000000000000..4de1ca908dce
--- /dev/null
+++ b/dev-ml/ocamlweb/ocamlweb-1.37.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlweb/ocamlweb-1.37.ebuild,v 1.1 2006/02/04 17:05:19 mattam Exp $
+
+DESCRIPTION="O'Caml literate programming tool"
+HOMEPAGE="http://www.lri.fr/~filliatr/ocamlweb/"
+SRC_URI="http://www.lri.fr/~filliatr/ftp/ocamlweb/${P}.tar.gz"
+
+IUSE=""
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+
+DEPEND=">=dev-lang/ocaml-3.09
+virtual/tetex"
+
+src_compile() {
+ econf || die
+ emake || die
+}
+
+src_install() {
+ emake UPDATETEX="" prefix=${D}/usr MANDIR=${D}/usr/share/man install || die
+ dodoc README COPYING CHANGES
+}
+
+tex_regen() {
+ einfo "Regenerating TeX database..."
+ /usr/bin/mktexlsr /usr/share/texmf /var/spool/texmf > /dev/null
+ eend $?
+}
+
+pkg_postinst() {
+ tex_regen
+}
+
+pkg_postrm() {
+ tex_regen
+}