summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-06-28 15:22:02 +0000
committerAlexis Ballier <aballier@gentoo.org>2015-06-28 15:22:02 +0000
commitb680c9e319dfdcf65d4b17163450b17db3b25d19 (patch)
tree0e30e3503fa06f2a066e10422135ef1d2ee57988 /dev-ml/ocurl
parentalpha stable wrt bug #552324 (diff)
downloadgentoo-2-b680c9e319dfdcf65d4b17163450b17db3b25d19.tar.gz
gentoo-2-b680c9e319dfdcf65d4b17163450b17db3b25d19.tar.bz2
gentoo-2-b680c9e319dfdcf65d4b17163450b17db3b25d19.zip
version bump
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml/ocurl')
-rw-r--r--dev-ml/ocurl/ChangeLog7
-rw-r--r--dev-ml/ocurl/ocurl-0.7.4.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/dev-ml/ocurl/ChangeLog b/dev-ml/ocurl/ChangeLog
index f2484568c314..57516d77b2c9 100644
--- a/dev-ml/ocurl/ChangeLog
+++ b/dev-ml/ocurl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/ocurl
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocurl/ChangeLog,v 1.22 2015/02/25 15:35:39 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocurl/ChangeLog,v 1.23 2015/06/28 15:22:02 aballier Exp $
+
+*ocurl-0.7.4 (28 Jun 2015)
+
+ 28 Jun 2015; Alexis Ballier <aballier@gentoo.org> +ocurl-0.7.4.ebuild:
+ version bump
25 Feb 2015; Agostino Sarubbo <ago@gentoo.org> ocurl-0.6.1.ebuild:
Stable for x86, wrt bug #535132
diff --git a/dev-ml/ocurl/ocurl-0.7.4.ebuild b/dev-ml/ocurl/ocurl-0.7.4.ebuild
new file mode 100644
index 000000000000..f3921f5a8143
--- /dev/null
+++ b/dev-ml/ocurl/ocurl-0.7.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocurl/ocurl-0.7.4.ebuild,v 1.1 2015/06/28 15:22:02 aballier Exp $
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="OCaml interface to the libcurl library"
+HOMEPAGE="http://forge.ocamlcore.org/projects/ocurl/"
+LICENSE="MIT"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/1523/${P}.tar.gz"
+
+SLOT="0/${PV}"
+IUSE="examples"
+
+RDEPEND=">=net-misc/curl-7.9.8
+ dev-ml/lwt:=
+ >=dev-lang/ocaml-3.12:=[ocamlopt]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+KEYWORDS="~amd64 ~x86"
+
+src_compile()
+{
+ emake -j1 all
+}
+
+src_install()
+{
+ findlib_src_install
+ dodoc CHANGES.txt README
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}