summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2014-10-30 17:28:10 +0000
committerAlexis Ballier <aballier@gentoo.org>2014-10-30 17:28:10 +0000
commit177f56e602c9c7192ec60c00dea81797d48c6d14 (patch)
treee9a97bcf73564263e9d008c0c978a1a4f658b464 /dev-ml/xmlm
parentVersion bumps. Remove old (diff)
downloadgentoo-2-177f56e602c9c7192ec60c00dea81797d48c6d14.tar.gz
gentoo-2-177f56e602c9c7192ec60c00dea81797d48c6d14.tar.bz2
gentoo-2-177f56e602c9c7192ec60c00dea81797d48c6d14.zip
version bump
Signed-off-by: aballier@gentoo.org (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml/xmlm')
-rw-r--r--dev-ml/xmlm/ChangeLog9
-rw-r--r--dev-ml/xmlm/xmlm-1.2.0.ebuild36
2 files changed, 43 insertions, 2 deletions
diff --git a/dev-ml/xmlm/ChangeLog b/dev-ml/xmlm/ChangeLog
index 6059388f1b03..7c0c5e7d5428 100644
--- a/dev-ml/xmlm/ChangeLog
+++ b/dev-ml/xmlm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/xmlm
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/xmlm/ChangeLog,v 1.9 2013/03/17 15:50:21 hwoarang Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/xmlm/ChangeLog,v 1.10 2014/10/30 17:28:10 aballier Exp $
+
+*xmlm-1.2.0 (30 Oct 2014)
+
+ 30 Oct 2014; Alexis Ballier <aballier@gentoo.org> +xmlm-1.2.0.ebuild:
+ version bump
17 Mar 2013; Markos Chandras <hwoarang@gentoo.org> metadata.xml:
Add proxy-maintainers to metadata.xml
diff --git a/dev-ml/xmlm/xmlm-1.2.0.ebuild b/dev-ml/xmlm/xmlm-1.2.0.ebuild
new file mode 100644
index 000000000000..7653be0b174f
--- /dev/null
+++ b/dev-ml/xmlm/xmlm-1.2.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/xmlm/xmlm-1.2.0.ebuild,v 1.1 2014/10/30 17:28:10 aballier Exp $
+
+EAPI=5
+
+DESCRIPTION="Ocaml XML manipulation module"
+HOMEPAGE="http://erratique.ch/software/xmlm"
+SRC_URI="http://erratique.ch/software/${PN}/releases/${P}.tbz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="doc +ocamlopt"
+
+RDEPEND=">=dev-lang/ocaml-3.12:=[ocamlopt?]"
+DEPEND="${RDEPEND}
+ dev-ml/findlib
+ dev-ml/opam
+"
+
+src_compile() {
+ pkg/build \
+ $(usex ocamlopt true false) \
+ || die
+}
+
+src_install() {
+ opam-installer \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ || die
+ dodoc CHANGES.md README.md
+ use doc && dohtml doc/*
+}