summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-01-04 02:07:57 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-01-04 02:07:57 +0000
commit16ff9a27bf8d7bb5859ce4409abf97d96f42679b (patch)
tree1230c5208a88254b68bc66cc75dc8cc8f95984f0 /dev-ml
parentversion bump, allow to build without ocamlopt (diff)
downloadgentoo-2-16ff9a27bf8d7bb5859ce4409abf97d96f42679b.tar.gz
gentoo-2-16ff9a27bf8d7bb5859ce4409abf97d96f42679b.tar.bz2
gentoo-2-16ff9a27bf8d7bb5859ce4409abf97d96f42679b.zip
add support to not build with ocmlopt
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/postgresql-ocaml/ChangeLog8
-rw-r--r--dev-ml/postgresql-ocaml/postgresql-ocaml-1.7.0.ebuild31
2 files changed, 31 insertions, 8 deletions
diff --git a/dev-ml/postgresql-ocaml/ChangeLog b/dev-ml/postgresql-ocaml/ChangeLog
index 8805ee754373..9d86d828bd98 100644
--- a/dev-ml/postgresql-ocaml/ChangeLog
+++ b/dev-ml/postgresql-ocaml/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ml/postgresql-ocaml
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/ChangeLog,v 1.3 2007/08/23 08:31:37 aballier Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/ChangeLog,v 1.4 2008/01/04 02:07:57 aballier Exp $
+
+ 04 Jan 2008; Alexis Ballier <aballier@gentoo.org>
+ postgresql-ocaml-1.7.0.ebuild:
+ add support to not build with ocmlopt
*postgresql-ocaml-1.7.0 (23 Aug 2007)
diff --git a/dev-ml/postgresql-ocaml/postgresql-ocaml-1.7.0.ebuild b/dev-ml/postgresql-ocaml/postgresql-ocaml-1.7.0.ebuild
index 11bf3d881b79..1ebd8f281df7 100644
--- a/dev-ml/postgresql-ocaml/postgresql-ocaml-1.7.0.ebuild
+++ b/dev-ml/postgresql-ocaml/postgresql-ocaml-1.7.0.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/postgresql-ocaml-1.7.0.ebuild,v 1.1 2007/08/23 08:31:37 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/postgresql-ocaml-1.7.0.ebuild,v 1.2 2008/01/04 02:07:57 aballier Exp $
-inherit findlib
+inherit findlib eutils
-IUSE="examples"
+EAPI="1"
+
+IUSE="examples +ocamlopt"
DESCRIPTION="A package for ocaml that provides access to PostgreSQL databases."
SRC_URI="http://ocaml.info/ocaml_sources/${P}.tar.bz2"
@@ -18,8 +20,25 @@ SLOT="0"
LICENSE="LGPL-2"
KEYWORDS="~amd64 ~ppc ~x86"
-src_install()
-{
+pkg_setup() {
+ if use ocamlopt && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
+ eerror "In order to build ${PN} with native code support from ocaml"
+ eerror "You first need to have a native code ocaml compiler."
+ eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
+ die "Please install ocaml with ocamlopt useflag"
+ fi
+}
+
+src_compile() {
+ cd "${S}/lib"
+ emake -j1 byte-code-library || die "failed to build byte code library"
+ if use ocamlopt; then
+ emake -j1 native-code-library || die "failed to built nativde code library"
+ fi
+}
+
+src_install () {
+ use ocamlopt || export OCAMLFIND_INSTFLAGS="-optional"
findlib_src_preinst
emake DESTDIR="${D}" install || die
dodoc AUTHORS VERSION