summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-08-02 12:37:53 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-08-02 12:37:53 +0000
commit45fe5151265d8f263ee43a66a616b2b356951088 (patch)
tree27d9630e764f5a712eb25e7be8ac0c1b5fbd6283 /dev-ml
parent(soft) block older versions of tl-mathextra as they collide, bug #429432 by ... (diff)
downloadgentoo-2-45fe5151265d8f263ee43a66a616b2b356951088.tar.gz
gentoo-2-45fe5151265d8f263ee43a66a616b2b356951088.tar.bz2
gentoo-2-45fe5151265d8f263ee43a66a616b2b356951088.zip
version bump
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/utop/ChangeLog7
-rw-r--r--dev-ml/utop/utop-1.2.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/dev-ml/utop/ChangeLog b/dev-ml/utop/ChangeLog
index 0852bede82fa..fb8a6c9a5b32 100644
--- a/dev-ml/utop/ChangeLog
+++ b/dev-ml/utop/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/utop
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/utop/ChangeLog,v 1.1 2012/03/30 11:52:39 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/utop/ChangeLog,v 1.2 2012/08/02 12:37:53 aballier Exp $
+
+*utop-1.2 (02 Aug 2012)
+
+ 02 Aug 2012; Alexis Ballier <aballier@gentoo.org> +utop-1.2.ebuild:
+ version bump
*utop-1.1 (30 Mar 2012)
diff --git a/dev-ml/utop/utop-1.2.ebuild b/dev-ml/utop/utop-1.2.ebuild
new file mode 100644
index 000000000000..a91c2270058b
--- /dev/null
+++ b/dev-ml/utop/utop-1.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/utop/utop-1.2.ebuild,v 1.1 2012/08/02 12:37:53 aballier Exp $
+
+EAPI=4
+
+OASIS_BUILD_DOCS=1
+inherit oasis elisp-common
+
+DESCRIPTION="A new toplevel for OCaml with completion and colorization"
+HOMEPAGE="http://forge.ocamlcore.org/projects/utop/"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/949/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="emacs"
+
+DEPEND=">=dev-ml/lwt-2.4.0[react]
+ >=dev-ml/lambda-term-1.2
+ >=dev-ml/zed-1.2
+ emacs? ( virtual/emacs )"
+RDEPEND="${DEPEND}"
+
+DOCS=( "CHANGES" "README" )
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ sed -i "s/(\"utop.el.*)//" setup.ml
+}
+
+src_compile() {
+ oasis_src_compile
+ if use emacs; then
+ elisp-compile src/top/*.el
+ fi
+}
+
+src_install() {
+ oasis_src_install
+ if use emacs; then
+ elisp-install "${PN}" src/top/*.el src/top/*.elc || die
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}