summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-01-03 21:10:25 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-01-03 21:10:25 +0000
commit5ddd507e8942c94784a4ba1dd24c4b5a0fcc8452 (patch)
tree29faf4b02564d7b337fb8d0e71a9cac8c317a64d /dev-ml
parentMarking ktorrent-2.2.4 ppc64 for bug 203756 (diff)
downloadgentoo-2-5ddd507e8942c94784a4ba1dd24c4b5a0fcc8452.tar.gz
gentoo-2-5ddd507e8942c94784a4ba1dd24c4b5a0fcc8452.tar.bz2
gentoo-2-5ddd507e8942c94784a4ba1dd24c4b5a0fcc8452.zip
Allow to disable ocamlopt via an useflag
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/camomile/ChangeLog7
-rw-r--r--dev-ml/camomile/camomile-0.7.1.ebuild28
2 files changed, 26 insertions, 9 deletions
diff --git a/dev-ml/camomile/ChangeLog b/dev-ml/camomile/ChangeLog
index 17979944d188..6a269147ac14 100644
--- a/dev-ml/camomile/ChangeLog
+++ b/dev-ml/camomile/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ml/camomile
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camomile/ChangeLog,v 1.9 2007/05/26 21:19:46 aballier Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camomile/ChangeLog,v 1.10 2008/01/03 21:10:25 aballier Exp $
+
+ 03 Jan 2008; Alexis Ballier <aballier@gentoo.org> camomile-0.7.1.ebuild:
+ Allow to disable ocamlopt via an useflag
*camomile-0.7.1 (26 May 2007)
diff --git a/dev-ml/camomile/camomile-0.7.1.ebuild b/dev-ml/camomile/camomile-0.7.1.ebuild
index 143148123e6c..9df365f6f2d5 100644
--- a/dev-ml/camomile/camomile-0.7.1.ebuild
+++ b/dev-ml/camomile/camomile-0.7.1.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camomile/camomile-0.7.1.ebuild,v 1.1 2007/05/26 21:19:46 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camomile/camomile-0.7.1.ebuild,v 1.2 2008/01/03 21:10:25 aballier Exp $
-inherit findlib
+inherit findlib eutils
+
+EAPI="1"
DESCRIPTION="Camomile is a comprehensive Unicode library for ocaml."
HOMEPAGE="http://camomile.sourceforge.net/"
@@ -11,16 +13,28 @@ SRC_URI="mirror://sourceforge/camomile/${P}.tar.bz2"
LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="debug"
+IUSE="debug +ocamlopt"
DEPEND=">=dev-lang/ocaml-3.07"
+pkg_setup() {
+ if use ocamlopt && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
+ eerror "In order to build ${PN} with native code support from ocaml"
+ eerror "You first need to have a native code ocaml compiler."
+ eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
+ die "Please install ocaml with ocamlopt useflag"
+ fi
+}
+
src_compile() {
- econf $(use_enable debug) || die
- emake -j1
+ econf $(use_enable debug)
+ emake -j1 byte unidata unimaps charmap_data locale_data || die "failed to build"
+ if use ocamlopt; then
+ emake -j1 opt || die "failed to build native code"
+ fi
}
src_install() {
- mkdir -p "${D}/usr/bin"
+ dodir /usr/bin
findlib_src_install DATADIR="${D}/usr/share" BINDIR="${D}/usr/bin"
}