summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2014-12-08 09:57:39 +0000
committerAlexis Ballier <aballier@gentoo.org>2014-12-08 09:57:39 +0000
commita2a62e7763d65c2fb22fa853e1b7668f434a33ca (patch)
tree74673c4765315dc85d9b196af2ea2a037b0a1162 /dev-ml
parentversion bump (diff)
downloadgentoo-2-a2a62e7763d65c2fb22fa853e1b7668f434a33ca.tar.gz
gentoo-2-a2a62e7763d65c2fb22fa853e1b7668f434a33ca.tar.bz2
gentoo-2-a2a62e7763d65c2fb22fa853e1b7668f434a33ca.zip
version bump
Signed-off-by: aballier@gentoo.org (Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/pcre-ocaml/ChangeLog7
-rw-r--r--dev-ml/pcre-ocaml/pcre-ocaml-7.1.3.ebuild31
2 files changed, 37 insertions, 1 deletions
diff --git a/dev-ml/pcre-ocaml/ChangeLog b/dev-ml/pcre-ocaml/ChangeLog
index 00b0bc76f2df..bb39ca6c0a45 100644
--- a/dev-ml/pcre-ocaml/ChangeLog
+++ b/dev-ml/pcre-ocaml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/pcre-ocaml
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/pcre-ocaml/ChangeLog,v 1.53 2014/01/19 13:18:26 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pcre-ocaml/ChangeLog,v 1.54 2014/12/08 09:57:39 aballier Exp $
+
+*pcre-ocaml-7.1.3 (08 Dec 2014)
+
+ 08 Dec 2014; Alexis Ballier <aballier@gentoo.org> +pcre-ocaml-7.1.3.ebuild:
+ version bump
*pcre-ocaml-7.0.4 (19 Jan 2014)
diff --git a/dev-ml/pcre-ocaml/pcre-ocaml-7.1.3.ebuild b/dev-ml/pcre-ocaml/pcre-ocaml-7.1.3.ebuild
new file mode 100644
index 000000000000..09d7b85c39c3
--- /dev/null
+++ b/dev-ml/pcre-ocaml/pcre-ocaml-7.1.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pcre-ocaml/pcre-ocaml-7.1.3.ebuild,v 1.1 2014/12/08 09:57:39 aballier Exp $
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="Perl Compatibility Regular Expressions for O'Caml"
+HOMEPAGE="http://mmottl.github.io/pcre-ocaml/ https://github.com/mmottl/pcre-ocaml"
+SRC_URI="https://github.com/mmottl/pcre-ocaml/releases/download/v${PV}/${P}.tar.gz"
+LICENSE="LGPL-2.1-with-linking-exception"
+IUSE="examples"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+RDEPEND=">=dev-libs/libpcre-4.5
+ >=dev-lang/ocaml-4:="
+DEPEND="${RDEPEND}"
+
+DOCS=( "AUTHORS.txt" "CHANGES.txt" "README.md" )
+
+src_install() {
+ oasis_src_install
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}