summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorMatthieu Sozeau <mattam@gentoo.org>2004-08-25 12:44:43 +0000
committerMatthieu Sozeau <mattam@gentoo.org>2004-08-25 12:44:43 +0000
commitd3e4c987b8963d7b6a4d120ed3631ad156ce7cec (patch)
treebbc96347955dfb43777abaf717846f4f6ea85d08 /dev-ml
parentAdded ~sparc keyword. (Manifest recommit) (diff)
downloadgentoo-2-d3e4c987b8963d7b6a4d120ed3631ad156ce7cec.tar.gz
gentoo-2-d3e4c987b8963d7b6a4d120ed3631ad156ce7cec.tar.bz2
gentoo-2-d3e4c987b8963d7b6a4d120ed3631ad156ce7cec.zip
New revision using findlib eclass.
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/camlzip/ChangeLog8
-rw-r--r--dev-ml/camlzip/Manifest9
-rw-r--r--dev-ml/camlzip/camlzip-1.01-r1.ebuild36
-rw-r--r--dev-ml/camlzip/files/META2
-rw-r--r--dev-ml/camlzip/files/camlzip-1.01-Makefile-findlib.patch23
-rw-r--r--dev-ml/camlzip/files/digest-camlzip-1.01-r11
6 files changed, 74 insertions, 5 deletions
diff --git a/dev-ml/camlzip/ChangeLog b/dev-ml/camlzip/ChangeLog
index 644f905da063..a86e946bf8b6 100644
--- a/dev-ml/camlzip/ChangeLog
+++ b/dev-ml/camlzip/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/camlzip
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlzip/ChangeLog,v 1.1 2004/08/18 12:01:52 mattam Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlzip/ChangeLog,v 1.2 2004/08/25 12:44:43 mattam Exp $
+
+*camlzip-1.01-r1 (25 Aug 2004)
+
+ 25 Aug 2004; Matthieu Sozeau <mattam@gentoo.org> files/META,
+ +files/camlzip-1.01-Makefile-findlib.patch, +camlzip-1.01-r1.ebuild:
+ Move to findlib eclass, ebuild cleanup.
*camlzip-1.01 (18 Aug 2004)
diff --git a/dev-ml/camlzip/Manifest b/dev-ml/camlzip/Manifest
index 525c7c402a9f..2f9ab22264e1 100644
--- a/dev-ml/camlzip/Manifest
+++ b/dev-ml/camlzip/Manifest
@@ -1,5 +1,8 @@
-MD5 a737327021264edfcf9fcdb572849338 camlzip-1.01.ebuild 1996
MD5 8b350f19c06fcabf1053b0421b7c3f5a metadata.xml 155
-MD5 e24ee6e6e31c30d81f700d3362c28b21 ChangeLog 485
-MD5 144d02af76045780262191bff2b44b62 files/META 104
+MD5 e58d0523d9dcc306e56d9dd3dfb800d9 ChangeLog 694
+MD5 a737327021264edfcf9fcdb572849338 camlzip-1.01.ebuild 1996
+MD5 48b88af8b3a6c5c173846151d03d720f camlzip-1.01-r1.ebuild 874
+MD5 357f403e3152810089ea2f7bb86bf77d files/META 107
MD5 247ab601d786744715f10b4952872f98 files/digest-camlzip-1.01 63
+MD5 34f19ca145eb89c455a8767467331619 files/camlzip-1.01-Makefile-findlib.patch 801
+MD5 247ab601d786744715f10b4952872f98 files/digest-camlzip-1.01-r1 63
diff --git a/dev-ml/camlzip/camlzip-1.01-r1.ebuild b/dev-ml/camlzip/camlzip-1.01-r1.ebuild
new file mode 100644
index 000000000000..9b8930ff974a
--- /dev/null
+++ b/dev-ml/camlzip/camlzip-1.01-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlzip/camlzip-1.01-r1.ebuild,v 1.1 2004/08/25 12:44:43 mattam Exp $
+
+inherit findlib eutils
+
+IUSE=""
+
+DESCRIPTION="Compressed file access ML library (ZIP, GZIP and JAR)"
+HOMEPAGE="http://cristal.inria.fr/~xleroy/software.html#camlzip"
+SRC_URI="http://caml.inria.fr/distrib/bazar-ocaml/${P}.tar.gz"
+
+SLOT="1"
+LICENSE="LGPL-2.1"
+KEYWORDS="~x86 ~ppc"
+
+DEPEND=">=dev-lang/ocaml-3.04 \
+ >=sys-libs/zlib-1.1.3"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-Makefile-findlib.patch
+ sed -e "s/VERSION/${PV}/" ${FILESDIR}/META >> META
+}
+
+src_compile() {
+ make all || die "Failed at compilation step !!!"
+ make allopt || die "Failed at ML compilation step !!!"
+}
+
+src_install() {
+ findlib_src_install
+
+ dodoc README
+}
diff --git a/dev-ml/camlzip/files/META b/dev-ml/camlzip/files/META
index c852fa144a55..988a4fc1185d 100644
--- a/dev-ml/camlzip/files/META
+++ b/dev-ml/camlzip/files/META
@@ -1,4 +1,4 @@
-version="1.01"
+version="VERSION"
requires="unix"
linkopts="-cclib -lz"
archive(byte)="zip.cma"
diff --git a/dev-ml/camlzip/files/camlzip-1.01-Makefile-findlib.patch b/dev-ml/camlzip/files/camlzip-1.01-Makefile-findlib.patch
new file mode 100644
index 000000000000..e7c4014d3c82
--- /dev/null
+++ b/dev-ml/camlzip/files/camlzip-1.01-Makefile-findlib.patch
@@ -0,0 +1,23 @@
+--- Makefile.orig 2004-08-25 14:34:02.963205056 +0200
++++ Makefile 2004-08-25 14:35:28.916138224 +0200
+@@ -55,18 +55,8 @@
+ rm -f *.o *.a
+
+ install:
+- mkdir -p $(INSTALLDIR)
+- cp zip.cma zip.cmi gzip.cmi zip.mli gzip.mli libcamlzip.a $(INSTALLDIR)
+- if test -f dllcamlzip.so; then \
+- cp dllcamlzip.so $(INSTALLDIR); \
+- ldconf=`$(OCAMLC) -where`/ld.conf; \
+- installdir=$(INSTALLDIR); \
+- if test `grep -s -c $$installdir'$$' $$ldconf || :` = 0; \
+- then echo $$installdir >> $$ldconf; fi \
+- fi
+-
+-installopt:
+- cp zip.cmxa zip.a zip.cmx gzip.cmx $(INSTALLDIR)
++ ocamlfind install camlzip META zip.cma zip.cmi gzip.cmi zip.mli gzip.mli libcamlzip.a dllcamlzip.so \
++ zip.cmxa zip.a zip.cmx gzip.cmx
+
+ depend:
+ gcc -MM -I$(ZLIB_INCLUDE) *.c > .depend
diff --git a/dev-ml/camlzip/files/digest-camlzip-1.01-r1 b/dev-ml/camlzip/files/digest-camlzip-1.01-r1
new file mode 100644
index 000000000000..0d0e36c33ebe
--- /dev/null
+++ b/dev-ml/camlzip/files/digest-camlzip-1.01-r1
@@ -0,0 +1 @@
+MD5 728940dc0958493274314d576c16ef68 camlzip-1.01.tar.gz 15113