summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-01-04 01:27:16 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-01-04 01:27:16 +0000
commitdf83dca2ca87a24ba1ef987591f77e4abfd4da35 (patch)
tree33e08d6c2fa87f3a026ccf8d88215ef2776bb965 /dev-ml
parentMarking lcms-1.17 ppc for bug 203237 (diff)
downloadgentoo-2-df83dca2ca87a24ba1ef987591f77e4abfd4da35.tar.gz
gentoo-2-df83dca2ca87a24ba1ef987591f77e4abfd4da35.tar.bz2
gentoo-2-df83dca2ca87a24ba1ef987591f77e4abfd4da35.zip
version bump, allow building without ocamlopt
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocamlgraph/ChangeLog10
-rw-r--r--dev-ml/ocamlgraph/files/digest-ocamlgraph-0.99b3
-rw-r--r--dev-ml/ocamlgraph/files/ocamlgraph-0.99b-installfindlib.patch21
-rw-r--r--dev-ml/ocamlgraph/ocamlgraph-0.99b.ebuild71
4 files changed, 103 insertions, 2 deletions
diff --git a/dev-ml/ocamlgraph/ChangeLog b/dev-ml/ocamlgraph/ChangeLog
index f0013436e0a7..d96d435eb0ea 100644
--- a/dev-ml/ocamlgraph/ChangeLog
+++ b/dev-ml/ocamlgraph/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/ocamlgraph
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlgraph/ChangeLog,v 1.5 2007/05/26 19:34:05 aballier Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlgraph/ChangeLog,v 1.6 2008/01/04 01:27:16 aballier Exp $
+
+*ocamlgraph-0.99b (04 Jan 2008)
+
+ 04 Jan 2008; Alexis Ballier <aballier@gentoo.org>
+ +files/ocamlgraph-0.99b-installfindlib.patch, +ocamlgraph-0.99b.ebuild:
+ version bump, allow building without ocamlopt
*ocamlgraph-0.98 (26 May 2007)
diff --git a/dev-ml/ocamlgraph/files/digest-ocamlgraph-0.99b b/dev-ml/ocamlgraph/files/digest-ocamlgraph-0.99b
new file mode 100644
index 000000000000..a3d825707350
--- /dev/null
+++ b/dev-ml/ocamlgraph/files/digest-ocamlgraph-0.99b
@@ -0,0 +1,3 @@
+MD5 21c2b980fc541d6a277f73263b322772 ocamlgraph-0.99b.tar.gz 175958
+RMD160 72f48b2f89b2dd9025326c2ec7f7f60291b5ac95 ocamlgraph-0.99b.tar.gz 175958
+SHA256 c4a646cfd152791268d9c2716c5e1c55bf3f39e8637a85f3c3937e3dd4dafec7 ocamlgraph-0.99b.tar.gz 175958
diff --git a/dev-ml/ocamlgraph/files/ocamlgraph-0.99b-installfindlib.patch b/dev-ml/ocamlgraph/files/ocamlgraph-0.99b-installfindlib.patch
new file mode 100644
index 000000000000..5c68c0c15a2d
--- /dev/null
+++ b/dev-ml/ocamlgraph/files/ocamlgraph-0.99b-installfindlib.patch
@@ -0,0 +1,21 @@
+Index: ocamlgraph-0.99b/Makefile.in
+===================================================================
+--- ocamlgraph-0.99b.orig/Makefile.in
++++ ocamlgraph-0.99b/Makefile.in
+@@ -208,10 +208,14 @@ install-byte:
+ install-opt: install-byte
+ cp -f graph$(LIBEXT) graph.cmx $(CMXA) "$(OCAMLLIB)"
+
++ifneq ($(OCAMLOPT),no)
++INSTALL_OPT=graph$(LIBEXT) graph.cmx $(CMXA)
++endif
++
+ install-findlib: META
+ ifdef OCAMLFIND
+- $(OCAMLFIND) install ocamlgraph META *.mli \
+- graph$(LIBEXT) graph.cmx graph.cmo graph.cmi $(CMA) $(CMXA)
++ $(OCAMLFIND) install ocamlgraph META src/*.mli lib/*.mli \
++ $(INSTALL_OPT) graph.cmo graph.cmi $(CMA)
+ endif
+
+ # documentation
diff --git a/dev-ml/ocamlgraph/ocamlgraph-0.99b.ebuild b/dev-ml/ocamlgraph/ocamlgraph-0.99b.ebuild
new file mode 100644
index 000000000000..3fd7912ac7af
--- /dev/null
+++ b/dev-ml/ocamlgraph/ocamlgraph-0.99b.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlgraph/ocamlgraph-0.99b.ebuild,v 1.1 2008/01/04 01:27:16 aballier Exp $
+
+inherit findlib eutils
+
+EAPI="1"
+
+DESCRIPTION="O'Caml Graph library"
+HOMEPAGE="http://www.lri.fr/~filliatr/ocamlgraph/"
+SRC_URI="http://www.lri.fr/~filliatr/ftp/ocamlgraph/${P}.tar.gz"
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+DEPEND=">=dev-lang/ocaml-3.08
+ doc? ( dev-tex/hevea dev-ml/ocamlweb )
+ gtk? ( dev-ml/lablgtk )"
+IUSE="doc examples gtk +ocamlopt"
+
+ocamlgraph_need_use() {
+ if ! built_with_use --missing true $1 $2; then
+ eerror "In order to build ${PN} with your useflags you first need to build $1 with $2 useflag"
+ die "Please install $1 with $2 useflag"
+ fi
+}
+
+pkg_setup() {
+ use ocamlopt && ocamlgraph_need_use 'dev-lang/ocaml' ocamlopt
+ use gtk && ocamlgraph_need_use 'dev-ml/lablgtk' gnomecanvas
+ use ocamlopt && use gtk && ocamlgraph_need_use 'dev-lang/lablgtk' ocamlopt
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-installfindlib.patch"
+}
+
+src_compile() {
+ econf
+ emake -j1 || die "failed to build"
+
+ if use doc; then
+ emake doc || die "making documentation failed"
+ fi
+ if use gtk; then
+ emake -j1 editor || die "compiling editor failed"
+ fi
+}
+
+src_install() {
+ findlib_src_preinst
+ emake install-findlib || die "make install failed"
+
+ if use gtk; then
+ if use ocamlopt; then
+ newbin editor/editor.opt ocamlgraph_editor || die "failed to install ocamlgraph_editor"
+ else
+ newbin editor/editor.byte ocamlgraph_editor || die "failed to install ocamlgraph_editor"
+ fi
+ fi
+ dodoc README CREDITS FAQ CHANGES
+ if use doc; then
+ dohtml doc/*
+ fi
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}