summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-01-26 13:51:24 +0000
committerAlexis Ballier <aballier@gentoo.org>2015-01-26 13:51:24 +0000
commite4186575a2c4d74a43e39cd65044eef2cc4887a5 (patch)
tree1ed5d37f9de538b88a69dce1bf007c6faa836888 /dev-ml
parentRemove old. (diff)
downloadgentoo-2-e4186575a2c4d74a43e39cd65044eef2cc4887a5.tar.gz
gentoo-2-e4186575a2c4d74a43e39cd65044eef2cc4887a5.tar.bz2
gentoo-2-e4186575a2c4d74a43e39cd65044eef2cc4887a5.zip
version bump
Signed-off-by: aballier@gentoo.org (Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/dose3/ChangeLog9
-rw-r--r--dev-ml/dose3/dose3-3.3.ebuild58
2 files changed, 65 insertions, 2 deletions
diff --git a/dev-ml/dose3/ChangeLog b/dev-ml/dose3/ChangeLog
index ae26a8c0299a..13d19c18b23d 100644
--- a/dev-ml/dose3/ChangeLog
+++ b/dev-ml/dose3/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/dose3
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/dose3/ChangeLog,v 1.5 2014/11/28 17:55:09 aballier Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/dose3/ChangeLog,v 1.6 2015/01/26 13:51:24 aballier Exp $
+
+*dose3-3.3 (26 Jan 2015)
+
+ 26 Jan 2015; Alexis Ballier <aballier@gentoo.org> +dose3-3.3.ebuild:
+ version bump
28 Nov 2014; Alexis Ballier <aballier@gentoo.org> dose3-3.3_beta2-r2.ebuild:
update deps for ocaml 4.02
diff --git a/dev-ml/dose3/dose3-3.3.ebuild b/dev-ml/dose3/dose3-3.3.ebuild
new file mode 100644
index 000000000000..aad1ebc6a12a
--- /dev/null
+++ b/dev-ml/dose3/dose3-3.3.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/dose3/dose3-3.3.ebuild,v 1.1 2015/01/26 13:51:24 aballier Exp $
+
+EAPI=5
+
+MY_P="${P/_beta/-beta}"
+DESCRIPTION="Library and a collection of tools to perform la large spectrum of analysis on package repositories"
+HOMEPAGE="http://dose.gforge.inria.fr/public_html/"
+SRC_URI="https://gforge.inria.fr/frs/download.php/file/34277/${MY_P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt +parmap zip bzip2 xml curl rpm4 test"
+
+RDEPEND="
+ >=dev-lang/ocaml-3.12:=[ocamlopt?]
+ dev-ml/cudf:=
+ dev-ml/extlib:=
+ dev-ml/ocaml-re:=
+ || ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )
+ parmap? ( dev-ml/parmap:= )
+ zip? ( dev-ml/camlzip:= )
+ bzip2? ( dev-ml/camlbz2:= )
+ >=dev-ml/ocamlgraph-1.8.5:=
+ xml? ( dev-ml/ocaml-expat:= dev-ml/xml-light:= )
+ curl? ( dev-ml/ocurl:= )
+ rpm4? ( app-arch/rpm )
+"
+DEPEND="${RDEPEND}
+ dev-ml/findlib
+ test? ( dev-python/pyyaml[libyaml] )
+"
+# missing test data
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ sed -e 's/INSTALLOPTS=-s/INSTALLOPTS=/' -i Makefile.config.in || die
+}
+
+src_configure() {
+ econf \
+ $(use ocamlopt || echo "--with-bytecodeonly") \
+ $(use parmap && echo "--with-parmap") \
+ $(use zip && echo "--with-zip") \
+ $(use bzip2 && echo "--with-bz2") \
+ --with-ocamlgraph \
+ $(use xml && echo "--with-xml") \
+ $(use curl && echo "--with-curl") \
+ $(use rpm4 && echo "--with-rpm4")
+}
+
+src_compile() {
+ emake -j1
+}