summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2014-07-30 12:31:34 +0000
committerMikle Kolyada <zlogene@gentoo.org>2014-07-30 12:31:34 +0000
commit356413099fc56060bfe14bd9524fd9c8aebe35b2 (patch)
treea6b5ba0770d1cb5dc916b3a3240370e23155fd93 /dev-perl/Alien-SDL
parentStable on amd64 and x64. Adds a minor DMA fix over the previous verions. (diff)
downloadgentoo-2-356413099fc56060bfe14bd9524fd9c8aebe35b2.tar.gz
gentoo-2-356413099fc56060bfe14bd9524fd9c8aebe35b2.tar.bz2
gentoo-2-356413099fc56060bfe14bd9524fd9c8aebe35b2.zip
Respect CC, thanks to Jer (bug #518576)
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xC42EB5D6)
Diffstat (limited to 'dev-perl/Alien-SDL')
-rw-r--r--dev-perl/Alien-SDL/Alien-SDL-1.440.0.ebuild10
-rw-r--r--dev-perl/Alien-SDL/Alien-SDL-1.444.0.ebuild10
-rw-r--r--dev-perl/Alien-SDL/ChangeLog6
3 files changed, 19 insertions, 7 deletions
diff --git a/dev-perl/Alien-SDL/Alien-SDL-1.440.0.ebuild b/dev-perl/Alien-SDL/Alien-SDL-1.440.0.ebuild
index f425e0d46ecf..c258c48a5115 100644
--- a/dev-perl/Alien-SDL/Alien-SDL-1.440.0.ebuild
+++ b/dev-perl/Alien-SDL/Alien-SDL-1.440.0.ebuild
@@ -1,18 +1,17 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Alien-SDL/Alien-SDL-1.440.0.ebuild,v 1.2 2014/07/29 14:32:51 zlogene Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Alien-SDL/Alien-SDL-1.440.0.ebuild,v 1.3 2014/07/30 12:31:34 zlogene Exp $
EAPI=5
MODULE_AUTHOR=FROGGS
MODULE_VERSION=1.440
-inherit perl-module
+inherit perl-module toolchain-funcs
DESCRIPTION="building, finding and using SDL binaries"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~x86"
-IUSE=""
# Archive::Extract, File::Fetch, File::Find, Test::More -> dev-lang/perl
RDEPEND="dev-perl/Archive-Zip
@@ -32,3 +31,8 @@ DEPEND=${RDEPEND}
SRC_TEST=do
myconf='--with-sdl-config'
+
+src_prepare() {
+ tc-export CC
+ perl-module_src_prepare
+}
diff --git a/dev-perl/Alien-SDL/Alien-SDL-1.444.0.ebuild b/dev-perl/Alien-SDL/Alien-SDL-1.444.0.ebuild
index b04f34ff7c9e..483d08df282a 100644
--- a/dev-perl/Alien-SDL/Alien-SDL-1.444.0.ebuild
+++ b/dev-perl/Alien-SDL/Alien-SDL-1.444.0.ebuild
@@ -1,18 +1,17 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Alien-SDL/Alien-SDL-1.444.0.ebuild,v 1.1 2014/07/29 14:32:51 zlogene Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Alien-SDL/Alien-SDL-1.444.0.ebuild,v 1.2 2014/07/30 12:31:34 zlogene Exp $
EAPI=5
MODULE_AUTHOR=FROGGS
MODULE_VERSION=1.444
-inherit perl-module
+inherit perl-module toolchain-funcs
DESCRIPTION="building, finding and using SDL binaries"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~x86"
-IUSE=""
# Archive::Extract, File::Fetch, File::Find, Test::More -> dev-lang/perl
RDEPEND="dev-perl/Archive-Zip
@@ -30,5 +29,10 @@ RDEPEND="dev-perl/Archive-Zip
virtual/perl-File-Temp"
DEPEND=${RDEPEND}
+src_prepare() {
+ tc-export CC
+ perl-module_src_prepare
+}
+
SRC_TEST=do
myconf='--with-sdl-config'
diff --git a/dev-perl/Alien-SDL/ChangeLog b/dev-perl/Alien-SDL/ChangeLog
index 2724e24f527c..3e14c2117242 100644
--- a/dev-perl/Alien-SDL/ChangeLog
+++ b/dev-perl/Alien-SDL/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-perl/Alien-SDL
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Alien-SDL/ChangeLog,v 1.20 2014/07/29 14:32:51 zlogene Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Alien-SDL/ChangeLog,v 1.21 2014/07/30 12:31:34 zlogene Exp $
+
+ 30 Jul 2014; Mikle Kolyada <zlogene@gentoo.org> Alien-SDL-1.440.0.ebuild,
+ Alien-SDL-1.444.0.ebuild:
+ Respect CC, thanks to Jer (bug #518576)
*Alien-SDL-1.444.0 (29 Jul 2014)