summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2010-05-06 07:18:56 +0000
committerTorsten Veller <tove@gentoo.org>2010-05-06 07:18:56 +0000
commite366961c0989b45fe0ac8f2b94216493adae23fb (patch)
tree674efce641380ed56ef3183977a0e96eec79588f /dev-perl/Finance-Quote
parentStable on x86 and amd64 (#318311) (diff)
downloadgentoo-2-e366961c0989b45fe0ac8f2b94216493adae23fb.tar.gz
gentoo-2-e366961c0989b45fe0ac8f2b94216493adae23fb.tar.bz2
gentoo-2-e366961c0989b45fe0ac8f2b94216493adae23fb.zip
Add VWD patch. Thanks to Thomas.Eschenbacher (#318491). Cleanup
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl/Finance-Quote')
-rw-r--r--dev-perl/Finance-Quote/ChangeLog8
-rw-r--r--dev-perl/Finance-Quote/Finance-Quote-1.17-r1.ebuild (renamed from dev-perl/Finance-Quote/Finance-Quote-1.16.ebuild)9
-rw-r--r--dev-perl/Finance-Quote/files/VWD.pm.diff13
3 files changed, 25 insertions, 5 deletions
diff --git a/dev-perl/Finance-Quote/ChangeLog b/dev-perl/Finance-Quote/ChangeLog
index b352dbb74259..299b262592e1 100644
--- a/dev-perl/Finance-Quote/ChangeLog
+++ b/dev-perl/Finance-Quote/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/Finance-Quote
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Finance-Quote/ChangeLog,v 1.59 2010/04/18 17:03:53 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Finance-Quote/ChangeLog,v 1.60 2010/05/06 07:18:56 tove Exp $
+
+*Finance-Quote-1.17-r1 (06 May 2010)
+
+ 06 May 2010; Torsten Veller <tove@gentoo.org> -Finance-Quote-1.16.ebuild,
+ +Finance-Quote-1.17-r1.ebuild, +files/VWD.pm.diff:
+ Add VWD patch. Thanks to Thomas.Eschenbacher (#318491). Cleanup
18 Apr 2010; <nixnut@gentoo.org> Finance-Quote-1.17.ebuild:
ppc stable #311337
diff --git a/dev-perl/Finance-Quote/Finance-Quote-1.16.ebuild b/dev-perl/Finance-Quote/Finance-Quote-1.17-r1.ebuild
index f91c7f0aea33..eab69e3e880b 100644
--- a/dev-perl/Finance-Quote/Finance-Quote-1.16.ebuild
+++ b/dev-perl/Finance-Quote/Finance-Quote-1.17-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Finance-Quote/Finance-Quote-1.16.ebuild,v 1.6 2009/05/20 17:54:30 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Finance-Quote/Finance-Quote-1.17-r1.ebuild,v 1.1 2010/05/06 07:18:56 tove Exp $
-EAPI=2
+EAPI=3
MODULE_AUTHOR=ECOCODE
inherit perl-module
@@ -11,7 +11,7 @@ DESCRIPTION="Get stock and mutual fund quotes from various exchanges"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 ia64 ppc sparc x86"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
IUSE=""
DEPEND="dev-perl/libwww-perl
@@ -22,3 +22,4 @@ RDEPEND="${DEPEND}"
SRC_TEST="do"
mydoc="TODO"
+PATCHES=( "${FILESDIR}"/VWD.pm.diff )
diff --git a/dev-perl/Finance-Quote/files/VWD.pm.diff b/dev-perl/Finance-Quote/files/VWD.pm.diff
new file mode 100644
index 000000000000..3edab6fb5cf1
--- /dev/null
+++ b/dev-perl/Finance-Quote/files/VWD.pm.diff
@@ -0,0 +1,13 @@
+--- lib/Finance/Quote/VWD.pm
++++ lib/Finance/Quote/VWD.pm
+@@ -122,8 +122,8 @@
+ );
+ next if not $content;
+
+- # <h1> contains price, time, name, and symbol
+- my $head = $content->find("h1");
++ # <h2> contains price, time, name, and symbol
++ my $head = $content->find("h2");
+ next if not $head;
+
+ my $wpkurs = $head->look_down(