summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2011-08-30 14:07:07 +0000
committerTorsten Veller <tove@gentoo.org>2011-08-30 14:07:07 +0000
commitbe48d574576821bd55259f79c943dce1edcf5212 (patch)
treec17730f59be2ced59c254858e5b2ad2da56a0bdf /dev-perl/HTML-Mason
parentChange version scheme (diff)
downloadgentoo-2-be48d574576821bd55259f79c943dce1edcf5212.tar.gz
gentoo-2-be48d574576821bd55259f79c943dce1edcf5212.tar.bz2
gentoo-2-be48d574576821bd55259f79c943dce1edcf5212.zip
Change version scheme
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl/HTML-Mason')
-rw-r--r--dev-perl/HTML-Mason/ChangeLog7
-rw-r--r--dev-perl/HTML-Mason/HTML-Mason-1.450.0.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/dev-perl/HTML-Mason/ChangeLog b/dev-perl/HTML-Mason/ChangeLog
index 6d5cc4ba258b..5a7d2cc01cfe 100644
--- a/dev-perl/HTML-Mason/ChangeLog
+++ b/dev-perl/HTML-Mason/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/HTML-Mason
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/HTML-Mason/ChangeLog,v 1.97 2011/06/19 15:50:32 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/HTML-Mason/ChangeLog,v 1.98 2011/08/30 14:07:07 tove Exp $
+
+*HTML-Mason-1.450.0 (30 Aug 2011)
+
+ 30 Aug 2011; Torsten Veller <tove@gentoo.org> +HTML-Mason-1.450.0.ebuild:
+ Change version scheme
19 Jun 2011; Raúl Porcel <armin76@gentoo.org> HTML-Mason-1.42.ebuild,
HTML-Mason-1.45.ebuild:
diff --git a/dev-perl/HTML-Mason/HTML-Mason-1.450.0.ebuild b/dev-perl/HTML-Mason/HTML-Mason-1.450.0.ebuild
new file mode 100644
index 000000000000..cf5d7c9a0470
--- /dev/null
+++ b/dev-perl/HTML-Mason/HTML-Mason-1.450.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/HTML-Mason/HTML-Mason-1.450.0.ebuild,v 1.1 2011/08/30 14:07:07 tove Exp $
+
+EAPI=4
+
+MODULE_AUTHOR=DROLSKY
+MODULE_VERSION=1.45
+inherit depend.apache perl-module
+
+DESCRIPTION="A HTML development and delivery Perl Module"
+HOMEPAGE="http://www.masonhq.com/ ${HOMEPAGE}"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="modperl doc test"
+
+RDEPEND="!modperl? ( virtual/perl-CGI )
+ modperl? (
+ www-apache/libapreq2
+ >=www-apache/mod_perl-2
+ )
+ >=dev-perl/Params-Validate-0.7
+ >=dev-perl/Class-Container-0.08
+ >=dev-perl/Exception-Class-1.15
+ dev-perl/HTML-Parser
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-File-Spec
+ >=dev-perl/Cache-Cache-1.01
+ dev-perl/Log-Any"
+
+DEPEND="${RDEPEND}
+ virtual/perl-Module-Build
+ test? ( dev-perl/Test-Deep )"
+
+want_apache2 modperl
+
+SRC_TEST="do"
+mydoc="CREDITS UPGRADE"
+myconf="--noprompts"
+
+pkg_setup() {
+ depend.apache_pkg_setup modperl
+ perl-module_pkg_setup
+}
+
+perl-module_src_prep() {
+ # Note about new modperl use flag
+ if use !modperl ; then
+ ewarn "HTML-Mason will only install with modperl support"
+ ewarn "if the use flag modperl is enabled."
+ sleep 5
+ fi
+ # rendhalver - needed to set an env var for the build script so it finds our apache.
+ APACHE="${APACHE_BIN}" perl "${S}"/Build.PL installdirs=vendor destdir="${D}" ${myconf}
+}
+
+src_install () {
+ perl-module_src_install
+ # rendhalver - the html docs have subdirs so this gets all of them
+ use doc && dohtml -r htdocs/*
+}