summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2007-03-30 20:09:17 +0000
committerMichael Cummings <mcummings@gentoo.org>2007-03-30 20:09:17 +0000
commitd14b6821e1c2c5c285ad31e3f51a7acc4f1aeaf1 (patch)
treef52ab242c1a6f3f29206db7b7599a57de0f54a78 /dev-perl/Inline-Java
parentDropped ppc-macos keyword, see you in prefix (diff)
downloadgentoo-2-d14b6821e1c2c5c285ad31e3f51a7acc4f1aeaf1.tar.gz
gentoo-2-d14b6821e1c2c5c285ad31e3f51a7acc4f1aeaf1.tar.bz2
gentoo-2-d14b6821e1c2c5c285ad31e3f51a7acc4f1aeaf1.zip
bug 169288
(Portage version: 2.1.2.2)
Diffstat (limited to 'dev-perl/Inline-Java')
-rw-r--r--dev-perl/Inline-Java/ChangeLog6
-rw-r--r--dev-perl/Inline-Java/Inline-Java-0.50.ebuild14
-rw-r--r--dev-perl/Inline-Java/Inline-Java-0.51.ebuild13
-rw-r--r--dev-perl/Inline-Java/Inline-Java-0.52.ebuild13
4 files changed, 39 insertions, 7 deletions
diff --git a/dev-perl/Inline-Java/ChangeLog b/dev-perl/Inline-Java/ChangeLog
index b68c2208e930..5d7ed018992d 100644
--- a/dev-perl/Inline-Java/ChangeLog
+++ b/dev-perl/Inline-Java/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-perl/Inline-Java
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Inline-Java/ChangeLog,v 1.10 2007/01/21 19:15:20 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Inline-Java/ChangeLog,v 1.11 2007/03/30 20:09:17 mcummings Exp $
+
+ 30 Mar 2007; Michael Cummings <mcummings@gentoo.org>
+ Inline-Java-0.50.ebuild, Inline-Java-0.51.ebuild, Inline-Java-0.52.ebuild:
+ bug 169288
*Inline-Java-0.52 (21 Jan 2007)
diff --git a/dev-perl/Inline-Java/Inline-Java-0.50.ebuild b/dev-perl/Inline-Java/Inline-Java-0.50.ebuild
index a7468f9c4c65..38b4f41adae3 100644
--- a/dev-perl/Inline-Java/Inline-Java-0.50.ebuild
+++ b/dev-perl/Inline-Java/Inline-Java-0.50.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Inline-Java/Inline-Java-0.50.ebuild,v 1.7 2007/01/21 19:15:20 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Inline-Java/Inline-Java-0.50.ebuild,v 1.8 2007/03/30 20:09:17 mcummings Exp $
inherit perl-module
@@ -18,9 +18,19 @@ SRC_TEST="do"
DEPEND=">=dev-perl/Inline-0.44
>=virtual/perl-Test-1.13
- >=virtual/jdk-1.4
+ >=virtual/jdk-1.4
+ dev-java/java-config
dev-lang/perl"
myconf="J2SDK=$JAVA_HOME"
mymake="java all"
+pkg_setup() {
+ if [ $(java-config -O | grep jdk ) ]; then
+ true
+ else
+ eerror "Please use java-config -S to set your system vm to a JDK"
+ die "Active VM is not a JDK"
+ fi
+}
+
diff --git a/dev-perl/Inline-Java/Inline-Java-0.51.ebuild b/dev-perl/Inline-Java/Inline-Java-0.51.ebuild
index 8b535d9f1110..76c29c60eec6 100644
--- a/dev-perl/Inline-Java/Inline-Java-0.51.ebuild
+++ b/dev-perl/Inline-Java/Inline-Java-0.51.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Inline-Java/Inline-Java-0.51.ebuild,v 1.5 2007/01/21 19:15:20 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Inline-Java/Inline-Java-0.51.ebuild,v 1.6 2007/03/30 20:09:17 mcummings Exp $
inherit perl-module
@@ -18,9 +18,18 @@ SRC_TEST="do"
DEPEND=">=dev-perl/Inline-0.44
>=virtual/perl-Test-1.13
- >=virtual/jdk-1.4
+ >=virtual/jdk-1.4
+ dev-java/java-config
dev-lang/perl"
myconf="J2SDK=$JAVA_HOME"
mymake="java all"
+pkg_setup() {
+ if [ $(java-config -O | grep jdk ) ]; then
+ true
+ else
+ eerror "Please use java-config -S to set your system vm to a JDK"
+ die "Active VM is not a JDK"
+ fi
+}
diff --git a/dev-perl/Inline-Java/Inline-Java-0.52.ebuild b/dev-perl/Inline-Java/Inline-Java-0.52.ebuild
index f53ddfa46768..bb034da63f28 100644
--- a/dev-perl/Inline-Java/Inline-Java-0.52.ebuild
+++ b/dev-perl/Inline-Java/Inline-Java-0.52.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Inline-Java/Inline-Java-0.52.ebuild,v 1.1 2007/01/21 19:15:20 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Inline-Java/Inline-Java-0.52.ebuild,v 1.2 2007/03/30 20:09:17 mcummings Exp $
inherit perl-module
@@ -18,9 +18,18 @@ SRC_TEST="do"
DEPEND=">=dev-perl/Inline-0.44
>=virtual/perl-Test-1.13
- >=virtual/jdk-1.4
+ >=virtual/jdk-1.4
+ dev-java/java-config
dev-lang/perl"
myconf="J2SDK=$JAVA_HOME"
mymake="java all"
+pkg_setup() {
+ if [ $(java-config -O | grep jdk ) ]; then
+ true
+ else
+ eerror "Please use java-config -S to set your system vm to a JDK"
+ die "Active VM is not a JDK"
+ fi
+}