summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2012-02-28 16:32:23 +0000
committerTorsten Veller <tove@gentoo.org>2012-02-28 16:32:23 +0000
commit68ffc17bedcd765a31a2ac1910b22725daeeec98 (patch)
tree8f5029d2de1ab5333373d462c07db1a81f594546 /dev-perl/Perlbal/Perlbal-1.800.0.ebuild
parentnet-mail/notmuch: Support for Ruby bindings is removed. Rels bug #405429. (diff)
downloadgentoo-2-68ffc17bedcd765a31a2ac1910b22725daeeec98.tar.gz
gentoo-2-68ffc17bedcd765a31a2ac1910b22725daeeec98.tar.bz2
gentoo-2-68ffc17bedcd765a31a2ac1910b22725daeeec98.zip
[bump] dev-perl/Perlbal-1.800.0
(Portage version: 2.2.0_alpha89/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl/Perlbal/Perlbal-1.800.0.ebuild')
-rw-r--r--dev-perl/Perlbal/Perlbal-1.800.0.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-perl/Perlbal/Perlbal-1.800.0.ebuild b/dev-perl/Perlbal/Perlbal-1.800.0.ebuild
new file mode 100644
index 000000000000..c198668c4f9f
--- /dev/null
+++ b/dev-perl/Perlbal/Perlbal-1.800.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Perlbal/Perlbal-1.800.0.ebuild,v 1.1 2012/02/28 16:32:23 tove Exp $
+
+EAPI=4
+
+MODULE_AUTHOR=DORMANDO
+MODULE_VERSION=1.80
+inherit perl-module
+
+DESCRIPTION="Reverse-proxy load balancer and webserver"
+HOMEPAGE="http://www.danga.com/perlbal/"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-perl/libwww-perl
+ dev-perl/HTTP-Date
+ dev-perl/Sys-Syscall
+ >=dev-perl/Danga-Socket-1.440.0
+ dev-perl/HTTP-Message
+ dev-perl/BSD-Resource
+ dev-perl/IO-AIO
+"
+DEPEND="${RDEPEND}"
+
+#SRC_TEST="do" # testing not available on Perlbal yet ;-)
+
+PATCHES=( "${FILESDIR}/${PN}-1.58-Use-saner-name-in-process-listing.patch" )
+
+src_install() {
+ perl-module_src_install || die "perl-module_src_install failed"
+ cd "${S}"
+ dodoc doc/*.txt
+ docinto hacking
+ dodoc doc/hacking/*.txt
+ docinto conf
+ dodoc conf/*.{dat,conf}
+ keepdir /etc/perlbal
+ newinitd "${FILESDIR}"/perlbal_init.d_1.58 perlbal
+ newconfd "${FILESDIR}"/perlbal_conf.d_1.58 perlbal
+}
+
+pkg_postinst() {
+ einfo "Please see the example configuration files located"
+ einfo "within /usr/share/doc/${PF}/conf/"
+}