summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2012-11-24 07:33:22 +0000
committerTorsten Veller <tove@gentoo.org>2012-11-24 07:33:22 +0000
commit4af2ec1d230c21cf394226184797027efc9ec321 (patch)
tree36e95f29490fbf236a0be974a6d7fcaca07d487c /dev-perl/Sys-Virt
parentVersion bump. Add myself as maintainer. (diff)
downloadgentoo-2-4af2ec1d230c21cf394226184797027efc9ec321.tar.gz
gentoo-2-4af2ec1d230c21cf394226184797027efc9ec321.tar.bz2
gentoo-2-4af2ec1d230c21cf394226184797027efc9ec321.zip
[bump] dev-perl/Sys-Virt-1.0.0
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 0x5772769F4E046AEC)
Diffstat (limited to 'dev-perl/Sys-Virt')
-rw-r--r--dev-perl/Sys-Virt/ChangeLog7
-rw-r--r--dev-perl/Sys-Virt/Sys-Virt-1.0.0.ebuild31
2 files changed, 37 insertions, 1 deletions
diff --git a/dev-perl/Sys-Virt/ChangeLog b/dev-perl/Sys-Virt/ChangeLog
index a61a2d26c77f..8c9f6232abef 100644
--- a/dev-perl/Sys-Virt/ChangeLog
+++ b/dev-perl/Sys-Virt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/Sys-Virt
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Sys-Virt/ChangeLog,v 1.17 2012/10/07 09:06:35 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Sys-Virt/ChangeLog,v 1.18 2012/11/24 07:33:22 tove Exp $
+
+*Sys-Virt-1.0.0 (24 Nov 2012)
+
+ 24 Nov 2012; Torsten Veller <tove@gentoo.org> +Sys-Virt-1.0.0.ebuild:
+ Version bump
*Sys-Virt-0.10.2 (07 Oct 2012)
diff --git a/dev-perl/Sys-Virt/Sys-Virt-1.0.0.ebuild b/dev-perl/Sys-Virt/Sys-Virt-1.0.0.ebuild
new file mode 100644
index 000000000000..fc5636cb3f17
--- /dev/null
+++ b/dev-perl/Sys-Virt/Sys-Virt-1.0.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Sys-Virt/Sys-Virt-1.0.0.ebuild,v 1.1 2012/11/24 07:33:22 tove Exp $
+
+EAPI=4
+
+MODULE_AUTHOR=DANBERR
+MODULE_VERSION=1.0.0
+inherit perl-module
+
+DESCRIPTION="Sys::Virt provides an API for using the libvirt library from Perl"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=app-emulation/libvirt-${PV}"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? (
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage
+ dev-perl/XML-XPath
+ virtual/perl-Time-HiRes
+ )"
+
+SRC_TEST="do"
+
+src_compile() {
+ MAKEOPTS+=" -j1" perl-module_src_compile
+}