summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-03-30 06:35:44 +0000
committerJustin Lecher <jlec@gentoo.org>2010-03-30 06:35:44 +0000
commitee73ca325e2aee76074b95f6ff1f5a4f7a74d4f2 (patch)
treea6445bdd3e0671918dfe9accb5d42b099274e102 /dev-perl/WWW-Dict-Leo-Org
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-ee73ca325e2aee76074b95f6ff1f5a4f7a74d4f2.tar.gz
gentoo-2-ee73ca325e2aee76074b95f6ff1f5a4f7a74d4f2.tar.bz2
gentoo-2-ee73ca325e2aee76074b95f6ff1f5a4f7a74d4f2.zip
Added Postinst msg, Umlaut patch #311997, Added missing perl-core/DB_File to RDEPEND #311997
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl/WWW-Dict-Leo-Org')
-rw-r--r--dev-perl/WWW-Dict-Leo-Org/ChangeLog9
-rw-r--r--dev-perl/WWW-Dict-Leo-Org/WWW-Dict-Leo-Org-1.34-r2.ebuild35
-rw-r--r--dev-perl/WWW-Dict-Leo-Org/files/1.34-umlaut.patch41
3 files changed, 84 insertions, 1 deletions
diff --git a/dev-perl/WWW-Dict-Leo-Org/ChangeLog b/dev-perl/WWW-Dict-Leo-Org/ChangeLog
index 58614314a6e8..265e5f5f760e 100644
--- a/dev-perl/WWW-Dict-Leo-Org/ChangeLog
+++ b/dev-perl/WWW-Dict-Leo-Org/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-perl/WWW-Dict-Leo-Org
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/WWW-Dict-Leo-Org/ChangeLog,v 1.2 2010/02/12 16:12:14 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/WWW-Dict-Leo-Org/ChangeLog,v 1.3 2010/03/30 06:35:44 jlec Exp $
+
+*WWW-Dict-Leo-Org-1.34-r2 (30 Mar 2010)
+
+ 30 Mar 2010; Justin Lecher <jlec@gentoo.org> +files/1.34-umlaut.patch,
+ +WWW-Dict-Leo-Org-1.34-r2.ebuild:
+ Added Postinst msg, Umlaut patch #311997, Added missing perl-core/DB_File
+ to RDEPEND #311997
*WWW-Dict-Leo-Org-1.34-r1 (12 Feb 2010)
diff --git a/dev-perl/WWW-Dict-Leo-Org/WWW-Dict-Leo-Org-1.34-r2.ebuild b/dev-perl/WWW-Dict-Leo-Org/WWW-Dict-Leo-Org-1.34-r2.ebuild
new file mode 100644
index 000000000000..85fa841ccdc8
--- /dev/null
+++ b/dev-perl/WWW-Dict-Leo-Org/WWW-Dict-Leo-Org-1.34-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/WWW-Dict-Leo-Org/WWW-Dict-Leo-Org-1.34-r2.ebuild,v 1.1 2010/03/30 06:35:44 jlec Exp $
+
+EAPI="3"
+
+MODULE_AUTHOR="TLINDEN"
+inherit perl-app
+
+DESCRIPTION="commandline interface to http://dict.leo.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-lang/perl
+ dev-perl/HTML-TableParser
+ perl-core/DB_File"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-umlaut.patch
+}
+
+src_install() {
+ perl-module_src_install
+ mv "${D}"/usr/bin/{l,L}eo || die
+}
+
+pkg_postinst() {
+ elog "We renamed leo to Leo"
+ elog "due to conflicts with app-editors/leo"
+}
diff --git a/dev-perl/WWW-Dict-Leo-Org/files/1.34-umlaut.patch b/dev-perl/WWW-Dict-Leo-Org/files/1.34-umlaut.patch
new file mode 100644
index 000000000000..accce925e039
--- /dev/null
+++ b/dev-perl/WWW-Dict-Leo-Org/files/1.34-umlaut.patch
@@ -0,0 +1,41 @@
+From d70ba71c7a0173991cddf9a43b4855864294c203 Mon Sep 17 00:00:00 2001
+From: Slaven Rezic <slaven@rezic.de>
+Date: Fri, 12 Feb 2010 21:47:01 +0100
+Subject: [PATCH] added support for non-iso8859-1 terminals, see
+ https://rt.cpan.org/Public/Bug/Display.html?id=35543
+
+---
+ leo | 10 ++++++++++
+ 1 files changed, 10 insertions(+), 0 deletions(-)
+
+diff --git a/leo b/leo
+index f734249..e65c1b1 100755
+--- a/leo
++++ b/leo
+@@ -58,6 +58,8 @@ sub debug;
+
+ my($o_s, $o_m, $o_c, $o_l, $o_v, $o_h, $o_n, $o_f, $o_d, $o_u, $o_p);
+
++isatty(1) && eval q{ use open OUT => ':locale'};
++
+ #
+ # commandline options
+ #
+@@ -95,6 +97,14 @@ if (!$string) {
+ $string = <STDIN>;
+ chomp $string;
+ }
++if (eval { require I18N::Langinfo; require Encode; 1 }) {
++ my $codeset = I18N::Langinfo::langinfo(I18N::Langinfo::CODESET());
++ if ($codeset) {
++ for ($string) {
++ $_ = Encode::decode($codeset, $_);
++ }
++ }
++}
+
+ #
+ # open the config, if any
+--
+1.6.4.3
+