summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2009-08-22 22:41:36 +0000
committerTorsten Veller <tove@gentoo.org>2009-08-22 22:41:36 +0000
commitbfd6931607c11e666900455017e4f9bf325cc57b (patch)
treeea5318f7038087c6d98b9249e1275647c4342bbf /dev-perl/WWW-Mechanize
parentVersion bump (diff)
downloadgentoo-2-bfd6931607c11e666900455017e4f9bf325cc57b.tar.gz
gentoo-2-bfd6931607c11e666900455017e4f9bf325cc57b.tar.bz2
gentoo-2-bfd6931607c11e666900455017e4f9bf325cc57b.zip
Version bump
(Portage version: 2.2_rc39/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl/WWW-Mechanize')
-rw-r--r--dev-perl/WWW-Mechanize/ChangeLog7
-rw-r--r--dev-perl/WWW-Mechanize/WWW-Mechanize-1.60.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-perl/WWW-Mechanize/ChangeLog b/dev-perl/WWW-Mechanize/ChangeLog
index 310bd4498fd6..790e49160631 100644
--- a/dev-perl/WWW-Mechanize/ChangeLog
+++ b/dev-perl/WWW-Mechanize/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/WWW-Mechanize
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/WWW-Mechanize/ChangeLog,v 1.59 2009/07/15 18:38:06 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/WWW-Mechanize/ChangeLog,v 1.60 2009/08/22 22:41:36 tove Exp $
+
+*WWW-Mechanize-1.60 (22 Aug 2009)
+
+ 22 Aug 2009; Torsten Veller <tove@gentoo.org> +WWW-Mechanize-1.60.ebuild:
+ Version bump
*WWW-Mechanize-1.58 (15 Jul 2009)
diff --git a/dev-perl/WWW-Mechanize/WWW-Mechanize-1.60.ebuild b/dev-perl/WWW-Mechanize/WWW-Mechanize-1.60.ebuild
new file mode 100644
index 000000000000..bcb9c8b70991
--- /dev/null
+++ b/dev-perl/WWW-Mechanize/WWW-Mechanize-1.60.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/WWW-Mechanize/WWW-Mechanize-1.60.ebuild,v 1.1 2009/08/22 22:41:36 tove Exp $
+
+EAPI=2
+
+MODULE_AUTHOR=PETDANCE
+inherit perl-module
+
+DESCRIPTION="Handy web browsing in a Perl object"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="test"
+
+# Bug in the tests - improper use of HTTP::Server
+SRC_TEST="do"
+
+# configure to run the local tests, but not the ones which access the Internet
+myconf="--local --nolive"
+
+RDEPEND="dev-perl/IO-Socket-SSL
+ >=dev-perl/libwww-perl-5.829
+ >=dev-perl/URI-1.36
+ >=dev-perl/HTML-Parser-3.34
+ dev-perl/Test-LongString"
+DEPEND="${RDEPEND}
+ test? ( dev-perl/Test-Pod
+ dev-perl/Test-Taint
+ >=dev-perl/Test-Warn-0.11
+ dev-perl/Test-Memory-Cycle )"
+# dev-perl/HTTP-Server-Simple )"
+
+# Remove test until the bug is fixed:
+# http://rt.cpan.org/Public/Bug/Display.html?id=41673
+src_unpack() {
+ perl-module_src_unpack
+ mv "${S}"/t/cookies.t{,.disable} || die
+ sed -i "/cookies.t/d" "${S}/MANIFEST" || die
+}