summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-11-11 13:42:13 +0000
committerAchim Gottinger <achim@gentoo.org>2000-11-11 13:42:13 +0000
commit3999c55318eea955d98dc0e2c4dda565f1818b22 (patch)
treea65d0e9698b2a2b15d359c64ca3f4945d254e690 /dev-perl
parentAdded basic perl-modul support (diff)
downloadgentoo-2-3999c55318eea955d98dc0e2c4dda565f1818b22.tar.gz
gentoo-2-3999c55318eea955d98dc0e2c4dda565f1818b22.tar.bz2
gentoo-2-3999c55318eea955d98dc0e2c4dda565f1818b22.zip
*** empty log message ***
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/mod_perl/files/digest-mod_perl-1.24.11
-rw-r--r--dev-perl/mod_perl/mod_perl-1.24.1.ebuild50
-rw-r--r--dev-perl/mod_perl/mod_perl-1.24.ebuild15
3 files changed, 60 insertions, 6 deletions
diff --git a/dev-perl/mod_perl/files/digest-mod_perl-1.24.1 b/dev-perl/mod_perl/files/digest-mod_perl-1.24.1
new file mode 100644
index 000000000000..e38c44525e4c
--- /dev/null
+++ b/dev-perl/mod_perl/files/digest-mod_perl-1.24.1
@@ -0,0 +1 @@
+MD5 342ca7a4efaecab70b516c8e789a84e4 mod_perl-1.24_01.tar.gz
diff --git a/dev-perl/mod_perl/mod_perl-1.24.1.ebuild b/dev-perl/mod_perl/mod_perl-1.24.1.ebuild
new file mode 100644
index 000000000000..f42b000a2e4d
--- /dev/null
+++ b/dev-perl/mod_perl/mod_perl-1.24.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/mod_perl/mod_perl-1.24.1.ebuild,v 1.1 2000/11/11 13:38:18 achim Exp $
+
+P=mod_perl-1.24
+A=${P}_01.tar.gz
+S=${WORKDIR}/${P}_01
+CATEGORY="dev-perl"
+DESCRIPTION="A Perl Modul for Apache"
+SRC_URI="http://perl.apache.org/dist/${A}"
+HOMEPAGE="http://perl.apache.org"
+
+DEPEND=">=sys-libs/glibc-2.1.3
+ >=dev-perl/libwww-perl-5.48
+ >=dev-perl/HTML-Parser-3.13
+ >=dev-perl/URI-1.09
+ >=net-www/apache-ssl-1.3"
+
+src_compile() {
+
+ cd ${S}
+ perl Makefile.PL USE_APXS=1 \
+ WITH_APXS=/usr/sbin/apxs EVERYTHING=1
+ cp Makefile Makefile.orig
+ sed -e "s:apxs_install doc_install:doc_install:" Makefile.orig > Makefile
+ try make
+# cd src/modules/perl
+# apxs -c -I /usr/lib/perl5/5.6.0/i686-linux-thread-multi/CORE mod_perl.c
+}
+
+src_install () {
+
+ cd ${S}
+ try make PREFIX=${D}/usr install
+ cd apaci
+ insinto /usr/lib/apache
+ doins libperl.so
+ cd ${S}
+ dodoc Changes CREDITS MANIFEST README SUPPORT ToDo
+ dodoc faq/*.txt
+ docinto html
+ dodoc apache-modlist.html
+ dodoc htdocs/manual/mod/mod_perl.html
+
+
+}
+
+
+
diff --git a/dev-perl/mod_perl/mod_perl-1.24.ebuild b/dev-perl/mod_perl/mod_perl-1.24.ebuild
index e6ebcc8bec30..01b52c0c45cb 100644
--- a/dev-perl/mod_perl/mod_perl-1.24.ebuild
+++ b/dev-perl/mod_perl/mod_perl-1.24.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/mod_perl/mod_perl-1.24.ebuild,v 1.4 2000/11/04 12:54:30 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/mod_perl/mod_perl-1.24.ebuild,v 1.5 2000/11/11 13:37:50 achim Exp $
P=mod_perl-1.24
A=${P}.tar.gz
@@ -20,19 +20,22 @@ DEPEND=">=sys-libs/glibc-2.1.3
src_compile() {
cd ${S}
- perl Makefile.PL NO_HTTPD=1
+ perl Makefile.PL USE_APXS=1 \
+ WITH_APXS=/usr/sbin/apxs EVERYTHING=1
+ cp Makefile Makefile.orig
+ sed -e "s:apxs_install doc_install:doc_install:" Makefile.orig > Makefile
try make
- cd src/modules/perl
- apxs -c -I /usr/lib/perl5/5.6.0/i686-linux-thread-multi/CORE mod_perl.c
+# cd src/modules/perl
+# apxs -c -I /usr/lib/perl5/5.6.0/i686-linux-thread-multi/CORE mod_perl.c
}
src_install () {
cd ${S}
try make PREFIX=${D}/usr install
- cd src/modules/perl
+ cd apaci
insinto /usr/lib/apache
- doins mod_perl.so
+ doins libperl.so
cd ${S}
dodoc Changes CREDITS MANIFEST README SUPPORT ToDo
dodoc faq/*.txt