summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2010-06-11 22:34:17 +0000
committerMatti Bickel <mabi@gentoo.org>2010-06-11 22:34:17 +0000
commitbdd252b54f43b668cede909b7b6a76c2741d1441 (patch)
tree4836fd1888a8f379dbe94152b457dcb01aa97d8b /dev-php/PEAR-Console_Getopt
parentbump, remove old (diff)
downloadgentoo-2-bdd252b54f43b668cede909b7b6a76c2741d1441.tar.gz
gentoo-2-bdd252b54f43b668cede909b7b6a76c2741d1441.tar.bz2
gentoo-2-bdd252b54f43b668cede909b7b6a76c2741d1441.zip
eapi2
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-php/PEAR-Console_Getopt')
-rw-r--r--dev-php/PEAR-Console_Getopt/ChangeLog7
-rw-r--r--dev-php/PEAR-Console_Getopt/PEAR-Console_Getopt-1.2.3-r1.ebuild27
2 files changed, 33 insertions, 1 deletions
diff --git a/dev-php/PEAR-Console_Getopt/ChangeLog b/dev-php/PEAR-Console_Getopt/ChangeLog
index fb5fadea355f..b12ad9372feb 100644
--- a/dev-php/PEAR-Console_Getopt/ChangeLog
+++ b/dev-php/PEAR-Console_Getopt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php/PEAR-Console_Getopt
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-Console_Getopt/ChangeLog,v 1.23 2010/05/09 16:24:19 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-Console_Getopt/ChangeLog,v 1.24 2010/06/11 22:34:17 mabi Exp $
+
+*PEAR-Console_Getopt-1.2.3-r1 (11 Jun 2010)
+
+ 11 Jun 2010; <mabi@gentoo.org> +PEAR-Console_Getopt-1.2.3-r1.ebuild:
+ EAPI=2, update for php-5.3
09 May 2010; Raúl Porcel <armin76@gentoo.org>
PEAR-Console_Getopt-1.2.3.ebuild:
diff --git a/dev-php/PEAR-Console_Getopt/PEAR-Console_Getopt-1.2.3-r1.ebuild b/dev-php/PEAR-Console_Getopt/PEAR-Console_Getopt-1.2.3-r1.ebuild
new file mode 100644
index 000000000000..ac021013d703
--- /dev/null
+++ b/dev-php/PEAR-Console_Getopt/PEAR-Console_Getopt-1.2.3-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-Console_Getopt/PEAR-Console_Getopt-1.2.3-r1.ebuild,v 1.1 2010/06/11 22:34:17 mabi Exp $
+
+EAPI="2"
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Command-line option parser"
+
+LICENSE="PHP-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+SRC_URI="http://pear.php.net/get/${MY_P}.tgz"
+DEPEND="|| ( <dev-lang/php-5.3[pcre] >=dev-lang/php-5.3 )
+ >=dev-php/PEAR-PEAR-1.8.1"
+PDEPEND="dev-php/pear"
+HOMEPAGE="http://pear.php.net/package/Console_Getopt"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ insinto /usr/share/php/
+ doins -r Console
+}