summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2007-11-15 18:03:57 +0000
committerMarkus Ullmann <jokey@gentoo.org>2007-11-15 18:03:57 +0000
commit95ef6fac4d614fb3da0344fcb2476b5bb314660e (patch)
tree58a67d29debeae378026a5a955b2df6af4ded2e7 /dev-php/PEAR-Crypt_HMAC2/PEAR-Crypt_HMAC2-0.2.1.ebuild
parentyet another rev bump for security holes... bug #198238 and bug #193437 (diff)
downloadgentoo-2-95ef6fac4d614fb3da0344fcb2476b5bb314660e.tar.gz
gentoo-2-95ef6fac4d614fb3da0344fcb2476b5bb314660e.tar.bz2
gentoo-2-95ef6fac4d614fb3da0344fcb2476b5bb314660e.zip
Initial import from project overlay
(Portage version: 2.1.3.19)
Diffstat (limited to 'dev-php/PEAR-Crypt_HMAC2/PEAR-Crypt_HMAC2-0.2.1.ebuild')
-rw-r--r--dev-php/PEAR-Crypt_HMAC2/PEAR-Crypt_HMAC2-0.2.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-php/PEAR-Crypt_HMAC2/PEAR-Crypt_HMAC2-0.2.1.ebuild b/dev-php/PEAR-Crypt_HMAC2/PEAR-Crypt_HMAC2-0.2.1.ebuild
new file mode 100644
index 000000000000..4c9352c72a08
--- /dev/null
+++ b/dev-php/PEAR-Crypt_HMAC2/PEAR-Crypt_HMAC2-0.2.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-Crypt_HMAC2/PEAR-Crypt_HMAC2-0.2.1.ebuild,v 1.1 2007/11/15 18:03:56 jokey Exp $
+
+inherit php-pear-r1 depend.php
+
+DESCRIPTION="Implementation of Hashed Message Authentication Code for PHP5"
+LICENSE="PHP"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+need_php5
+
+pkg_postinst() {
+ has_php
+ local flags="hash mhash"
+ if ! PHPCHECKNODIE="yes" require_php_with_use ${flags} ; then
+ elog "${PN} can use the hash or mhash extensions when enabled to extend the range"
+ elog "of cryptographic hash functions beyond the natively implemented MD5 and SHA1."
+ elog "Recompile ${PHP_PKG} with ${flags} USE flags enabled if you want these features."
+ fi
+}